LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   GeForce 210 video tearing / artifacts with current stable (http://www.linuxquestions.org/questions/linux-hardware-18/geforce-210-video-tearing-artifacts-with-current-stable-819623/)

mrmnemo 07-13-2010 12:05 PM

GeForce 210 video tearing / artifacts with current stable
 
Hi.

I was just wondering if anyone is having issues such as i am. I set up a GeForce 210 over HDMI with audio. What appears to be happening is that the card is tearing on HD video sources. I did not have this issue when using the integrated nvidia card on the board ( 256 MB shared mem ). I am not sure what to check at this point.

dugan 07-13-2010 12:20 PM

If you're decoding and outputting using vdpau, then do you have the composite extension enabled? Check with xdpyinfo | grep -i composite. Many people have reported that the composite extension causes screen tearing with vdpau, and I can confirm that (I have a GT210 too). Turn it off.

Double-check that VSync is turned on in nvidia-settings too.

mrmnemo 07-18-2010 10:24 AM

Hi,

Sorry it took me so long to get back and let you know how it worked. the best compliment i can give you is that it worked!!!

I also wanted to post a few things to help anyone else that may run into similar issues.

I changed cards to a BFG GeForce 7950 gt OC pciExpress 512MB / winTV pc 1600:

Iwas unable to get the accelerated graphics working at first. Upon doing some research i found it was due to the nvidia card not being started up correctly at boot. This is caused by the winTV card grabbing to much memory. The fix that follows was found here.
In short, run
Code:

sudo nano /etc/defaults/grub
then add the following to the end of the line GRUB_CMDLINE_LINUX_DEFAULT
Code:

"quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap blacklist=nouveau vmalloc=256M"
next, update the system with
Code:

sudo update-grub2 && sudo update-initramfs && sudo nvidia-xconfig --no-composite
doing the above got my system to play true HD content with out tearing, running accelerated graphics, and booting ok.

thanks.


All times are GMT -5. The time now is 01:43 PM.