LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-17-2003, 04:11 AM   #1
phoezies
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Rep: Reputation: 0
GE Force4 mx440 install problems, can not create /dev/nvidia*


Pentium Celeron 1.7GHz
GE Force4 MX440
mdk9.1 kernel 2.4.21-0.13mdk

Just downloaded and install the latest driver version: 1.0-4496 but not working.

The installation log as follow :
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Oct 16 23:40:11 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
4496). As part of installing this driver (version: 1.0-4496), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> A precompiled kernel interface for kernel 'Mandrake Linux 9.1 kernel
2.4.21-0.13mdk i586' has been found.
executing: 'cd ./usr/src/nv; /usr/bin/ld -r -o nvidia.o precompiled-nv-linux
.o nv-kernel.o'...
-> Kernel module linked successfully.
-> Installing classic TLS OpenGL libraries.
-> Parsing log file:
-> done.
-> Validating previous installation:
-> done.
-> Uninstalling NVIDIA Accelerated Graphics Driver for Linux-x86 (1.0-4496):
-> done.
-> Uninstallation of existing driver: NVIDIA Accelerated Graphics Driver for
Linux-x86 (1.0-4496) is complete.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-4496):
executing: './usr/src/nv/makedevices.sh'...
executing: '/sbin/ldconfig'...
executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Sanity check passed.
-> Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
(version: 1.0-4496) is now complete. Please update your XF86Config file as
appropriate; see the file /usr/share/doc/NVIDIA_GLX-1.0/README for details.


And this is my XFree log :
XFree86 Version 4.3.0
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.21-0.13mdksmp i686 [ELF]
Build Date: 12 March 2003
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Oct 16 23:12:20 2003
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "layout1"
(**) |-->Screen "screen1" (0)
(**) | |-->Monitor "monitor1"
(**) | |-->Device "device1"
(**) |-->Input Device "Keyboard1"
(WW) Option "XkbCompat" requires an string value
(**) Option "XkbModel" "pc105"
(**) XKB: model: "pc105"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(WW) Option "XkbOptions" requires an string value
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Mouse1"
(**) FontPath set to "unix/:-1"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "AllowMouseOpenFail"
Using vt 7
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80010044, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,3148 card 1106,0000 rev 00 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,b091 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:09:0: chip 13f6,0111 card 13f6,0111 rev 10 class 04,01,00 hdr 00
(II) PCI: 00:10:0: chip 1106,3038 card 1106,3038 rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:1: chip 1106,3038 card 1106,3038 rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:2: chip 1106,3038 card 1106,3038 rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:3: chip 1106,3104 card 1106,3104 rev 82 class 0c,03,20 hdr 00
(II) PCI: 00:11:0: chip 1106,3177 card 1106,0000 rev 00 class 06,01,00 hdr 80
(II) PCI: 00:11:1: chip 1106,0571 card 1106,0571 rev 06 class 01,01,8a hdr 00
(II) PCI: 01:00:0: chip 10de,0171 card 0000,0000 rev a3 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000c (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xdde00000 - 0xdfefffff (0x2100000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xcdb00000 - 0xddcfffff (0x10200000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:17:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV17 [GeForce4 MX 440] rev 163, Mem @ 0xde000000/24, 0xd0000000/27, 0xddc80000/19, BIOS @ 0xdfee0000/17
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xe0000000 from 0xe3ffffff to 0xdfffffff
(II) Active PCI resource ranges:
[0] -1 0 0xdfffff00 - 0xdfffffff (0x100) MX[B]
[1] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[2] -1 0 0xdfee0000 - 0xdfefffff (0x20000) MX[B](B)
[3] -1 0 0xddc80000 - 0xddcfffff (0x80000) MX[B](B)
[4] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[5] -1 0 0xde000000 - 0xdeffffff (0x1000000) MX[B](B)
[6] -1 0 0x0000fc00 - 0x0000fc0f (0x10) IX[B]
[7] -1 0 0x0000e800 - 0x0000e81f (0x20) IX[B]
[8] -1 0 0x0000e400 - 0x0000e41f (0x20) IX[B]
[9] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[10] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xdfffff00 - 0xdfffffff (0x100) MX[B]
[1] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[2] -1 0 0xdfee0000 - 0xdfefffff (0x20000) MX[B](B)
[3] -1 0 0xddc80000 - 0xddcfffff (0x80000) MX[B](B)
[4] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[5] -1 0 0xde000000 - 0xdeffffff (0x1000000) MX[B](B)
[6] -1 0 0x0000fc00 - 0x0000fc0f (0x10) IX[B]
[7] -1 0 0x0000e800 - 0x0000e81f (0x20) IX[B]
[8] -1 0 0x0000e400 - 0x0000e41f (0x20) IX[B]
[9] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[10] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xdfffff00 - 0xdfffffff (0x100) MX[B]
[6] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[7] -1 0 0xdfee0000 - 0xdfefffff (0x20000) MX[B](B)
[8] -1 0 0xddc80000 - 0xddcfffff (0x80000) MX[B](B)
[9] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[10] -1 0 0xde000000 - 0xdeffffff (0x1000000) MX[B](B)
[11] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[12] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[13] -1 0 0x0000fc00 - 0x0000fc0f (0x10) IX[B]
[14] -1 0 0x0000e800 - 0x0000e81f (0x20) IX[B]
[15] -1 0 0x0000e400 - 0x0000e41f (0x20) IX[B]
[16] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[17] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "v4l"
(II) Loading /usr/X11R6/lib/modules/drivers/linux/v4l_drv.o
(II) Module v4l: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.0.1
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 2.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4496
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4496
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) v4l driver for Video4Linux
(II) NVIDIA XFree86 Driver 1.0-4496 Wed Jul 16 19:06:03 PDT 2003
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xdfffff00 - 0xdfffffff (0x100) MX[B]
[6] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[7] -1 0 0xdfee0000 - 0xdfefffff (0x20000) MX[B](B)
[8] -1 0 0xddc80000 - 0xddcfffff (0x80000) MX[B](B)
[9] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[10] -1 0 0xde000000 - 0xdeffffff (0x1000000) MX[B](B)
[11] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[12] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[13] -1 0 0x0000fc00 - 0x0000fc0f (0x10) IX[B]
[14] -1 0 0x0000e800 - 0x0000e81f (0x20) IX[B]
[15] -1 0 0x0000e400 - 0x0000e41f (0x20) IX[B]
[16] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[17] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xdfffff00 - 0xdfffffff (0x100) MX[B]
[6] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[7] -1 0 0xdfee0000 - 0xdfefffff (0x20000) MX[B](B)
[8] -1 0 0xddc80000 - 0xddcfffff (0x80000) MX[B](B)
[9] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[10] -1 0 0xde000000 - 0xdeffffff (0x1000000) MX[B](B)
[11] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[12] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[13] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[14] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[15] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[16] -1 0 0x0000fc00 - 0x0000fc0f (0x10) IX[B]
[17] -1 0 0x0000e800 - 0x0000e81f (0x20) IX[B]
[18] -1 0 0x0000e400 - 0x0000e41f (0x20) IX[B]
[19] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[20] -1 0 0x0000ec00 - 0x0000ecff (0x100) IX[B]
[21] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[22] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xD0000000
(--) NVIDIA(0): MMIO registers at 0xDE000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.




I have done the installation on procedure (change the nv to nvidia)
Looking at the Readme file, I came accross the following:

Problems will arise if applications use the wrong version of a library.
This can be the case if there are either old libGL libraries or stale
symlinks left lying around. If you think there may be something awry
in your installation, check that the following files are in place
(these are all the files of the NVIDIA Accelerated Linux Driver Set,
plus their symlinks):

/usr/X11R6/lib/modules/drivers/nvidia_drv.o

/usr/X11R6/lib/modules/extensions/libglx.so.x.y.z
/usr/X11R6/lib/modules/extensions/libglx.so -> libglx.so.x.y.z

/usr/lib/libGL.so.x.y.z
/usr/lib/libGL.so.x -> libGL.so.x.y.z
/usr/lib/libGL.so -> libGL.so.x

/usr/lib/libGLcore.so.x.y.z
/usr/lib/libGLcore.so.x -> libGLcore.so.x.y.z

/lib/modules/`uname -r`/video/NVdriver, or
/lib/modules/`uname -r`/kernel/drivers/video/NVdriver

Installation of the NVIDIA_kernel package will also create the /dev files:

crw-rw-rw- 1 root root 195, 0 Feb 15 17:21 nvidia0
crw-rw-rw- 1 root root 195, 1 Feb 15 17:21 nvidia1
crw-rw-rw- 1 root root 195, 2 Feb 15 17:21 nvidia2
crw-rw-rw- 1 root root 195, 3 Feb 15 17:21 nvidia3
crw-rw-rw- 1 root root 195, 255 Feb 15 17:21 nvidiactl

So I checked it out and found that not all file listed above are present on my system. Especially I can not find the nvidia* folder on my /dev.

Oh yeah... when I started X, the screen will fade for a couple seconds then back to console while saying no /dev/nvidia0 found. After that the system will hang. Even with raw booting method it wont work except to press the reset button.

Anybody know how to fix this?
How can I check whether i'm using wrong version library?
Should I create the nvidia0 folder manually?
Should I symlink some files above manually and if yes to where???
 
Old 10-17-2003, 05:03 AM   #2
IsNoGood
Member
 
Registered: Oct 2003
Posts: 67

Rep: Reputation: 15
Mandrake uses devfs - devices get created as needed.Creating a device wont help you there.Try modprobe nvidia or insmod nvidia and see if the module loads.
 
Old 10-17-2003, 05:16 AM   #3
phoezies
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Quoted from the readme file:

Q: My X server fails to start, and my XFree86 log file contains the error:

"(EE) NVIDIA(0): Failed to initialize the NVdriver kernel module!"

A: Nothing will work if the NVdriver kernel module doesn't function
properly. If you see anything in the X log file like "(EE) NVIDIA(0):
Failed to initialize the NVdriver kernel module!" then there is
most likely a problem with the NVdriver kernel module. First, you
should verify that if you installed from rpm that the rpm was built
specifically for the kernel you are using. You should also check
that the module is loaded ('/sbin/lsmod'); if it is not loaded try
loading it explicitly with 'insmod' or 'modprobe' (be sure to exit the
X server before installing a new kernel module). If you receive errors
about unresolved symbols, then the kernel module has most likely been
built using header files for a different kernel revision than what
you are running. You can explicitly control what kernel header files
are used by building NVdriver from the NVIDIA_kernel tar file with:
'make install SYSINCLUDE=/path/to/kernel/headers'.

Please note that the convention for the location of kernel
header files is in a state of transition, as is the location
of kernel modules. If the kernel module fails to load properly,
modprobe/insmod may be trying to load an older kernel module (assuming
you've upgraded). cd'ing into the directory with the new kernel
module and doing 'insmod ./NVdriver' may help.
-----------------------------------------------------------------------------------

Have tried it and Probing gives an error about unresolved symbols & still not loaded.
From what I understand on the above paragraph - I have to compile my kernel - which is something I scared of because I'm just a newbie. Is that right???
 
Old 10-17-2003, 05:22 AM   #4
IsNoGood
Member
 
Registered: Oct 2003
Posts: 67

Rep: Reputation: 15
You shouldn't have to recompile your kernel if you use a mandrake stock kernel.Do you got the kernel source installed? It's under /usr/src/linux.
 
Old 10-17-2003, 05:41 AM   #5
phoezies
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Yes I have the source installed..
have checked it via rpm -qi

Any other hints for me???
I know that I can just simply reinstall my linux box from scratch and install the driver on the first boot.. Maybe that will work perfectly, but i do believe there must be a way to solve this problem as long as I can log on.
 
Old 10-17-2003, 05:59 AM   #6
IsNoGood
Member
 
Registered: Oct 2003
Posts: 67

Rep: Reputation: 15
I didn't really think the source was missing - better save than sorry.Only other thing I could think of right now is what is in the manual you pasted above - cd to /lib/modules/yourkernel/video and try to do insmod nvidia in there.
I suppose you did all this without x running.
 
Old 10-17-2003, 06:10 AM   #7
phoezies
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Original Poster
Rep: Reputation: 0
ok will try it n give the reuslt tomorrow.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
help editing xf86config for nvidia geforce mx440 after installing nvidia driver linguist Linux - Newbie 11 06-13-2006 07:31 AM
Display far too dark in MOHAA NVIDIA MX440 Hecubus21 Linux - Software 0 10-20-2004 05:03 PM
NVIDIA GEFORCE4 MX440 and MANDRAKE 9.1 frog-newbie Linux - Hardware 4 09-10-2003 06:11 PM
Nvidia Geforce MX440-SE, Driving ME NUTS frog-newbie Linux - Hardware 2 09-07-2003 08:19 PM
NVIDIA Predator MX440 8X AGP - Linux shutdown during install Kdiver58 Linux - Hardware 1 05-30-2003 01:40 AM


All times are GMT -5. The time now is 10:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration