LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 04-26-2008, 08:19 PM   #1
Pinks2
LQ Newbie
 
Registered: Jul 2007
Posts: 11

Rep: Reputation: 0
"Frequency Out of Range" Error - ATI X800 - Catalyst 8.3/Ubuntu 8.04


I was hoping that with this release, the first having a graduated driver from ATI that has a lot more bells and whistles than the default Gutsy driver did, I was hoping that I wouldn't have any problems with my old ATI X800. But...I was wrong. I install the driver using the restricted driver manager, and then on reboot, I get this weird "Out of Range" error coming up on the monitor, leaving me unable to see much of anything, and I then have to reboot and I've just left my Ubuntu partition alone at this point. I try booting into recovery mode in Ubuntu, using the "Fix X server", but then I get a white screen after login screen. Then all I have left to do is a sudo dpkg-reconfigure xserver-xorg, and that has no 3D or any sort of acceleration at all. Any ideas at what I should do? Is there a way I can add resolutions to my xorg.conf before I reboot after I've installed my ATI drivers using restricted driver manager? Just, I'd like to know what I can do to get ubuntu up and running, cause I just want to completely switch over.

But...here's some other things, if it helps anyone. After I've installed my ATI driver and I've gotten the error again, I did ctrl+alt+f1, did cp /var/log/Xorg.0.log ~/Desktop, and did sudo dpkg-reconfigure xserver-xorg so I can see it. Did the same for my Xorg.conf as well.

Quote:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
Driver "fglrx"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection
My Xorg.0.log file can be found at http://ubuntuforums.org/showthread.p...51#post4816651

Last edited by Pinks2; 04-27-2008 at 07:06 PM.
 
Old 04-28-2008, 07:51 AM   #2
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
The following might work:

Add HorizSync and VertRefresh to the monitor section; values can be found in your monitor manual.
Add a line for UseEdidFreqs to the device section

Code:
Section "Monitor"
    Identifier     "Generic Monitor"
    HorizSync       27.0 - 96.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS"
EndSection
Code:
Section "Device"
    Identifier     "NVIDIA Corporation NV44 [GeForce 6200 TurboCache]"
    Driver         "nvidia"
    Option         "UseEdidFreqs" "False"
EndSection
The first change tell X which frequencies it can use; the last change tells it to ignore the VertRefresh and HorizSync that it retrieved from the monitor.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor Error "Out Of Frequency Range" GCZFFL Ubuntu 6 03-06-2007 05:22 AM
error "Set Frequency" (8b04) : when restarting rc.inet1 tux31337 Linux - Wireless Networking 1 02-13-2006 04:47 PM
FC4 Doesn't boot error: Signal Frequency is out of Range" tillotso Fedora 11 11-23-2005 08:44 AM
9.2 error message "Signal frequency is out of range" ? What to do? A6Quattro Suse/Novell 8 09-30-2005 09:59 PM
"Frequency out of Range" at boot mbegovic Fedora 4 06-16-2004 10:26 AM


All times are GMT -5. The time now is 01:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration