LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 05-18-2009, 02:31 AM   #1
swoq
LQ Newbie
 
Registered: May 2009
Location: Lithuania
Distribution: debian & ubuntu
Posts: 3

Rep: Reputation: 0
freeze with horizontal lines while loading Xorg


Hi,

what can bring this problem ??
kernel, Xorg, faulty graphics card?

during while init process, system is ok, splash screen works just fine, but when starting X (gdm), 7 of 8 times I see just horizontal black and white lines. keyboard stuck. only buttons working - power and reset.

while input is stuck, background processes work ok - I can ssh into this pc..

the 8th (not really counted, just "something about 8th time ") time Xorg does not freeze and I can use it just fine.

checked log files..
diff Xorg.0.log Xorg.0.log.old
brings nothing. At first it showed only that mouse used is different (/dev/input/even4 vs /dev/input/even5), but last time it was the same...

Also, in some places (e.g. firefox render screen), my mouse pointer is "dirty" (using transparent m.p.)

I guess kernel does work - since bg process are not stuck.
graphics card or Xorg ?? also - this happens NOT every time.. just 7/8


Also, noticed, that if I run StarUml in wine, the Xorg freezes too (this time no horz lines - the last screen used is left). only this program (so far) brings this. And if I press reset (not power off and on again), the SAME screen is stuck instead of lines (after reboot)!!!

using ubuntu jaunty, kernel 2.6.28-11-generic, Xorg 1.6.0 with nv driver

Thanks,
 
Old 05-18-2009, 09:11 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,477

Rep: Reputation: 87
You most likely have a hardware problem...

Also, have you tried using different color depths? I had this very same problem long ago on an old Trident 3DImage975 display card. It absolutely refused to run X in any color depth except 24bit - 16 or 32 caused those same horisontal lines you referred to - but it happend EACH time, not every eighth time.

Do you have Windows on that machine? If you boot into Windows, does it work?
 
Old 05-18-2009, 11:21 AM   #3
swoq
LQ Newbie
 
Registered: May 2009
Location: Lithuania
Distribution: debian & ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
Hi,

no, I dont have Windows.., as I too guess this is more HW related, I will have to wait a few days for another card to try.. I hope this error will be gone then.
It is really strange to me, that it works some times.. And there are no problems displaying bios or the splash screen (vga 791)..
ghmm, still working without reboot from the morning - no problems.. just that currently I'm quite afraid to turn it off

Also, will try changing color depth (later, when restarting X would be inevitable )
 
Old 05-21-2009, 04:15 PM   #4
Hern_28
Member
 
Registered: Mar 2007
Location: North Carolina
Distribution: Slackware 12.0, Gentoo, LFS, Debian, Kubuntu.
Posts: 906

Rep: Reputation: 38
Video card driver?

The nv driver starts my backup video card about like what you are describing. If you are using an older nvidia card I would check nvidia and see if you can get one of their older drivers.
 
Old 05-22-2009, 02:13 AM   #5
swoq
LQ Newbie
 
Registered: May 2009
Location: Lithuania
Distribution: debian & ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
broken hw

hi,

got my ati back - no more problems

so it was cards fault.. (or nv module as mentioned here )

Thanks
 
  


Reply

Tags
freezes, loading, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Splitting horizontal to verical...lines venki Linux - General 7 07-04-2007 11:24 AM
Horizontal Lines in Photos on HP 722c w/ CUPS rignes Linux - Hardware 0 10-11-2004 06:37 PM
Faint horizontal rolling lines sleepindawg Mandriva 2 07-05-2004 01:51 AM
horizontal lines on screen? svar Linux - General 8 07-12-2003 11:53 AM
Roving horizontal lines thomask Linux - Hardware 0 07-11-2003 04:41 AM


All times are GMT -5. The time now is 11:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration