LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-12-2008, 07:52 AM   #1
dxlr8r
LQ Newbie
 
Registered: Oct 2007
Posts: 9

Rep: Reputation: 0
Unhappy FPS drop in games with nvidia gpu


Hello. I have a Dell laptop with: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1), with 64MB ram.

And I have alot of troubles with gaming. All games I have tried on it: CS steam (wine), Quake 3 (both original and ioQuake), ioUrbanTerror, Unreal Tournament and EVEN GLTron have frame drops. The first 10-15 minutes of playing it's stabile fps. But then it starts to drop, and then after another minute it's down to 2-3 fps.

The problems aren't there in Windows though. But I want to save that HD space and don't have Windows.

I have tried many xorg.conf configurations. I have made a file from scratch my self. KDE has made one for me. nvidia-settings has made one for me. The package manager (or something) made one for me. And I have also tried others from internet and such. My current xorg.conf file is KDE standard, except that I have added "VideoRam" and some synaptics options.

Code:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"no"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"	"/dev/input/mice"
	Option		"Protocol"	"ImPS/2"
	Option		"ZAxisMapping"	"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"	"/dev/psaux"
	Option		"Protocol"	"auto-dev"
	Option		"HorizEdgeScroll"	"0"
	Option		"SHMConfig"	"on"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"stylus"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"eraser"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"cursor"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300]"
	Driver		"nvidia"
	Busid		"PCI:1:0:0"
	Option		"AddARGBVisuals"	"True"
	Option		"NoLogo"	"True"
	VideoRam	65536
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	Horizsync	28-64
	Vertrefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300]"
	Monitor		"Generic Monitor"
	Defaultdepth	24
	SubSection "Display"
		Modes		"1280x800"
	EndSubSection
	Option		"AddARGBGLXVisuals"	"True"
	Option 		"Coolbits" 	"1"
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
  screen "Default Screen"
	Inputdevice	"Generic Keyboard"
	Inputdevice	"Configured Mouse"
	
	# Uncomment if you have a wacom tablet
	#	InputDevice     "stylus"	"SendCoreEvents"
	#	InputDevice     "cursor"	"SendCoreEvents"
	#	InputDevice     "eraser"	"SendCoreEvents"
	Inputdevice	"Synaptics Touchpad"
EndSection
Section "Module"
	Load		"glx"
EndSection
Section "Extensions"
	Option		"Composite"	"Enable"
EndSection
Please help... I really don't have any idea about what it is. I have searched the net alot and tried to see people with the same problem without any luck.

Edit: I have had many distroes on it. Same in everyone. Ubuntu 7.04 and 7.10, now I run the newest Kubuntu. I have also had the previous Linux Mint on it, and the newest Mint.

Last edited by dxlr8r; 01-12-2008 at 08:01 AM.
 
Old 01-12-2008, 08:05 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
It's probably an issue with the drivers. Which version are you using ? Try either older or newer that what you are currently using.
 
Old 01-12-2008, 08:46 AM   #3
dxlr8r
LQ Newbie
 
Registered: Oct 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by H_TeXMeX_H View Post
It's probably an issue with the drivers. Which version are you using ? Try either older or newer that what you are currently using.
I have used the ones that come with the distro, dunno the version. How do I check this? And now I have the newest ones. Compiled and installed using Envy.
 
Old 01-12-2008, 02:12 PM   #4
dxlr8r
LQ Newbie
 
Registered: Oct 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Is this related and of interest?

http://www.nvnews.net/vbulletin/showthread.php?t=100803
 
Old 01-13-2008, 09:35 AM   #5
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Quote:
Originally Posted by dxlr8r View Post
Only if you run compiz, do you ?

As for driver version, run 'nvidia-settings' it'll have the driver version on there.
 
Old 01-13-2008, 04:45 PM   #6
dxlr8r
LQ Newbie
 
Registered: Oct 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Still no go :(

Quote:
Originally Posted by H_TeXMeX_H View Post
Only if you run compiz, do you ?

As for driver version, run 'nvidia-settings' it'll have the driver version on there.
No I don't. Ok... Nice to now.

Now I have tried Open Suse to. And same thing there in 169.07 driver. Drops after 10 minutes.

I tried the "legacy" drivers as well which was version "9639". X wouldn't even start with it...

Just to be sure. When I installed Open Suse I did not touch the system at all. I let Open Suse do everything. So, it's nothing something I've done

Last edited by dxlr8r; 01-13-2008 at 05:04 PM.
 
Old 01-14-2008, 01:14 PM   #7
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Any error when X fails to start ? It may not be configured properly.
 
Old 01-14-2008, 01:20 PM   #8
dxlr8r
LQ Newbie
 
Registered: Oct 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by H_TeXMeX_H View Post
Any error when X fails to start ? It may not be configured properly.
I've read that it is to old anyway. That you must have one of the newer drivers. I don't recal exactly, but X said that it didn't find the device. Not very strange since the kernel module wouldn't load because it couldn't find the card.
 
Old 01-15-2008, 02:41 AM   #9
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I don't think there is such a thing, I can use the legacy (7000 and 9000 series) as well as the newest drivers just fine with the same Xorg version. The problem is that I sometimes have to re-configure Xorg between updates.
 
Old 01-15-2008, 07:26 AM   #10
dxlr8r
LQ Newbie
 
Registered: Oct 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by H_TeXMeX_H View Post
I don't think there is such a thing, I can use the legacy (7000 and 9000 series) as well as the newest drivers just fine with the same Xorg version. The problem is that I sometimes have to re-configure Xorg between updates.
modprobe nvidia, doesn't have a nything to say with Xorg. It should load anyway, and it doesn't on legacy versions. If only the kernel module would load it might be my xorg.conf yes.
 
Old 01-15-2008, 12:00 PM   #11
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Ahh, I see so the nvidia module will not load even before X starts. Then the module may not have been compiled correctly. What does it say when you try to load it 'modprobe nvidia' ? I already know about what it will say, but just want to make sure. So, if it gives you an error it's probably related to the module being compiled for a different kernel than you are using. Did you install it using the official installer to compile a module or from a pre-made package by the distro. If by the distro make sure it was compiled for your specific kernel.
 
Old 01-15-2008, 08:20 PM   #12
dxlr8r
LQ Newbie
 
Registered: Oct 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by H_TeXMeX_H View Post
Ahh, I see so the nvidia module will not load even before X starts. Then the module may not have been compiled correctly. What does it say when you try to load it 'modprobe nvidia' ? I already know about what it will say, but just want to make sure. So, if it gives you an error it's probably related to the module being compiled for a different kernel than you are using. Did you install it using the official installer to compile a module or from a pre-made package by the distro. If by the distro make sure it was compiled for your specific kernel.
I tried the "legacy" drivers in both Ubuntu and Open Suse. I don't remember the warning right now, I'll check tomorrow. And yes. I run all standard kernels from the package manager. Nowadays making your own is to hard... Atleast with all the udev and auto detecting things. Before I always made my own kernels. Guess it's lazyness that I haven't read more about udev though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow FPS on ePSXe with Pete's MesaGL GPU LoneCanisLupus Linux - Games 3 01-22-2008 02:12 PM
FPS Drop with Dekstop Effects on FC6 Chuong Linux - Software 2 11-08-2006 11:18 AM
FPS Games on Linux trex1268 Linux - General 1 08-15-2006 08:14 PM
Native Multiplayer FPS Games? Battlefield Linux - Games 4 11-28-2004 08:26 PM
post your (fps) In Games duaux General 52 09-27-2003 07:55 AM


All times are GMT -5. The time now is 06:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration