LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 02-29-2008, 08:43 PM   #1
Registered: Feb 2008
Distribution: Kubuntu 11.10 64-bits
Posts: 70

Rep: Reputation: 15
Talking Fix For "[ao_alsa] Playback Open Error: Device Or Resource Busy. No coding!!

Hey guys,

Have you ever had that error when trying to play sound from terminal

[AO_ALSA] Playback open error: Device or resource busy
Or oustide terminal while loading software such as Amarok you get something like

xine engine unable to load sound drivers
Well there is a super simple fix for that. It might not work, cuz there could be 100s of causes, but check on this one in case.

First, just to make sure the fix will do what it's meant for (fixing!), type the following in terminal

lsof /dev/snd/{whatever your device name is, similar to "pcmC0D1p"}
You can get the device name in terminal when you type the following and get the sound error which is the subject of this post

It will show something like

[AO_ALSA] alsa-lib: pcm_hw.c:1099:(snd_pcm_hw_open) open /dev/snd/pcmC0D1p failed: Device or resource busy
Then go back to the step about the lsof command. Check if you have anything showing. If the lsof command lists nothing, then your problem is something else and look elsewhere. But if lsof lists something, it means those things are using the sound device, and most probably in an exclusive manner which means nothing else can start the device.

The culprit? The stupid "Sound File preview" function in KDE!!
You can uncheck that option from 2 places:

-right-click desktop
-choose behavior
-file icon tab
-uncheck "sound files"

The other way is through kcontrol, this first one is a lot easier though.
Then reboot (restarting X is enough, I think).
And then do another lsof typing. And nothing will show!! Now start Amarok or anything else.

That problem happened to me when I tried to force all sounds through SPDIF. Analog I had no problem, but through SPDIF it was always busy until I found that workaround.

Last edited by Frank64; 03-03-2008 at 04:30 PM.
Old 03-02-2008, 07:22 AM   #2
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971
well that's one cause, there are many many more...
Old 03-03-2008, 04:28 PM   #3
Registered: Feb 2008
Distribution: Kubuntu 11.10 64-bits
Posts: 70

Original Poster
Rep: Reputation: 15
Correct. I just figured my post wasn't clear enough about that so I will edit it. tnx.


alsa, busy, device, sound, spdif

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless RT2500, "Device or resource busy" in Ubuntu puggers Linux - Hardware 2 10-22-2006 01:18 PM
Device or resource busy error obulpathi Linux - Laptop and Netbook 1 01-20-2006 04:03 AM
How to fix Device or Resource Busy!?!? Micah Linux - General 2 06-24-2005 02:21 PM
gnomemeeting crashed, now i got "video0: Device or resource busy" B sirpelidor Linux - Hardware 0 01-10-2005 03:02 AM
open /dev/[sound/]dsp: Device or resource busy tearinox Linux - Newbie 1 10-24-2003 06:47 PM

All times are GMT -5. The time now is 01:55 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration