LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-03-2005, 12:24 AM   #1
jonlake
Member
 
Registered: Apr 2004
Distribution: Slackware 11.0, Gentoo
Posts: 252

Rep: Reputation: 31
firmware won't load on wireless card on boot


FC2 kernel 2.6.6 custom

I have a Dlink card that requires the firmware be loaded everytime the computer boots. I downloaded a script that will load the firmware after the module is loaded. Right now I have the module loaded in /etc/modprobe.conf. I also added a script (1 line that calls the script to load the firmware) to /etc/rc.d/init.d. I added a link /etc/rc.d/rc5.d/S07hostapfwload that points to the script in init.d. It needs to run before the networking script so that can intialize my wireless card.
When I boot, it appears that everything goes ok (no output), but the firmware doesn't get loaded.
I know this because when I boot, and if i have the wlan0 set to onboot=yes, it will hang on "bringing up wlan0". I looked in /var/log/messages and found that it keeps trying to broadcast for a dhcp address, but since the firmware isn't loaded, it just keeps trying. I have let it sit for about 1 minute and it will not get past this point.

Also, if I do an interactive boot, choose not to initiliaze the wlan0, and get to my prompt I cannot setup the card until I load the firmware. To load the firmware, I just use the command /usr/bin/hostap_fw_load wlan0. I don't know if I need something else in my script to let it load, this is my first attempt at putting anything in the
rc's, so I don't know if anything else needs to be done. I chmod 755 the script in init.d, so it does actually attempt to run.

Code:
# dmesg
hostap_crypt: registered algorithm 'NULL'
hostap_pci: 0.2.0 - 2004-02-15 (Jouni Malinen <jkmaline@cc.hut.fi>)
hostap_pci: Registered netdevice wifi0
wifi0: Original COR value: 0xa8
hostap_pci: assuming no Primary image in flash - card initialization not completed
wifi0: test Genesis mode with HCR 0x1f
wifi0: Original COR value: 0x21
Readback test failed, HCR 0x1f write 00 e1 a1 ff read 00 ce a1 ce
wifi0: test Genesis mode with HCR 0x0f
wifi0: Original COR value: 0xa1
Readback test succeeded, HCR 0x0f
wifi0: Intersil Prism2.5 PCI: mem=0xe8100000, irq=5
wifi0: registered netdevice wlan0
lp0: using parport0 (polling).
eth0: link down
wlan0: could not set interface UP - no PRI f/w
wlan0: cannot get RID fdc6 (len=12) - no PRI f/w
wlan0: cannot get RID fdc6 (len=12) - no PRI f/w
wlan0: cannot get RID fdc1 (len=2) - no PRI f/w
wlan0: cannot get RID fc06 (len=2) - no PRI f/w
wlan0: cannot get RID fd42 (len=6) - no PRI f/w
wlan0: cannot get RID fc0e (len=34) - no PRI f/w
wlan0: cannot get RID fc84 (len=2) - no PRI f/w
wlan0: cannot get RID fc83 (len=2) - no PRI f/w
wlan0: cannot get RID fc82 (len=2) - no PRI f/w
wlan0: cannot get RID fc09 (len=2) - no PRI f/w
wlan0: cannot get RID fd48 (len=2) - no PRI f/w
prism2: wlan0: operating mode changed 3 -> 2
wlan0: cannot set RID fc00 (len=2) - no PRI f/w
wlan0: cannot set RID fc0e (len=34) - no PRI f/w
hostap_crypt: registered algorithm 'WEP'
wifi0: cannot get RID fc28 (len=2) - no PRI f/w
Could not read current WEP flags.
wifi0: encryption setup failed
wlan0: set_encryption failed
wlan0: cannot set RID fc02 (len=34) - no PRI f/w
wlan0: could not set interface UP - no PRI f/w
wlan0 unsupported ioctl(0x8947)
wlan0: could not set interface UP - no PRI f/w
wlan0: could not set interface UP - no PRI f/w
prism2_download: dl_cmd=4 start_addr=0x003f0000 num_areas=3
wifi0: test Genesis mode with HCR 0x0f
wifi0: Original COR value: 0x0
Readback test succeeded, HCR 0x0f
prism2_hw_init: initialized in 0 ms
wifi0: NIC: id=0x8000 v0.0.1
wifi0: PRI: id=0x15 v1.1.2
Could not get RID for component STA
wifi0: Failed to read STA f/w version - only Primary f/w present
prism2_download: dl_cmd=6 start_addr=0x003f0000 num_areas=3
wifi0: test Genesis mode with HCR 0x0f
wifi0: Original COR value: 0x0
Readback test succeeded, HCR 0x0f
prism2_hw_init: initialized in 0 ms
wifi0: NIC: id=0x8024 v1.0.0
wifi0: PRI: id=0x15 v1.1.2
Could not get RID for component STA
wifi0: Failed to read STA f/w version - only Primary f/w present
prism2_download: dl_cmd=5 start_addr=0x003f0c01 num_areas=3
prism2_hw_init: initialized in 27 ms
wifi0: NIC: id=0x8024 v1.0.0
wifi0: PRI: id=0x15 v1.1.2
wifi0: STA: id=0x1f v1.8.3
wlan0 unsupported ioctl(0x8947)
wifi0: LinkStatus=1 (Connected)
wifi0: LinkStatus: BSSID=00:0d:88:29:9f:b9

# less /var/log/messages

Sep  2 21:52:03 jon rc: Starting cups:  succeeded
Sep  2 21:52:03 jon kernel: eth0: link down
Sep  2 21:52:25 jon login(pam_unix)[1776]: session opened for user root by (uid=0)
Sep  2 21:52:25 jon  -- root[1776]: ROOT LOGIN ON tty1
Sep  2 21:52:34 jon dhclient: wifi0: unknown hardware address type 801
Sep  2 21:52:35 jon dhclient: wifi0: unknown hardware address type 801
Sep  2 21:52:35 jon dhclient: receive_packet failed on wlan0: Network is down
Sep  2 21:52:36 jon dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
Sep  2 21:52:36 jon dhclient: send_packet: Network is down
Sep  2 21:53:57 jon kernel: wifi0: NIC: id=0x8000 v0.0.1
Sep  2 21:53:57 jon kernel: wifi0: PRI: id=0x15 v1.1.2
Sep  2 21:53:57 jon kernel: wifi0: NIC: id=0x8024 v1.0.0
Sep  2 21:53:57 jon kernel: wifi0: PRI: id=0x15 v1.1.2
Sep  2 21:53:57 jon kernel: wifi0: NIC: id=0x8024 v1.0.0
Sep  2 21:53:57 jon kernel: wifi0: PRI: id=0x15 v1.1.2
Sep  2 21:53:57 jon kernel: wifi0: STA: id=0x1f v1.8.3
Sep  2 21:54:02 jon login(pam_unix)[1776]: session closed for user root
Sep  2 21:54:07 jon gdm(pam_unix)[1979]: session opened for user jon by (uid=0)
Sep  2 21:54:25 jon gconfd (jon-2273): starting (version 2.6.0), pid 2273 user 'jon'
Sep  2 21:54:25 jon gconfd (jon-2277): starting (version 2.6.0), pid 2277 user 'jon'
Sep  2 21:54:25 jon gconfd (jon-2273): Failed to get lock for daemon, exiting: Failed to lock '/tmp/gconfd-jon/lock/ior': probably a
nother process has the lock, or your operating system has NFS file locking misconfigured (Resource temporarily unavailable)
Sep  2 21:54:25 jon gconfd (jon-2277): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only config source a
t position 0
Sep  2 21:54:25 jon gconfd (jon-2277): Resolved address "xml:readwrite:/home/jon/.gconf" to a writable config source at position 1
Sep  2 21:54:25 jon gconfd (jon-2277): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only config source at
 position 2
Sep  2 21:54:28 jon bonobo-activation-server (jon-2279): iid OAFIID:BrokenNoType:20000808 has a NULL type
Sep  2 21:54:28 jon bonobo-activation-server (jon-2279): invalid character '#' in iid 'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBad
Chars'
Sep  2 23:35:09 jon login(pam_unix)[2153]: session opened for user root by LOGIN(uid=0)
Sep  2 23:35:09 jon  -- root[2153]: ROOT LOGIN ON tty1
Sep  2 23:35:20 jon dhclient: wifi0: unknown hardware address type 801
Sep  2 23:35:21 jon dhclient: wifi0: unknown hardware address type 801
Sep  2 23:35:23 jon dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
Sep  2 23:35:31 jon dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
Sep  2 23:35:31 jon dhclient: DHCPACK from 192.168.0.1
Sep  2 23:35:31 jon dhclient: bound to 192.168.0.120 -- renewal in 1021779516 seconds.

Last edited by jonlake; 09-03-2005 at 12:26 AM.
 
Old 09-03-2005, 10:49 AM   #2
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
I should be easier to load this with rc.local.
 
Old 09-07-2005, 10:03 AM   #3
jonlake
Member
 
Registered: Apr 2004
Distribution: Slackware 11.0, Gentoo
Posts: 252

Original Poster
Rep: Reputation: 31
Yea, that is what I was going to do, but then I thought I would try to get some experience with the other startup scripts. If anyone has an idea why this didn't work the way I originally had done it, please let me know.

Thanks
 
Old 09-08-2005, 12:31 AM   #4
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Perhaps this will help:
When you run a command (in a script) with & at the end ( ie: xmms& ) then xmms is launched but the following command is parallelized, so even if there's a hang with xmms, other stuff will follow.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
load wireless card at reboot(Fedora 4) beyondreality Linux - Wireless Networking 5 07-01-2005 10:06 AM
Getting ipw2100 firmware to load on boot lamiroy Linux - Wireless Networking 4 03-31-2005 07:10 AM
Updated Firmware of Wireless card, now doesnt work properly? kromatic Linux - Hardware 1 02-18-2005 01:36 PM
I need help installing firmware and driver for wireless card mntamimi Linux - Newbie 3 02-03-2005 04:27 PM
Resource in use error when trying to load modules for wireless card blk96gt Slackware 0 06-27-2004 01:10 AM


All times are GMT -5. The time now is 11:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration