LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 05-12-2005, 12:10 AM   #1
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Rep: Reputation: 30
file names on USB flashdrive


I'm having a problem with my USB flashdrive... filenames are restricted to 8 characters, plus ".xxx" where "xxx" is the file extension. filenames are all converted to lowercase.
This only happens on linux, and only on my home system. Linux at school, OS X, and WindowsXP have no problems with filenames on the USB drive.
I'm guessing that my home configuration is reading the USB drive as some old file system (wasn't this naming scheme similar to and old DOS system?), but I don't know where or how to change it.
 
Old 05-12-2005, 01:23 AM   #2
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
your system is mounting your drive like a FAT16 filesystem instead of FAT32. Just add "-t vfat" to your mount line, or in the options column in /etc/fstab
 
Old 05-24-2005, 10:28 PM   #3
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 30
Ok, my fstab line for the USB device now looks like:

Code:
/dev/sda1	/mnt/USBflashdrive auto  noauto,owner,rw,user,vfat	0	0
I get the following error:

Code:
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
I got the same error when I tried with ufs... not sure what's going on... I haven't tried EVERY possible fs type, but maybe someone here knows a quicker way to fix it?
 
Old 05-24-2005, 10:30 PM   #4
Lord Zoltar
Member
 
Registered: Jun 2004
Distribution: Slackware
Posts: 200

Original Poster
Rep: Reputation: 30
Oh yeah... when I do the suggested dmesg in the error message, I get output like:

FAT: Unrecognized mount option "vfat" or missing value
FAT: Unrecognized mount option "ufs" or missing value

...so is it a FAT USB drive then? why can't i get long filenames in Linux, but I CAN in WinXP,OSX?
 
Old 05-24-2005, 11:32 PM   #5
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
sorry my bad, dont put it in the "option" column but in the "fs" column

So it should be like :
Code:
/dev/sda1	/mnt/USBflashdrive vfat  noauto,owner,rw,user	0	0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why do file names keep getting changed to dos 8.3 format on my usb drive? firehawk256 Linux - Newbie 1 02-25-2005 04:32 PM
still more USB flashdrive problems... Lord Zoltar Linux - Hardware 8 01-22-2005 01:38 PM
USB flashdrive problems endfx Linux - Hardware 11 01-01-2005 06:40 PM
USB FlashDrive -- Again kadalz Linux - Newbie 1 10-12-2003 12:20 PM
USB Flashdrive disto cli_man General 7 02-23-2003 05:56 AM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration