LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   fglrxinfo always displays Mesa while ATI's CCC works / restricted manager says in use (http://www.linuxquestions.org/questions/linux-hardware-18/fglrxinfo-always-displays-mesa-while-atis-ccc-works-restricted-manager-says-in-use-603602/)

Mysticle31 11-30-2007 05:25 PM

fglrxinfo always displays Mesa while ATI's CCC works / restricted manager says in use
 
I have been trying for DAYS to make this work.

fglrxinfo just refuses to indicate that ATI drivers are being used. I've tried manually installing the drivers from ATI's website. I've tried installing from the package manager. I've tried "installing the driver the Ubuntu way" from here:

http://wiki.cchtml.com/index.php/Ubu...allation_Guide

I've tried the manual way too.

I've tried several different how-tos.

this thing just will not work.

The strange thing is that the ATI CCC (both the newest one from the ATI website and the one that installs via the package manager) work. They do not complain about "no ATI device found" or anything like that. Even the restricted driver manager in Ubuntu says it's in use.

What gives? I can't get compiz-fusion to install, which has it's own issues. Right now I just want fglxconfig to say ATI.

here is my Xorg.config
Quote:

Section "ServerLayout"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
Identifier "Default Layout"
screen "Default Screen" 0 0
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"
Option "AIGLX" "True"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection
Section "Monitor"
Identifier "DPro 2070SB"
Option "DPMS"
EndSection

Section "Device"
Identifier "ATI Technologies Inc RV350 AP [Radeon 9600]"
Driver "fglrx"
Option "XAANoOffscreenPixmaps" "true"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Busid "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc RV350 AP [Radeon 9600]"
Monitor "DPro 2070SB"
Defaultdepth 24
SubSection "Display"
Modes "2048x1536" "1920x1440" "1600x1200" "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "0"
EndSection


Lenard 12-01-2007 05:55 AM

Hmmm...............

I believe that fglxconfig is now aticonfig; aticonfig --initial=check


All times are GMT -5. The time now is 10:37 AM.