LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-05-2007, 04:12 AM   #1
simopal6
Member
 
Registered: Jun 2006
Location: Italy
Distribution: Slackware 13.1
Posts: 217

Rep: Reputation: 30
fglrx won't use its internal agp, but agpgart's !


Hello!

Slackware 10.2
Kernel 2.6.19
Ati mobility radeon 9700

I've recently installed the ati fglrx drivers (version 8.32.5), and i didn't get any errore during installation. DRI works (both fgl_glxgears and glxgears, even if the latter shows many more fps). Nevertheless, dmesg says:

Code:
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected an Intel 855PM Chipset.
agpgart: AGP aperture is 256M @ 0xe0000000
fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[fglrx] Maximum main memory to use for locked dma buffers: 429 MBytes.
[fglrx] module loaded - fglrx 8.32.5 [Dec 12 2006] on minor 0
[fglrx] Internal AGP support requested, but kernel AGP support active.
[fglrx] Have to use kernel AGP support to avoid conflicts.
[fglrx] AGP detected, AgpState   = 0x1f000217 (hardware caps of chipset)
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
[fglrx] AGP enabled,  AgpCommand = 0x1f000314 (selected caps)
[fglrx] total      GART = 268435456
[fglrx] free       GART = 252440576
[fglrx] max single GART = 252440576
[fglrx] total      LFB  = 67108864
[fglrx] free       LFB  = 52719616
[fglrx] max single LFB  = 52719616
[fglrx] total      Inv  = 0
[fglrx] free       Inv  = 0
[fglrx] max single Inv  = 0
[fglrx] total      TIM  = 0
How can I tell the kernel that i want to use fglrx? ATI guide says that kernel built-in agp support must be disabled: do i have to prevent the module from loading or not build the module at all?

thanks to everyone!

p.s. i've read cwwilson's thread, but didn't find anything useful...
 
Old 01-05-2007, 05:26 AM   #2
FnordPerfect
Member
 
Registered: Dec 2006
Location: Germany
Distribution: Kubuntu (Feisty Fawn), Debian (SID)
Posts: 127

Rep: Reputation: 15
I have no experience neither with Slackware nor with ATI hardware, but let's see...

If it is a kernel pre-compiled by your distributor, then check whether AGP support is actually a module, or built-in into the kernel.
You can do that by looking in /proc/config.gz (if available with your kernel) or checking the output of 'lsmod' (type 'lsmod | grep agp')

If it is built-in, then you might give your boot manager (grub or lilo) the kernel boot parameter iommu=noagp (I hope I'm not telling bullshit now; I'm sure there is an noagp option for Knoppix...)

If AGP support is realized via modules, then there are two modules in 2.6.x:
* one generic named 'agpgart'
* one specific to you mainboard chipset! (mine is a VIA chipset, so the module is called via_agp)

To prevent your distro from autoloading it at boot time, there should be a 'blacklist' file in /etc
Look for it, put both module names in there, and reboot.

In Debian, it is /etc/modprobe.d/blacklist

These modules would be installed in /lib/modules/2.6.19/kernel/drivers/char/agp
You could go "brute force" and move these out of the way. It won't break your system.

I guess, it is also possible to put modules inside an initramdisk. I have no experience with that.


Or is it a custom kernel compiled by yourself?

Then 'make menuconfig' and deactivate agp there.

It's under
Code:
Device Drivers
 -> Character Devices
    < > /dev/agpgart support
Hope that helps

cheers
 
Old 01-05-2007, 04:06 PM   #3
simopal6
Member
 
Registered: Jun 2006
Location: Italy
Distribution: Slackware 13.1
Posts: 217

Original Poster
Rep: Reputation: 30
I removed the agpgart module, and dri doesn't work anymore. Also, ATI says that agpgart must be loaded for fglrx to work... They're driving me crazy! They say that kernel agp support must be disabled in order to use fglrx's internal agp, but they also want the agpgart module to be loaded!

Does anybody know how to make fglrx use its own agp support?
Thank you!
 
Old 01-05-2007, 08:52 PM   #4
FnordPerfect
Member
 
Registered: Dec 2006
Location: Germany
Distribution: Kubuntu (Feisty Fawn), Debian (SID)
Posts: 127

Rep: Reputation: 15
Oh my, that didn't work too well...
sorry. I hope by "removed the agpgart module" you mean "unloaded" and not "deleted" as my posting might have implied.

However, I googled around a bit, but only found very outdated HOWTOs.
* Slackware
* Debian (you can just skip the Debian-related stuff

It looks like you can choose whether the fglrx module should use the kernel's internel agpgart or its own by using the fglrxconfig utility.
Code:
Do you want to use the external AGP GART module (y/n)? [n] y
Also, you apparently have to deactivate the kernel's DRI support..
Code:
Device Drivers
 -> Character Devices
  - [ ] Direct Rendering Manager (XFree86 DRI support)

good luck.
 
Old 02-01-2007, 07:22 AM   #5
simopal6
Member
 
Registered: Jun 2006
Location: Italy
Distribution: Slackware 13.1
Posts: 217

Original Poster
Rep: Reputation: 30
Hi! I haven't used linux for a while, so i couldn't test your suggestions until now. I removed the kernel dri support (but i didn't remove agpgart), but nothing changed. I couldn't find fglrxconfig, where should it be? It isn't in the same folder as fgl_glxgears and fglrxinfo.
 
Old 04-20-2007, 06:18 AM   #6
nithintou
LQ Newbie
 
Registered: Apr 2007
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
find /etc/X11/xorg.conf and change or add this variable:

Option "UseInternalAGPGART" "yes"

 
  


Reply

Tags
agpgart, fglrx


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AGP Graphics cards not showing up in lspci - cannot load fglrx robthebob Linux - Hardware 2 02-28-2006 02:52 AM
Missing agp-gart modules (moving from PCI to AGP video card) JLTB Debian 1 03-31-2005 04:08 AM
I have an onboard AGP, but want to use my nVidia card in my AGP slot. xorg.conf help LordRaven Slackware 16 09-17-2004 05:36 PM
ATI Radeon fglrx driver - setting AGP speed vharishankar Linux - Hardware 17 08-17-2004 10:47 PM
Old AGP 2x card - can work in AGP 2x/4x slot? elnomadkvn Linux - Hardware 1 04-04-2004 01:35 AM


All times are GMT -5. The time now is 07:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration