LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-25-2006, 06:11 AM   #1
kdog
LQ Newbie
 
Registered: Aug 2006
Posts: 22

Rep: Reputation: 15
Fedora Core 5 and Netgear WG511 v3 Made in China


Hi there,

I am going crazy here.

Basics:
Laptop: IBM Thinkpad 600X PIII 500MHz
WiFi Card: Netgear WG511 v3 "Made in China" (intersil prism Chipset)
Linux: Fedora Core 5
Kernel: 2.6.17-1.2174_FC5 i686 and the matching Kernel-devel and ndiswrapper installed.

I have read almost all tutorials about the problems with this card and none have helped. Either I am not doing something I should be doing, oder something is very wrong.

What am I doing?

1. Got the windowsXP Pro drivers in version 3.0.0 from netgear and extracted them.
Copied the .sys and the .inf files into a directory.

2. I changed into the driectory and ran ndiswrapper -i netwg511.inf.
The drivers were installed.

3. Ran a ndiswrapper -l with teh result:
Installed drivers:
netwg511 driver installed, hardware present

4. ran a modprobe -r prism54 without errors

5. ran a depmod -a without errors

6. ran a modprobe ndiswrapper without errors

7. ran a dmesg with the following result:
ndiswrapper version 1.18 loaded (preempt=no,smp=no)
ndiswrapper: driver netwg511 (NETGEAR, 09/06/2004, 2.1.25) loaded
ACPI; PCI Interrupt 0000:02:00.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
ndiswrapper: using irq 11
ndiswrapper (miniport_init:262): couldn`t initialize device; C0010006
ndiswrapper (pnp_start_device:438): Windows driver couldn`t initialize the device (C0000001)
ndiswrapper (minport_halt;303): device c39732c0 is not initialized - not halting
ndiwrapper; device eth%d removed
unregister_netdevice; device eth%d/c3973000 never was registered
ndiswrapper; probe of 0000:02:00.0 failed with error -22


I have been playing round with this for the past few days and searched google like mad. But none of the tutorials are working for me.

I desparately need help here to get my WiFi card up and running.

I have posted in so many forums now, with no results.

Please help me with my problem here.

Thanks
ken
 
Old 08-25-2006, 08:19 AM   #2
kdog
LQ Newbie
 
Registered: Aug 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Please, Im desperate.....

ken
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Netgear wg511 Made in China v3 wireless card r_f_k_c Linux - Wireless Networking 4 02-12-2006 05:19 PM
wg511 on fedora core 4 dkippers Linux - Wireless Networking 0 10-28-2005 11:18 AM
wg511 (china) ndiswrapper el_pajaro! Linux - Wireless Networking 5 05-16-2005 03:26 PM
Problems installing Netgear WG511 in Fedora piampri Linux - Hardware 0 02-15-2005 05:12 PM
netgear wg511 v2 in fedora 3 honduraz10 Linux - Wireless Networking 1 12-07-2004 02:25 AM


All times are GMT -5. The time now is 11:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration