LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-05-2005, 06:59 AM   #1
gilbertt
LQ Newbie
 
Registered: Apr 2004
Location: London, UK
Distribution: Ubuntu 6. 06.2 LTS 'Dapper'
Posts: 23

Rep: Reputation: 15
FAT 32 access permissions problem


Hello all,

I'm trying to sort out a FAT 32 partition on a dual boot running SuSE 10 and XP on separate discs. Having trouble though: in Suse i can only get write access if i logon as su.

The entry in etc/fstab for this partition reads:

/dev/hdb3 /data1 vfat rw,users,gid=100,umask=000,utf8=true 0 0

I've also gone into YasT > System > partitioner > edit > fstab options , which reads:

users,gid=users,umask=000,utf8=true,0 0.

rw isn't there, because after I've entered it YasT for some removes it. But I can add rw directly into etc/fstab , and i thought that umask=100 would give universal permissions anyway.

Can anyone help please?

Gilbertt
 
Old 11-05-2005, 07:11 AM   #2
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Rep: Reputation: 32
This works for me:

Code:
#Windows Disc
/dev/hda5 /mnt/win_d vfat umask=0,iocharset=iso8859-15,codepage=850 0 0
/dev/hda6 /mnt/win_e vfat umask=0,iocharset=iso8859-15,codepage=850 0 0
/dev/hda7 /mnt/win_f vfat umask=0,iocharset=iso8859-15,codepage=850 0 0
/dev/hda8 /mnt/win_g vfat umask=0,iocharset=iso8859-15,codepage=850 0 0
and I don't even need the rw.

Check the permissions of /data1. It might be that only root has rw perms. On my system /mnt is restricted to root but the subdirs have rw perms to everyone.
 
Old 11-05-2005, 08:24 AM   #3
gilbertt
LQ Newbie
 
Registered: Apr 2004
Location: London, UK
Distribution: Ubuntu 6. 06.2 LTS 'Dapper'
Posts: 23

Original Poster
Rep: Reputation: 15
hi davcefai,

v grateful for your help on this. my data1 directory is indeed set up as root access only. i thought the etc/fstab entry would over-ride it but it clearly doesn't. I guess now i just su into a console and use either chown or chmod?

the learning curve on linux can be pretty steep for a newbie sometimes, but thats good.

thanks again,

gilbertt
 
Old 11-05-2005, 01:35 PM   #4
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Rep: Reputation: 32
This is how the Linux world works. Hope you enjoy living in it.


Quote:
I guess now i just su into a console and use either chown or chmod?
There may be an easier way. I'm not familiar wirh SUSE but you probably have a "File Manager - Superuser Mode" Icon or Menu item. It launches Konquerer in su mode (asks you for root password).

Find the directory, right click, choose properties and change permissions there. This works under KDE but I believe that Gnome does the same things.
 
Old 11-05-2005, 06:09 PM   #5
gilbertt2
LQ Newbie
 
Registered: Oct 2005
Location: london, uk
Distribution: SuSE 9.2 Pro
Posts: 6

Rep: Reputation: 0
i changed the etc/fstab entry to:

user,iocharset=iso8859-15,codepage=85000

but it took me an hour to realise that i had to reboot for it to work! Before then i tried changing the permissions by opening the filemanager as su and then right-clicking on the directory for properties and the permissions box. But any changes i made there were revoked straight away, even though I was in root! Then i went into a console as su and tried chown, chgrp and chmod, but all i got was the message 'Operation not permitted'.

Anyway now I have write access to the fat32 directory , but i can't see any of the files that were there . Why is this? I kind of don't mind so far, because there's some learning going on, but i would like to play my mp3s!

As always any help would be really appreciated.

(BTW my usename is slightly different because somehow when i was logging onto this site i was getting someone elses profile -different registration date and email.???)

gilbertt2
 
Old 11-06-2005, 12:14 AM   #6
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Rep: Reputation: 32
Try using the mount command to see whether the fat32 drive is mounted. What you are describing sounds like it's not.

A part of the mount output will look like:

Quote:
/dev/hda1 on /mnt/win_c type ntfs (rw)
/dev/hda5 on /mnt/win_d type vfat (rw,umask=0,iocharset=iso8859-15,codepage=850)
/dev/hda6 on /mnt/win_e type vfat (rw,umask=0,iocharset=iso8859-15,codepage=850)
If it is not mounted then, as root, use

mount -a

Either it will mount or you'll get an error message telling you what went wrong.
 
Old 11-06-2005, 08:38 AM   #7
gilbertt2
LQ Newbie
 
Registered: Oct 2005
Location: london, uk
Distribution: SuSE 9.2 Pro
Posts: 6

Rep: Reputation: 0
gilbertt@linux:~> mount
/dev/hdd6 on / type reiserfs (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
tmpfs on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/hdb1 on /windows/C type ntfs (ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8)
usbfs on /proc/bus/usb type usbfs (rw)
gilbertt@linux:~> su
Password:
linux:/home/gilbertt # mount -a
mount: wrong fs type, bad option, bad superblock on /dev/hdb3,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

linux:/home/gilbertt # dmesg | tail
atkbd.c: Unknown key released (translated set 2, code 0x81 on isa0060/serio0).
atkbd.c: Use 'setkeycodes e001 <keycode>' to make it known.
atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.
atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.
atkbd.c: Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.
atkbd.c: Unknown key released (translated set 2, code 0x81 on isa0060/serio0).
atkbd.c: Use 'setkeycodes e001 <keycode>' to make it known.

 
Old 11-06-2005, 11:18 AM   #8
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 764

Rep: Reputation: 32
Can you post /etc/fstab ?

From what I can see you are able to see the files on the Windows C drive - being NTFS you can't write to this partition.

In Windows, can you check the properties of the hdb3 partition? Assuming that this is the one you are having problems with I have a suspicion that either:

1. It is not FAT32.
2. You created the partition with a non-MS prog such as Ranish.
 
Old 11-10-2005, 01:01 PM   #9
gilbertt2
LQ Newbie
 
Registered: Oct 2005
Location: london, uk
Distribution: SuSE 9.2 Pro
Posts: 6

Rep: Reputation: 0
Hi,

A very belated reply-this thing called the rest of my life keeps getting in the way.

Under Windows the partition is seen as FAT32, and to create the partition I used SuSE's YasT partition module. Maybe the YasT is misbehaving. I've finally settled for the quickest workaround. I copied the files that I can see with the codepage 85000 to /home. Then i changed the etc/fstab codepage to 850 0 0 and copied those files back. Still not entirely sure about why it happened, I will leave it to larger Linux minds, and settle back with my mp3's.

Big thanks davcefai!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/fat-c permissions Hectic Slackware 3 10-18-2004 08:39 PM
folder permissions /fat-c Hectic Linux - Newbie 2 10-17-2004 01:08 AM
/fat-c permissions in fstab Ops Slackware 2 07-08-2004 10:43 AM
Fat partition permissions doralsoral Linux - Software 11 02-04-2004 10:50 AM
fat drive permissions problem llimllib Linux - General 2 07-18-2003 07:51 PM


All times are GMT -5. The time now is 07:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration