LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   F13. Mic not working. Skype 2.1 Beta. Pulseaudio. Alsamixer. (http://www.linuxquestions.org/questions/linux-hardware-18/f13-mic-not-working-skype-2-1-beta-pulseaudio-alsamixer-838091/)

1337.HDLA 10-14-2010 02:28 PM

F13. Mic not working. Skype 2.1 Beta. Pulseaudio. Alsamixer.
 
Hi. Good day!

I'm using F13. I have alsamixer and pulseaudio and Skype 2.1 Beta installed.
Everything is fine except my microphone. I tried to plug it on every possible
jack (front, line in, etc.) but it doesnt work. I can hear someone I called from
skype, but he cannot hear me.

I tried to change input devices on pavucontrol, and input source on alsamixer to
microphone 1, microphone 2, and line in, still mic doesnt work. all volume on alsamixer is maxed up, including mic boost etc.

I went to Skype Option > Sound devices, and when I look at microphone and speakers, its "Pulseaudio server (local)" and there's no other option. I'm using built in sound card HDA Intel.

I did all possible way I could do. I'm trying to search on the net but cannot find a solution.
I hope you can help me guys. Thanks a lot. Cheers.

Additional info. my /etc/asound.conf
Code:


#
# Place your global alsa-lib configuration here...
#

@hooks [
        {
                func load
                files [
                        "/etc/alsa/pulse-default.conf"
                ]
                errors false
        }
]


 pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

# for 5.1 speakers
pcm.ch51dup {
        slave.pcm surround51
        slave.channels 6
        type route
        ttable.0.0 1
        ttable.1.1 1
        ttable.0.2 1
        ttable.1.3 1
        ttable.0.4 0.5
        ttable.1.4 0.5
        ttable.0.5 0.5
        ttable.1.5 0.5
}



options Intel index=0
options Intel model=5stack
# add pulse
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}


markush 10-14-2010 03:24 PM

Hello 1337.HDLA,

could you please post a screenshot of your alsamixer settings.
I had a similar problem 2 years ago, I posted this in the german slackforum: http://www.slackforum.de/forum/index...817&#msg_19817

Markus

1337.HDLA 10-15-2010 07:15 AM

Hi Markus.

Here's the screenshot of my alsamixer
http://img138.imageshack.us/img138/1766/alsa.jpg

and pulseaudio input devices settings
http://img31.imageshack.us/img31/1756/pulsev.jpg

Thanks for the reply. I appreciate it.

markush 10-15-2010 07:31 AM

Well,

in alsamixer you may navigate to "s/pdif" and press the "m" key. This will mute/unmute the device.
Maybe that helps.
It may be good to look at the "recording" tab in your puleaudio-settings. But I'm not sure if pulsaudio is involved here.

Markus

1337.HDLA 10-15-2010 12:25 PM

Hi Markus.

My microphone works now! Thanks for your help. All I have to do is unmute "Mic" and "S/PDIF" and mute "Smart 5.1". I think I have a 5.1 Surround sound default setting coz I like to watch movies. I just need to turn off that and make the front jack to be mic. Thanks.

Thanks for your help.


All times are GMT -5. The time now is 05:16 AM.