LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   External USB HDD"Mounting local filesystems: /dev/sdb1 is not a valid block device" (http://www.linuxquestions.org/questions/linux-hardware-18/external-usb-hdd-mounting-local-filesystems-dev-sdb1-is-not-a-valid-block-device-265681/)

manudath 12-12-2004 06:23 PM

External USB HDD"Mounting local filesystems: /dev/sdb1 is not a valid block device"
 
Hi,

I was trying to mount my new external HDD (Maxtor, 120GB) on the Redhat Enterprise Linux (installed on a SATA hard drive)

The entry for the external drive in /etc/fstab is:

/dev/sdb1 /mnt/external1 ext3 exec,auto,nouser,async 0 0

My problem is: Whenever the system boots up, after performing the fsck, it gives an error: "Mounting local filesystems: /dev/sdb1 is not a valid block device" [FAILED]

But on booting up completely, the drive is actually mounted. If I make the option in /etc/fstab as noauto, I see a clean boot up, but I have to manually mount the drive, and I dont want to do that everytime.

Can anyone please help me with this?

Thanks,
Manudath

michaelk 12-12-2004 09:30 PM

AFAIK the kernel mounts the filesystems via fstab prior to loading modules. So there are several options:

You can compile sata support into the kernel.

Change the boot sequence to load the modules prior to mounting the filesystems. I do not know how to accomplish this or if it is possible but wonder why this isn't done anyway.

You can add the sata module to the initrd image.

You can add a command to mount the drive into the /etc/rc.local file. The /etc/rc.local is the last thing to run and the module would be already loaded.

Obviously, the last two choices are the easiest.

manudath 12-13-2004 05:11 PM

Thanks michael,

I had put the command in rc.local... But I was thinking if there were better choices...

Thanks for ur reply...

michaelk 12-13-2004 09:59 PM

Adding the sata module to the initrd image should also work.


All times are GMT -5. The time now is 12:04 AM.