LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   External hard-drive - readonly, can't make it read/write (http://www.linuxquestions.org/questions/linux-hardware-18/external-hard-drive-readonly-cant-make-it-read-write-554564/)

mooseman 05-17-2007 04:38 AM

External hard-drive - readonly, can't make it read/write
 
Hi all...

I'm hoping there' someone out there who can help with a problem that has me **utterly** tearing my hair out....

I've just bought a Nexstar3 400GB external hard-drive. It has the ntfs filesystem on it (which I've heard is pretty standard/not unusual for external drives). Anyway - I am able to mount the drive, but can only do so as root, even though my old (small) USB external drive could be mounted by a normal user. Sheesh...

Ok, cut the long story short- I can mount the drive (as root) but can not copy anything onto it - it says "read-only filesystem". All I want to be able to do is -

a) Mount the drive as a normal user (not just as root) and -
b) Be able to copy files onto it.

Doesn't sound like I'm asking that much, but geez... this drive is just a paper-weight at the moment, and it's going out the window if I can't solve this in the next few days....

***Update*** - typing "ls -l /dev/sda1" gives this -
brw-rw---- 1 root plugdev 8, 1 2007-05-17 20:43 /dev/sda1

... and my entry in /etc/fstab is -
/dev/sda1 /media/400GB ntfs auto auto,users,rw 0 0

/media/400GB is what the drive identifies itself as.
Very many thanks for any help received... Bye for now -
- mooseman

Centinul 05-17-2007 06:58 AM

You will need to enable NTFS Write support in your kernel. This option is most likely turned off. Google around the net for NTFS-3G as well.

Once you re-compile your kernel you should be all set to write to that external drive.

HTH,

Centinul

jschiwal 05-17-2007 07:01 AM

You can also use the fuse system to enable write access. However, as this is a new drive, why don't you format it in with a Linux filesystem?

mooseman 05-18-2007 03:27 AM

Re: making external hard-drive read/write
 
Quote:

Originally Posted by jschiwal
You can also use the fuse system to enable write access. However, as this is a new drive, why don't you format it in with a Linux filesystem?

Hi - thanks for this, jschiwal! ( and centinul too ).

*** UPDATE... SUCCESS!!!! ****
QtPartEd to the rescue!!!
Fired that up and formatted the drive as ext3. The progress-bar ticked over - Yes - it's doing something!
The real breakthrough was this post by user "stress_junkie" (which I should have read in the first place, so sorry for the "noise".... :-) )
That user's tips -
a) Add the drive to /etc/fstab as follows -
/dev/sda1 /media/usbdisk defaults 0 0

b) As root, mount the drive and change owner and permissions -
mount /dev/sda1 /media/usbdisk
chown root:users /media/usbdisk
chmod 777 /media/usbdisk

I've just run my backup script to copy files to the drive, and success!
Here's the proof -

andy@obsidian:~$ df -h /media/400GB
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 367G 3.9G 345G 2% /media/400GB
andy@obsidian:~$

Thanks all for your help!


All times are GMT -5. The time now is 03:59 AM.