LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-17-2007, 03:38 AM   #1
mooseman
LQ Newbie
 
Registered: Mar 2004
Location: Wellington, New Zealand
Distribution: Ubuntu
Posts: 19

Rep: Reputation: 0
External hard-drive - readonly, can't make it read/write


Hi all...

I'm hoping there' someone out there who can help with a problem that has me **utterly** tearing my hair out....

I've just bought a Nexstar3 400GB external hard-drive. It has the ntfs filesystem on it (which I've heard is pretty standard/not unusual for external drives). Anyway - I am able to mount the drive, but can only do so as root, even though my old (small) USB external drive could be mounted by a normal user. Sheesh...

Ok, cut the long story short- I can mount the drive (as root) but can not copy anything onto it - it says "read-only filesystem". All I want to be able to do is -

a) Mount the drive as a normal user (not just as root) and -
b) Be able to copy files onto it.

Doesn't sound like I'm asking that much, but geez... this drive is just a paper-weight at the moment, and it's going out the window if I can't solve this in the next few days....

***Update*** - typing "ls -l /dev/sda1" gives this -
brw-rw---- 1 root plugdev 8, 1 2007-05-17 20:43 /dev/sda1

... and my entry in /etc/fstab is -
/dev/sda1 /media/400GB ntfs auto auto,users,rw 0 0

/media/400GB is what the drive identifies itself as.
Very many thanks for any help received... Bye for now -
- mooseman

Last edited by mooseman; 05-17-2007 at 03:51 AM.
 
Old 05-17-2007, 05:58 AM   #2
Centinul
Member
 
Registered: Jun 2005
Distribution: Gentoo
Posts: 552

Rep: Reputation: 30
You will need to enable NTFS Write support in your kernel. This option is most likely turned off. Google around the net for NTFS-3G as well.

Once you re-compile your kernel you should be all set to write to that external drive.

HTH,

Centinul
 
Old 05-17-2007, 06:01 AM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You can also use the fuse system to enable write access. However, as this is a new drive, why don't you format it in with a Linux filesystem?
 
Old 05-18-2007, 02:27 AM   #4
mooseman
LQ Newbie
 
Registered: Mar 2004
Location: Wellington, New Zealand
Distribution: Ubuntu
Posts: 19

Original Poster
Rep: Reputation: 0
Re: making external hard-drive read/write

Quote:
Originally Posted by jschiwal
You can also use the fuse system to enable write access. However, as this is a new drive, why don't you format it in with a Linux filesystem?
Hi - thanks for this, jschiwal! ( and centinul too ).

*** UPDATE... SUCCESS!!!! ****
QtPartEd to the rescue!!!
Fired that up and formatted the drive as ext3. The progress-bar ticked over - Yes - it's doing something!
The real breakthrough was this post by user "stress_junkie" (which I should have read in the first place, so sorry for the "noise".... :-) )
That user's tips -
a) Add the drive to /etc/fstab as follows -
/dev/sda1 /media/usbdisk defaults 0 0

b) As root, mount the drive and change owner and permissions -
mount /dev/sda1 /media/usbdisk
chown root:users /media/usbdisk
chmod 777 /media/usbdisk

I've just run my backup script to copy files to the drive, and success!
Here's the proof -

andy@obsidian:~$ df -h /media/400GB
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 367G 3.9G 345G 2% /media/400GB
andy@obsidian:~$

Thanks all for your help!

Last edited by mooseman; 05-18-2007 at 03:32 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
External Hard Drive does not give me the permission to write erockallstar Linux - Newbie 22 01-29-2007 03:40 PM
Can't read external hard drive alrymala Linux - Security 1 10-23-2005 01:42 PM
Write permissions for external hard drive kg4ysy Linux - Hardware 1 05-19-2005 05:36 AM
Write to external USB hard drive Rob Roye Linux - Software 6 07-06-2004 04:15 PM
read external hard drive mccclxxxv Linux - Hardware 4 04-21-2004 06:15 PM


All times are GMT -5. The time now is 01:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration