LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 04-04-2005, 10:22 PM   #1
djljjm
Member
 
Registered: Nov 2004
Distribution: Fedora 3
Posts: 77

Rep: Reputation: 15
external hard drive permissions


I finally got manually mounted my 250 gig external hard drive...everything is working except that I can't delete or write to the drive from any user other than SU. I'm not sure what I did wrong or how to fix it....my /etc/fstab for the device looks like this

/dev/sda1 /media/external vfat
defaults,users,auto,umask=000 0 0

I'm kind of a newbie so if anyone knows how to fix this problem please attempt to explain it kind of in detail....sorry if this is an inconvenience...I've tried a few things and nothing seems to be working. THANK YOU


djljjm
 
Old 04-05-2005, 06:17 PM   #2
squisher
Member
 
Registered: Apr 2005
Location: Abq, NM
Distribution: Debian, Ubuntu
Posts: 40

Rep: Reputation: 15
The umaks=000 should take care of it and I'm not sure why it doesn't.
What exactly are the permissions when you mount it? Do an ls -ld /media/external after you mounted it and post the result.
Also, why don't you just mount the drive with the user that you want to use it with? That's usually what you do when you specify the 'user' option in the fstab. So don't do it as root, rather mount it with your regular user.
 
Old 04-05-2005, 08:10 PM   #3
djljjm
Member
 
Registered: Nov 2004
Distribution: Fedora 3
Posts: 77

Original Poster
Rep: Reputation: 15
ls -ld on device came up with the following
drwxr-xr-x 2 root root 4096 Apr 4 09:43 /mnt/external

I tried mounting it as non su and it gave me the following error
mount: only root can do that
 
Old 04-05-2005, 09:42 PM   #4
squisher
Member
 
Registered: Apr 2005
Location: Abq, NM
Distribution: Debian, Ubuntu
Posts: 40

Rep: Reputation: 15
As a regular user you need to run 'mount /media/external'. If the fstab entry really has a 'user' in the options field, this should work just fine.
 
Old 04-06-2005, 12:51 AM   #5
djljjm
Member
 
Registered: Nov 2004
Distribution: Fedora 3
Posts: 77

Original Poster
Rep: Reputation: 15
I did this..."mount /media/external (new place mounted) and it gave the error which I listed before.
 
Old 04-06-2005, 02:44 AM   #6
nnsg
Member
 
Registered: Apr 2004
Distribution: Slackware 9.1/10.1, Mandrake 9.1/10.1
Posts: 75

Rep: Reputation: 15
Re: external hard drive permissions

Hi djljjm,

Just a thought.... is this entry in the fstab actually splitted into 2 lines?


Quote:
Originally posted by djljjm
/dev/sda1 /media/external vfat
defaults,users,auto,umask=000 0 0
 
Old 04-06-2005, 10:57 AM   #7
djljjm
Member
 
Registered: Nov 2004
Distribution: Fedora 3
Posts: 77

Original Poster
Rep: Reputation: 15
yes it is, is this a problem? I have another drive (actually a partition on my first drive) that is in two lines and works fine
 
Old 04-06-2005, 11:34 AM   #8
squisher
Member
 
Registered: Apr 2005
Location: Abq, NM
Distribution: Debian, Ubuntu
Posts: 40

Rep: Reputation: 15
Quote:
Originally posted by djljjm
I did this..."mount /media/external (new place mounted) and it gave the error which I listed before.
What do you mean by new place mounted? You really only have to type mount /media/external, because then mount looks everything up in /etc/fstab. If you give mount two arguments, then it thinks it is a manual mount, which only root can do.
 
Old 04-06-2005, 11:36 AM   #9
squisher
Member
 
Registered: Apr 2005
Location: Abq, NM
Distribution: Debian, Ubuntu
Posts: 40

Rep: Reputation: 15
Re: Re: external hard drive permissions

Quote:
Originally posted by nnsg
Hi djljjm,

Just a thought.... is this entry in the fstab actually splitted into 2 lines?
No, it has to be one line. What might be happening to you is that some editors display it as "two" lines if the line is too long for your current console, but nonetheless it has to be one line and it still might be even though it is displayed as two lines. What editor are you using?
 
Old 04-06-2005, 12:55 PM   #10
djljjm
Member
 
Registered: Nov 2004
Distribution: Fedora 3
Posts: 77

Original Poster
Rep: Reputation: 15
gedit
 
Old 04-06-2005, 12:57 PM   #11
djljjm
Member
 
Registered: Nov 2004
Distribution: Fedora 3
Posts: 77

Original Poster
Rep: Reputation: 15
tried one line and same error came up
 
Old 04-06-2005, 01:03 PM   #12
djljjm
Member
 
Registered: Nov 2004
Distribution: Fedora 3
Posts: 77

Original Poster
Rep: Reputation: 15
IT WORKED! Thanks! I've had at least 10 people try to help me and that was the problem...one line...thanks again
 
Old 04-06-2005, 02:23 PM   #13
squisher
Member
 
Registered: Apr 2005
Location: Abq, NM
Distribution: Debian, Ubuntu
Posts: 40

Rep: Reputation: 15
You're welcome , glad it works now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Not able to set write permissions on external hard drive. jpen8560 Linux - Hardware 19 03-22-2006 11:44 AM
Installing grub to external USB hard drive for later use as internal hard drive dhave Linux From Scratch 2 12-10-2005 09:48 AM
no permissions to external hard drive Maxtor OneTouche II roler Linux - Hardware 4 11-08-2005 09:04 AM
Write permissions for external hard drive kg4ysy Linux - Hardware 1 05-19-2005 06:36 AM
Setting permissions on an external USB hard drive so that all users can read from it? Pi Man Linux - Hardware 2 09-07-2004 10:50 PM


All times are GMT -5. The time now is 03:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration