LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 04-11-2007, 02:27 PM   #1
esspy4
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 7.04
Posts: 10

Rep: Reputation: 0
External Hard Drive is mounted but I can't access - pls help! (newbee)


I just purchased a new ext hard drive "Western Digital Essential Edition 250 GB USB2". It came preformated in FAT32 and had some software on it. I used gparted to format it as ext3 and then mounted it in /media/usbdisk It shows as /dev/sda1 in gparted.

I used disklabeltype msdos and have no flags set.
When i open the drive there's a file folder there "lost+found" with a small red box with an "x" in it. When i try to open it it says "You do not have the permissions necessary to view the contents of "lost+found"."

Essentially, it's there but I can't store anything on it...

Can someone help a newbee please?
 
Old 04-11-2007, 02:31 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
The lost+found directory is for system use. It is used on ext2 and ext3 file systems. When the disk is checked by using fsck the lost file fragments are stored in the lost+found directory.

Try to either create a file or a directory at the same level as the lost+found directory. If you don't have permission for that then post back to this thread.

 
Old 04-11-2007, 02:33 PM   #3
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
The lost and found is normal. When you try to copy a file to the drive what happens?
 
Old 04-11-2007, 03:54 PM   #4
esspy4
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 7.04
Posts: 10

Original Poster
Rep: Reputation: 0
I can't copy a file to it or create a folder in it. Also I noticed that the "permissions" tab in the properties box for it, the "owner" and "group" are set as "root".....
 
Old 04-11-2007, 05:15 PM   #5
Road_map
Member
 
Registered: Jan 2007
Distribution: Slackware
Posts: 341

Rep: Reputation: 31
Did you add an entry in /etc/fstab?
 
Old 04-11-2007, 05:25 PM   #6
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
What destro are you running? Are you trying to copy the files as root? If the permissions are set as root only then only root can do anything.
 
Old 04-11-2007, 05:46 PM   #7
esspy4
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 7.04
Posts: 10

Original Poster
Rep: Reputation: 0
What's a "destro" ?

Here's what I added to /etc/fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hda2
UUID=631dde64-165c-4cae-a7f8-0829f199e5f1 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda5
UUID=b8cb67f0-ea6f-4e4c-9be5-26c894e369b3 none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/ /media/floppy0 auto rw,user,noauto 0 0
/dev/hda1 /media/windows vfat rw
/dev/sdb1 /media/usbdisk ext3 rw
 
Old 04-11-2007, 06:27 PM   #8
esspy4
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 7.04
Posts: 10

Original Poster
Rep: Reputation: 0
The problem really seems to be that the permissions for useage of the drive are for some reason set to root -how did that happen? and how can I change it to acess the drive?
 
Old 04-11-2007, 07:02 PM   #9
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
What version of linux are you running? Fedora, ubuntu, yellow dog? As well as version of that type ie: Fedora core 6, suse 10.1,etc.

Destro was a typo for distro as in distribution.

Last edited by lazlow; 04-11-2007 at 07:06 PM.
 
Old 04-11-2007, 07:15 PM   #10
esspy4
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 7.04
Posts: 10

Original Poster
Rep: Reputation: 0
I'm using ubuntu 6.10
 
Old 04-11-2007, 07:25 PM   #11
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Quote:
Originally Posted by esspy4
What's a "destro" ?
A destro is what someone uses when they can't spell distro a.k.a. distribution. (Red Hat, SuSE, Debian, Slackware, et. al.)
Quote:
Originally Posted by esspy4
Here's what I added to /etc/fstab
/dev/sdb1 /media/usbdisk ext3 rw
This is what I would do.

Log on as root and change the line in your /etc/fstab to the following:
Code:
/dev/sdb1    /media/usbdisk   ext3   defaults   0  0
Then mount the partition and change the owner and permissions on the disk as follows.
Code:
mount /dev/sdb1 /media/usbdisk
chown root:users /media/usbdisk
chmod 777 /media/usbdisk
Then normal users can create, edit, and delete files and directories on the partition. If you want a bit more security you can change the last 7 to a zero in the chmod command where chmod 777 changes to chmod 770.

Let us know if you continue to have problems.

Last edited by stress_junkie; 04-11-2007 at 09:21 PM.
 
Old 04-11-2007, 08:13 PM   #12
esspy4
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 7.04
Posts: 10

Original Poster
Rep: Reputation: 0
Wow!! thanks Stress Junkie...that works. I've been working on this all day and was becoming quite frustrated. What beer do you drink, I'll send you a cold one
Thanks again you're my hero!!

If you don't mind could you tell me what the extra security would be by changing the the mode settings that you mention (I used the 777 settings.

Thanks you've made my day.
 
Old 04-11-2007, 09:03 PM   #13
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Quote:
Originally Posted by esspy4
If you don't mind could you tell me what the extra security would be by changing the the mode settings that you mention (I used the 777 settings.
I'm glad that I could help. That's the way I set up all of my mount points.

The security has to do with what the 777 means. You probably already know that the first number controls the access by user/owner of the file or directory, the seond number controls the access by the group that owns the file or directory, and the third number controls access by anyone that does not fit into the first two categories. Since we made the directory owned by the users group and all of your normal user accounts will belong to this group then this is how we allowed access to this directory by normal users.

Accounts that don't belong to either root or users are things like the nobody account, ftp account, mail account, and other accounts for various functions. The nobody account is usually used to run the updatedb utility that creates the database for the locate utility. If you allow accounts that are not root and are not users to read the directory then the files in that partition will be listed in the database used by the locate utility. That may or may not be a problem. Business computers with several user accounts would not allow files owned by one user to be seen by other users. The locate utility would show any user any file that the nobody account can see. So there is a potential for a privacy leak by means of the locate utility.

Actually, even if you want the files in that partition to be visible to accounts that are not root and are not users you probably still don't want those accounts to create files so you should restrict that third number to read + execute for directories and read for files. That would be a number 5 for directories and 4 for files.
Code:
chmod 775 /media/usbdisk
It's just an idea.

Last edited by stress_junkie; 04-11-2007 at 09:26 PM.
 
Old 07-12-2007, 05:51 AM   #14
fedorafreak62
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Rep: Reputation: 0
I recently installed fedora 7 from a live cd. I have a cdrom & a cd writer on my system. My system recognises both my cd drives, but it cant read the cdrom. It reads the cd writer. How can I make my computer read the CDROM? my etc/ftab is as follows

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
 
  


Reply

Tags
mount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ext3 partition on external USB hard drive mounted, but only root access allowed leontini Linux - Hardware 4 02-17-2006 02:54 AM
NTFS external hard drive, mounted but not accessible jmrother Linux - Newbie 7 02-01-2006 10:41 PM
Can't access external hard drive. new@this Linux - Hardware 0 12-11-2003 06:43 AM
External Hard Drive Not Mounted during Install chazdg Mandriva 5 10-30-2003 12:02 PM
External Drive Mounted, Can't access as a user thewaker Linux - Hardware 4 08-14-2003 04:26 PM


All times are GMT -5. The time now is 05:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration