LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-29-2003, 09:29 AM   #1
cevjr
Member
 
Registered: Jul 2003
Location: USA
Distribution: Slack 12.2 and Ubuntu 9.04
Posts: 61

Rep: Reputation: 15
EPSON Stylus C82 not working even after ins CUPS and Foomatic filters


I just bought an EPSON Stylus C82 (I use the USB) and am trying to install it on my Slackware v 9

FIrst I tried /usr/share/apsfilter/SETUP
I picked the gimp-print-ijs driver and chose Epson Stylus C80 bec there was no C82. RESULT - Printer did not work.

Next I tried what one of the members suggested: I followed this exactly. RESULT -printer printed garbage when I ran the test: Can you please verify my steps and make any suggestions that might help. - THanks

1.) Download the latest cups (cups-1.1.19-i386-1.tgz)
2.) Install the cups package by doing:# installpkg cups-version.tgz
3.) Reboot.
4.) Go to Linuxprinting.org. download PPD for Epson C82 and save the file to /usr/share/cups/model. The file should be in a model.ppd format, if not, then rename it to my_printer.ppd.
5.) Restart cups by doing # /etc/rc.d/rc.cups restart.
6.) download the latest foomatic-filters.tar.gz (foomatic-filters-3.0.0.tar.gz). Then do the following:
# tar -xzf foomatic-filters-3.0.0.tar.gz
# ./configure
# make
# cp foomatic-rip /usr/lib/cups/filter/
7.) Open your favorite browser and point it to http://localhost:631
8.) Under Administrative Tasks, add your printer. Just follow the directions.
Can you please verify my steps and make any suggestions that might help. THanks
-C
 
Old 09-29-2003, 02:00 PM   #2
cevjr
Member
 
Registered: Jul 2003
Location: USA
Distribution: Slack 12.2 and Ubuntu 9.04
Posts: 61

Original Poster
Rep: Reputation: 15
does any one out there have this printer working under Slack. I really need some help with this...I'm sure I have missed a step but I can't seem to see my error. I know its my fault as everything else I have done with LInux eventually works.
Thanks.
 
Old 09-29-2003, 03:08 PM   #3
cevjr
Member
 
Registered: Jul 2003
Location: USA
Distribution: Slack 12.2 and Ubuntu 9.04
Posts: 61

Original Poster
Rep: Reputation: 15
I got it to work...It will only work via the Parallel cable. It will not work on the USB port /dev/usb/lp0

I would like it to work via USB

Does anyone have any suggestions?

-C
 
Old 10-31-2003, 08:15 PM   #4
nightoil
LQ Newbie
 
Registered: Oct 2003
Location: Thailand
Distribution: Slackware 10.0
Posts: 29

Rep: Reputation: 15
I too have an Epson C82 and followed your list for installation as above -CUPS-Foomatic etc. and can get it available in CUPS admin page

But I can't even get mine to print on a parallel port, I enabled the logging and get a message about 'Hint- do you have ESP-gs installed ?' I certainly have gs installed 'whereis' says /usr/bin/gs /usr/share/gs I'd appreciate any hints on how you got yours working on a parallel port

P
 
Old 11-01-2003, 11:42 AM   #5
cevjr
Member
 
Registered: Jul 2003
Location: USA
Distribution: Slack 12.2 and Ubuntu 9.04
Posts: 61

Original Poster
Rep: Reputation: 15
the instructions abovie should work for the Epson C82 working on the parallel port...

After you install the foomatic drivers...and you go to the CUPS admin page, make sure you select the "Epson Stylus C82 Foomatic/gimp-print-ijs (recommended)" from the list of available printers.

After that you really should be ok.

USB does not work for me.
 
Old 11-01-2003, 11:47 AM   #6
cevjr
Member
 
Registered: Jul 2003
Location: USA
Distribution: Slack 12.2 and Ubuntu 9.04
Posts: 61

Original Poster
Rep: Reputation: 15
oh wait...i know what the problem is....
see step 6d : cp foomatic-rip and foomatic-gswrapper to /usr/lib/cups/filter/
make sure you copy both the foomatic-rip and foomatic-gswrapper
or you can just run make install after step 6c make

PRINTER
Download the latest cups (cups-1.1.19-i386-1.tgz)
2.) Install the cups package by doing:# installpkg cups-version.tgz
3.) Reboot.
4.) Go to Linuxprinting.org. download PPD for Epson C82 and save the file to /usr/share/cups/model. I saved it as my_printer.ppd.
5.) Restart cups by doing # /etc/rc.d/rc.cups restart.
6.) download the latest foomatic-filters.tar.gz (foomatic-filters-3.0.0.tar.gz). Then do the following:
a. tar -xzf foomatic-filters-3.0.0.tar.gz
b. ./configure
c. make
d. cp foomatic-rip and foomatic-gswrapper to /usr/lib/cups/filter/
7.) Open browser and point it to http://localhost:631
8.) Under Administrative Tasks, add your printer. Just follow the directions.
 
Old 11-01-2003, 09:38 PM   #7
nightoil
LQ Newbie
 
Registered: Oct 2003
Location: Thailand
Distribution: Slackware 10.0
Posts: 29

Rep: Reputation: 15
Thanks for that !

It was the foomatic-gswrapper that wasn't where it should be. I was thinking along the lines that something wasn't telling cups where to find gs.

On a similar point I found the page

http://www.turboprint.de/english.html

I downloaded their program and it worked a treat straight off. So now I've even got a choice. I haven't tried turboprint for the USB ports yet, after 6 days of trying I was happy to have something coming out of my printer !

Regards
-P
 
Old 03-17-2004, 03:54 PM   #8
simbolo
Member
 
Registered: Mar 2002
Location: US, CT
Distribution: Gentoo
Posts: 56

Rep: Reputation: 15
ok, i have a stylus c82, clackware 9.0 with upgraded packeges, and vanilla 2.6.4 i have followed the instructions above and when i try http://localhost:631 i get a "Not Found
The requested resource was not found on this server." or if i go to http://127.0.0.1:631/printers it just times out,or if i try http://127.0.0.1:631/admin it asks me for user and pass then it times out.
Im postitive cupsd is running cause i did a "ps ax".

when i run "lpc status" reports :

lp:
printer is on device 'parallel' speed -1
queuing is enabled
printing is enabled
no entries
daemon present

i have configured this printer using kcontrol, if i hit test after printer configuration it says that "test page has benn successfully sent to the printer" but nothing happens, when i open txt file in kedit for example and hit print it says printing really fast but does nothing, then when i check "lpc status" it reports :

lp:
printer is on device 'parallel' speed -1
queuing is enabled
printing is enabled
no entries
daemon present

again as if no request was sent. I also tried printing in gimp, it only works if i select one of the Epson Stylus drivers in the printer setup box, but the picture comes out really shitty.

does anyone have any idea as to why cups is not responding to any queing requests.

Last edited by simbolo; 03-17-2004 at 06:39 PM.
 
Old 03-18-2004, 04:33 PM   #9
cevjr
Member
 
Registered: Jul 2003
Location: USA
Distribution: Slack 12.2 and Ubuntu 9.04
Posts: 61

Original Poster
Rep: Reputation: 15
I would check again and make sure you have cups installed.

open up the terminal and do a pkgtool
select view packages and scroll down to see if it has been installed.

If not, follow the instructions above precisely including the reboot. I know its silly but I did finally get my C82 to work proerly.

**I double checked everythiung and just removed and reinstalled cups just to make sure and I'm telling you this should work.

Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
EPSON c82 printer problems with CUPS aznkwyjibo007 Linux - Hardware 0 02-27-2005 10:39 AM
Epson c82 printer and CUPS simbolo Linux - Hardware 0 03-18-2004 11:21 AM
Epson Stylus C82 - Colour Settings!! Phorem Linux - Hardware 0 01-19-2004 05:00 PM
Epson Stylus C82 - got it 2 work! but not via USB cevjr Linux - Hardware 1 10-16-2003 09:01 PM
Epson Stylus Color 600 doens't like CUPS jmcvicar Linux - General 0 06-15-2001 09:52 AM


All times are GMT -5. The time now is 06:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration