LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-03-2012, 12:31 PM   #1
Joydeep Bakshi
Member
 
Registered: May 2007
Distribution: debian
Posts: 62

Rep: Reputation: 15
epson C20SX prints WHITE PAGE !!!


Dear list,

I have a epson C20SX parallel printer. I have bought a parallel to usb cable so that I can use it with my laptop. After connecting the cable I have seen the new H/W has been detected.

From lsusb

`````````````````````
Bus 001 Device 069: ID 067b:2305 Prolific Technology, Inc. PL2305 Parallel Port

```````````````````````

And the node has created as /dev/usb/lp1

crw-rw---T 1 root lp 180, 1 Jun 2 22:45 /dev/usb/lp1


Now I have checked by both cups and system-config-printer; which detected an unknown printer. But not the printer model. Hence I have selected the printer model and from its database the driver i.e. "epson stylus C20Sx" . Unfortunately both the application prints blank test pages. Is there anyone having the same issue.
Can you suggest any fix please ?

Thanks
 
Old 06-04-2012, 08:34 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Have a look at this thread. The user got the printer working by configuring it through cups. I suspect getting the device URI correct may help.

The thread -->http://ubuntuforums.org/showthread.php?p=11630251

Hope this helps.
 
Old 06-04-2012, 08:48 AM   #3
Joydeep Bakshi
Member
 
Registered: May 2007
Distribution: debian
Posts: 62

Original Poster
Rep: Reputation: 15
Yes I did, but still the same blank page :-(
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HP deskjet 940c on linksys printserver prints alternating good page and bad page frogger Linux - Hardware 2 03-14-2011 02:54 PM
Printer prints white space very slowly Ipozya Linux - Hardware 2 02-21-2011 10:53 AM
Gutenprint Epson R300 CD prints are off mark sirscott Linux - Software 0 01-22-2010 12:04 AM
When Epson printer prints endless jibber how do you stop it? tmitch70377 Linux - Newbie 4 01-24-2007 12:40 PM
Epson Stylus Color 880 prints blanks premsaggar Linux - Hardware 0 12-17-2003 06:06 PM


All times are GMT -5. The time now is 10:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration