LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   EP9302 Boot problem (http://www.linuxquestions.org/questions/linux-hardware-18/ep9302-boot-problem-4175450290/)

abdberkana 02-15-2013 10:18 AM

EP9302 Boot problem
 
Hi,

Hope that i m in the right place, even if i had made a mistake on where i have to publish my request i hope that you help me in my problem.

I have designed a custom board based around EP9302 the same as the cirrus logic evaluation board EDB9302A but only missing usb slave and audio and power supply where i use some LM317 with high current transistor.

When i power on the board the LED flushes means that the mcu is alive.

I had used the utility download.exe to download redboot.bin that come with in the package linux_1-0-3-9302a.tar that i had got from arm.cirrus.com website.

By pressing reset and boot from srial button the download process is fine and the download utility upload the first boot stage and then download the redboot.bin.

After downloading redboot every things looks fine as redboot identify the flash and sram manufacturer.

When every thing is done i press the reset button to reset the board and boot the redboot image.

After resetting the board the MCU became in short circuit ( about 1 ohm of load impedance). I had got the same problem for 5 boards with different MCU newly purchased. I dont know what is the problem exactly.

So my question is :

- Have some one got the same problem before ?
- Have some one any idea about the problem ?
- Have i missed some thing to do ??
- Do redboot can harm the MCU if it is not configured correctly in compiling time ?
- Do i need to compile my own redboot binary file to solve the problem ?

Please help me this problem drive me crazy.

Thanks.


All times are GMT -5. The time now is 11:37 PM.