LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Emacs giving error on delete-selection-mode (http://www.linuxquestions.org/questions/linux-hardware-18/emacs-giving-error-on-delete-selection-mode-867916/)

ravi.xolve 03-11-2011 08:33 AM

Emacs giving error on delete-selection-mode
 
I am using Emacs 23.2.1 on Opensuse 11.4. I have enabled delete selection mode, but I get this error on it :

Code:

Symbol's function definition is void: delete-selection-mode
Earlier it was working on Ubuntu 10.10 which uses an older version on emacs.

hda7 03-11-2011 09:45 AM

It looks like there is no such function as delete-selection-mode in that version (or something didn't load right). Did you check the changelog? That function may have been removed or renamed between the two versions you had.

hda7 03-11-2011 09:52 AM

If delete-selection-mode wasn't moved or deleted, try
Code:

M-: (require 'delsel)<return>
which should load the file providing delete-selection-mode. If this command fails, the "delsel.el" file may have been deleted accidentally (or is no longer provided with emacs). If it succeeds, but delete-selection-mode still fails with an error, look at the file "delsel.el" and see if the mode name has changed.


All times are GMT -5. The time now is 11:27 AM.