LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-22-2013, 12:01 PM   #1
VoodooDali
Member
 
Registered: Mar 2013
Location: Chicago, IL, USA
Distribution: Mageia
Posts: 35

Rep: Reputation: 3
Question Editing my GPU's power profile (AMD 5870)


Hello:

My GPU (AMD Radeon Mobility HD 5870) runs very hot (about 187 degrees F) while using the open-source "radeon" driver. I could switch to the AMD Catalyst Driver but that no longer works properly in Netflix, YouTube, ESPN3 and a bunch of other video applications.

I can cool down my GPU by running the following command as root:

Code:
echo low > /sys/class/drm/card0/device/power_profile
However, this is a temporary fix. Exiting su/root mode causes my sound to cut out. And, next time I reboot, my power profile will be set back to "default" which runs very hot.

Anyone know how I can *permanently* alter my power profile? (There really needs to be a GUI-based tool for this tweak :lol: ) Thanks!
 
Old 04-22-2013, 01:24 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,580
Blog Entries: 2

Rep: Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037
Just add the above code to your rc.local file, this way it will be run automatically at boot.
 
Old 04-22-2013, 05:01 PM   #3
VoodooDali
Member
 
Registered: Mar 2013
Location: Chicago, IL, USA
Distribution: Mageia
Posts: 35

Original Poster
Rep: Reputation: 3
Unfortunately Mageia uses systemd, which (IIRC) doesn't allow rc.local to work.

To test this I created an rc.local file in /etc/rc.d/, added the command, attempted to enable the rc-local.service in systemctl, and got a lengthy error message instead.

Stumped. :/
 
Old 04-22-2013, 05:31 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,580
Blog Entries: 2

Rep: Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037
I don't know much about systemd, but it may help if you post the error-message you got.
 
Old 04-22-2013, 05:41 PM   #5
VoodooDali
Member
 
Registered: Mar 2013
Location: Chicago, IL, USA
Distribution: Mageia
Posts: 35

Original Poster
Rep: Reputation: 3
Here it is:

Code:
The unit files have no [Install] section. They are not meant to be enabled
using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).
 
Old 04-22-2013, 05:52 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,580
Blog Entries: 2

Rep: Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037Reputation: 4037
This may help to create a correct unit file for your purpose: http://forums.fedoraforum.org/showthread.php?t=282446
 
1 members found this post helpful.
Old 04-22-2013, 06:01 PM   #7
VoodooDali
Member
 
Registered: Mar 2013
Location: Chicago, IL, USA
Distribution: Mageia
Posts: 35

Original Poster
Rep: Reputation: 3
I'll give that a try as soon as I get a second wind. thanks

EDIT: The procedure from the Fedora link seems to have worked. Although there were some error messages in response to both the "enable" and "start" commands, upon reboot the required string was indeed passed to my power profile. Thanks!

Last edited by VoodooDali; 04-22-2013 at 08:19 PM.
 
  


Reply

Tags
amd, ati, driver, heat, radeon


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New GPU, no X (slack 13.37 / AMD HD 6800 Series) Eerie Linux - Hardware 2 07-23-2012 03:35 AM
6-core ATI CPU, Radeon 5870 GPU and 16GB RAM..which 64-bit Linux is best for me? Whatthefrack Linux - Newbie 10 07-26-2011 01:38 PM
LXer: AMD Launches Open GPU Website LXer Syndicated Linux News 0 02-13-2008 09:10 PM
LXer: AMD Preparing For Another GPU Documentation Release LXer Syndicated Linux News 0 11-16-2007 01:00 AM
LXer: AMD: GPU Specifications Without NDAs! LXer Syndicated Linux News 0 09-11-2007 01:42 AM


All times are GMT -5. The time now is 06:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration