LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-07-2006, 12:23 PM   #1
zcapx32
LQ Newbie
 
Registered: Jun 2006
Posts: 10

Rep: Reputation: 0
Editing my fstab .... please help


Ok so i wish to set my computer so that when i plug in my 80gb usb drive it will automount (currently using "mount /dev/sda5"). Below is a copy of my /etc/fstab file

Code:
/dev/hda5            swap                 swap       defaults              0 0
/dev/hda6            /                    reiserfs   acl,user_xattr        1 1
/dev/hda7            /home                reiserfs   acl,user_xattr        1 2
/dev/hda1            /windows/C           ntfs       ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda5            /windows/D           vfat       users,gid=users,umask=0002,utf8=true 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
I also have a dodgy drive D that sits on my desktop as a shortcut by when i click on it, it say "could not create dbus message"


So my question is what should the fstab look like so that the usb will mount automatically when plugged in and how do i remove the D drive sitting on my desktop.


p.s i use suse 10.1 with gnome and xgl
 
Old 07-07-2006, 12:33 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,731
Blog Entries: 1

Rep: Reputation: 224Reputation: 224Reputation: 224
Change
Quote:
/dev/sda5 /windows/D vfat users,gid=users,umask=0002,utf8=true 0 0
to
Quote:
/dev/sda5 /windows/D vfat auto,users,gid=users,umask=0002,utf8=true 0 0
should do the trick.

I don't think I understand your second question.
 
Old 07-07-2006, 01:08 PM   #3
zcapx32
LQ Newbie
 
Registered: Jun 2006
Posts: 10

Original Poster
Rep: Reputation: 0
Ok, doing what you suggested above removed the hdd icon from my desktop labelled D but in order to get access to the usb drive i still need to do "mount /dev/sda5" so that clicking on the "80gb usb" icon allows access

Any ideas?

When i type "mount /dev/sda5" the desktop symbol change slightly!

When i Click on the "80gb usb" symbol that appears when i plug in my usb drive results in the following error message:


/dev/sda5 found in /etc/fstab



does this mean that two things are asigned the same /dev/sda5?

Last edited by zcapx32; 07-07-2006 at 01:11 PM.
 
Old 07-07-2006, 01:36 PM   #4
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian jessie/sid; OpenSuSE; Fedora
Posts: 1,593

Rep: Reputation: 162Reputation: 162
Auto mount using "auto" option in fstab only works on boot. If you have the USB drive plugged in before you boot, linux assigns it differently than if you use hotplug. I think what you meant to say is:

"/dev/sda5 not found in /etc/fstab"

When you plug in the USB drive, do

dmesg | tail

and see where hotplug assigned it. Then, manually mount it, or make a line in fstab for that device, too.
 
Old 07-07-2006, 01:50 PM   #5
zcapx32
LQ Newbie
 
Registered: Jun 2006
Posts: 10

Original Poster
Rep: Reputation: 0
when i type dmesg | tail it says:

sda: sda1 <sda5>

So i am not to sure what that means?


That problem I have is before I changed suse 10.1 to run with xgl, plugging in my usb drive allowed me immediate access without the need for typing "mount /dev/sda5". Now when i plug it in a icon appears on the desktop and if i double click it, it says "/dev/sda5 found in /etc/fstab" (checked it again). When i then type "mount /dev/sda5" ithe icon changes and allows me to access it.


What I am looking to do is edit my fstab so that when linux is already booted plugging in my usb drive allows me to access it without out opening the terminal and typing "mount /dev/sda5"

IS this possible anymore?


P.s I am a newbie! So I would not know what to added to fstab to mount the usb device!


p.p.s Right clicking on the icon and selecting "mount" will produce the "/dev/sda5 found in /etc/fstab" error also?

Last edited by zcapx32; 07-07-2006 at 02:08 PM.
 
Old 07-07-2006, 03:03 PM   #6
zcapx32
LQ Newbie
 
Registered: Jun 2006
Posts: 10

Original Poster
Rep: Reputation: 0
Help Me Anyone?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
editing the fstab geckoguykc Linux - Newbie 3 05-03-2006 06:58 PM
fstab editing similar Linux - Newbie 4 03-15-2006 05:52 AM
Editing etc/fstab- yet again:-) hitest Slackware 7 04-21-2005 12:50 PM
editing the etc/fstab firefightin4fun Linux - Newbie 8 09-20-2003 10:53 PM
Fstab editing Ando Linux - General 4 06-29-2003 05:17 PM


All times are GMT -5. The time now is 02:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration