LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-05-2012, 01:01 PM   #1
Chris.Bristol
Member
 
Registered: Jul 2011
Distribution: elementary OS CrunchBang
Posts: 151

Rep: Reputation: 3
DVD writer won't eject


My DVD writer won't eject. I had the same problem with a different drive on a different PC and wrecked about twenty disks trying to get them out with the paperclip method. This time I think it started after I was trying to write on a disk and the computer couldn't handle it and got stuck in a loop which it couldn't get out of.
I was on Ubuntu 11.10 but I have just switched to Debian 6.0.4 in the hope that it would fix it.

I've looked for relevant threads, but most of them are old and none have solved the problem.

This thread:
http://www.linuxquestions.org/questi...d-line-726616/

Made a suggestion in Message 34 (last but one) to type: ps aux |grep gvfsd-cdd

Which resulted in:
root 3928 0.0 0.0 3304 764 pts/1 S+ 18:35 0:00 grep gvfsd-cdd

Which I imagine is a process running and owning the device. It suggests that I should kill that proceess, I think I should type: kill 3928
but I'm a bit wary about trying that without a little advice!

This is the relevant entry in fstab:
/dev/scd0 /media/cdrom0 udf,iso9660 users,noauto 0 0

This was suggested somewhere:
/dev/hdc /mnt/cd iso9660,udf ro,user,noauto,noexec,unhid
But I've no idea whether that is safe to try.

It's an infuriating problem, particularly since it concerns such a simple function!

Last edited by Chris.Bristol; 02-05-2012 at 02:02 PM.
 
Old 02-05-2012, 02:42 PM   #2
jthill
Member
 
Registered: Mar 2010
Distribution: Arch
Posts: 209

Rep: Reputation: 65
I don't see eject -i0 (that's a zero) in that thread, try that then eject, here's hoping...
 
Old 02-05-2012, 03:16 PM   #3
Chris.Bristol
Member
 
Registered: Jul 2011
Distribution: elementary OS CrunchBang
Posts: 151

Original Poster
Rep: Reputation: 3
This is what happens;

root@Asus:/home/chris# eject -i0
CD-Drive may be ejected with device button

The tray does not open.

It may be relevant to mention that a motor runs whenever I try to eject, but there is a clunk as though some lock is still in place. It's as though there need to be two actions and they aren't synchronised.

There's no mechanical problem because it ejects when the ribbon cable is disconnected.

Last edited by Chris.Bristol; 02-05-2012 at 03:18 PM.
 
Old 02-05-2012, 05:49 PM   #4
jthill
Member
 
Registered: Mar 2010
Distribution: Arch
Posts: 209

Rep: Reputation: 65
Did you try the -i0 then a plain eject? I have seen that fail, but I've also seen it work. One other thing to try is (I'm not on linux atm so you'll have to dig for this) explicitly specifying a driver or interface named generic-mmc or generic-mmc-raw or something along those lines, ring changes on those options for whatever's doing your burning. iirc when I did that it didn't fix the immediate problem, I still had to reboot, but the problem stopped recurring.
 
Old 02-05-2012, 06:21 PM   #5
Chris.Bristol
Member
 
Registered: Jul 2011
Distribution: elementary OS CrunchBang
Posts: 151

Original Poster
Rep: Reputation: 3
jthill
I typed eject -i0 then pressed the eject button.

Sorry - I don't know what Linux atm is or how to install a driver.

Last edited by Chris.Bristol; 02-05-2012 at 06:47 PM.
 
Old 02-05-2012, 08:32 PM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,111

Rep: Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985
Try (as root) "eject /dev/sr0" (that's a zero)
 
Old 02-05-2012, 09:42 PM   #7
Chris.Bristol
Member
 
Registered: Jul 2011
Distribution: elementary OS CrunchBang
Posts: 151

Original Poster
Rep: Reputation: 3
syg00 I have tried that without success.

Would it be worth trying the kill command or changing the line in fstab as mentioned in my original post?
 
Old 02-05-2012, 11:44 PM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,111

Rep: Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985
No, your kill idea won't work - that process is just the grep command you entered.
Try "eject /dev/scd0" (sorry about that, I don't use Debian, and I wasn't reading obviously).
 
Old 02-06-2012, 12:44 AM   #9
EDDY1
Guru
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,087

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
Try rebooting the computer & eject right when computer is starting before dvd is mounted.

Last edited by EDDY1; 02-06-2012 at 12:46 AM.
 
Old 02-06-2012, 12:48 AM   #10
jthill
Member
 
Registered: Mar 2010
Distribution: Arch
Posts: 209

Rep: Reputation: 65
atm is just "at the moment" :-)

The drivers I'm referring to are already installed, they're choices of how to talk to the hardware you have. Sometimes you have to give your tool a hint. What are you actually using to talk to the dvd burner? gvfs is a gnome thing, are you using brasero? I was using command-line tools, wodim via genisoimage, there's a driver= option for those times when the hardware's not playing nice. If you're using a gui burner I hope someone can help you find where to pick the access method.
 
Old 02-06-2012, 12:14 PM   #11
Chris.Bristol
Member
 
Registered: Jul 2011
Distribution: elementary OS CrunchBang
Posts: 151

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by EDDY1 View Post
Try rebooting the computer & eject right when computer is starting before dvd is mounted.
This was suggested one of the threads I looked at but it doesn't work. Eject only works if I disconnect the ribbon cable before switching on. This suggests to me that it's not a hardware or firmware problem.

Last edited by Chris.Bristol; 02-06-2012 at 12:23 PM.
 
Old 02-06-2012, 12:35 PM   #12
Chris.Bristol
Member
 
Registered: Jul 2011
Distribution: elementary OS CrunchBang
Posts: 151

Original Poster
Rep: Reputation: 3
jthill
I know what a driver is, but I thought Linux organised them rather more slickly than other OSs I could mention so I haven't looked into them. I did see a tool in a menu once but it didn't list any drivers, so I suppose you have to download them from somewhere.

I usually use brasero, but when the problem started I also tried K3B because I know that it has more functionality when you need it. That didn't work either, but it does give a report - nothing useful in it unfortunately.

I've just used a paperclip to open the drive, put a disk in, pressed the button and it ejected successfully.

It's now not working again.
 
Old 02-06-2012, 05:19 PM   #13
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 159Reputation: 159
Are you unmounting the drive before trying to eject the disc?
 
Old 02-06-2012, 06:45 PM   #14
jthill
Member
 
Registered: Mar 2010
Distribution: Arch
Posts: 209

Rep: Reputation: 65
Quote:
Originally Posted by Chris.Bristol View Post
jthill
I know what a driver is, but I thought Linux organised them rather more slickly than other OSs I could mention so I haven't looked into them. I did see a tool in a menu once but it didn't list any drivers, so I suppose you have to download them from somewhere.
I'm trying to get this thread around to finding some way way to do what you want to do so the problem you're having doesn't recur or at least you don't have to reboot to fix it. Please say what you were actually trying to do when your burner wedged this way, and how you went about it, so someone here can figure out an alternate route that will actually work. I've actually encountered the symptoms you're reporting, and solved them, but it was months ago for a one-off and I idiotically did not keep notes on what I did to fix it. So between you not saying what you want to do and me not remembering how I fixed this while doing what I wanted to do, the best I can offer is help trying to find your way out of this. Whatever the cause of the symptoms you're reporting, it's some very unusual combination of circumstances, and the thing to do now is to try to identify them. So far, the most concrete information you've given about those circumstances is "I think it started after I was trying to write on a disk" and that you usually use brasero but tried k3b after the problem already started "because I know that it has more functionality when you need it", but you don't say what you tried to do with it and don't post the results of what you tried. Surely you can see that you could hardly have made it more difficult to help you if you'd been trying.
 
Old 02-07-2012, 01:05 AM   #15
EDDY1
Guru
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,087

Rep: Reputation: 448Reputation: 448Reputation: 448Reputation: 448Reputation: 448
When I run this command it doesn't show root it shows my user name
Quote:
ps aux |grep gvfsd-cdd
edward 2355 0.0 0.0 3500 756 pts/0 S+ 23:06 0:00 grep gvfsd-cdd

Last edited by EDDY1; 02-07-2012 at 01:07 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DVD Writer won't burn DVD's spandey Linux - Hardware 7 01-13-2011 10:25 PM
Eject CD/DVD Media using Eject Button - Hal/Udev help v00d00101 Linux - Hardware 4 03-17-2008 03:04 PM
New DVD writer won't write; old dvd reader won't read. Tomermory Linux - Hardware 15 09-24-2007 11:20 AM
Cannot find DVD writer or get CD-writer to spin audio disk dgwebb Linux - Hardware 5 03-28-2005 05:00 PM


All times are GMT -5. The time now is 12:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration