LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   DVD-ROM on /dev/hdc (http://www.linuxquestions.org/questions/linux-hardware-18/dvd-rom-on-dev-hdc-165595/)

Impaler 04-02-2004 11:54 PM

DVD-ROM on /dev/hdc
 
Hi! I am using Mandrake 9.2 and I have realised that my DVD-ROM is located on /dev/hdc. When I mount the device, usind the icon on my desktop, everything works fine. I changed the mount point using Mandrakes Cotontrol Center and the icon on my desktop turned into a hard disk icon using for name the path I chosen for the mount point (/mnt/dvdrom). The most wierd thing is that when I try to erase the folder which I was using to mount my DVD-ROM, although I succeed after restarting the folder is still there!My questions are:

1)Is it ok that the DVD-ROM drive is located on /dev/hdc?
2)How can I change the icon on my desktop into a CD and rename it also?
3)How can I erase the folder that I was using for mount point?

motub 04-03-2004 03:19 AM

Quote:

Is it ok that the DVD-ROM drive is located on /dev/hdc?
If the DVD-ROM is the secondary master device, then it's called /dev/hdc. There's no "right" or "wrong" about it, that's just the way it is, the same way as the first floppy drive under Windows is always designated "A:\". It's how the given OS names drives and partitions so it knows where they are and can tell the programs that need to know where the devices are to read or write from/to them.

Quote:

3)How can I erase the folder that I was using for mount point?
Which one? The original one, or the new one? What was the original mount point, anyway?

In any case, if the drive is listed in /etc/fstab (which I would imagine that it is, this being Mandrake, which mounts everything by default), the mount point is going to be recreated at every boot, when /etc/fstab is read, so the thing to do would be to remove the mount from that /etc/fstab completely (which makes no sense), turn off supermount or automount (most likely supermount, if you haven't changed Mandrake's default behaviour) by removing the option from the line in /etc/fstab (which is fine if you don't mind mounting the DVD drive manually every time you want to use it, but probably you do), or by confirming that the line in /etc/fstab refers to the mount point that you actually want to use, making sure that the drive is actually mounted to that directory (unmount and remount if necessary), then removing the other folder as root (use File Manager (Super User mode) if using KDE, or open a terminal, su to root, then type nautilus --no-desktop if using GNOME. If using another WM, follow the instructions for GNOME, but use the name of whatever file manage you use under that WM instead of Nautilus). This should delete the other folder permanently, as long as it's not referenced in /etc/fstab.

[
Quote:

2)How can I change the icon on my desktop into a CD and rename it also?
Not sure-- reset everything to the default? I'm sorry, it's really not clear what benefit you're getting from what you've done in the first place (since the new mount point is in /mnt just like the old one was, only a different folder inside /mnt), and since (as you've no doubt noticed) changing things like this in Mandrake's careful little setup tends to confuse it slightly, it's often not worth the bother if there's no significant benefit. Heck, it's not actually clear what you've done in the first place... if you've set some other device than /dev/hdc to use the /mnt/dvdrom mountpoint, then that would explain why the icon changed, as the mounted filesystem is no longer a DVD-ROM drive in the first place.

If that isn't what you've done, you might be able to right-click the icon, go to the properties menu, and change the icon back, at least. If it works, it might or might not hold (depending on if it's the supermount icon or one you added yourself).

Worth a try, anyway. Hope this helps.

Impaler 04-04-2004 06:03 AM

Thanks for your answer. I tested your suggestions and work but as you mentioned Mandrake is being confused by this staff so I changed it back to the first mount point (I hadn't changed the /dev/....). I still can't find how to change the name and the icon on my desktop but that's ok (I have two cd-dvd drives, the one is apperared as "CD-ROM" and the other as "CD-ROM 2").

Thanks a lot for your help


All times are GMT -5. The time now is 10:22 AM.