Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 06-16-2006, 03:31 PM   #1
Registered: Apr 2006
Distribution: sabayon, opensuse
Posts: 55

Rep: Reputation: 16
DVD movies blurry under ATI Radeon / fglrx

I have (apparently) sucessfully installed the ati driver for my Radeon X300 - 128Mb PCI-express card (fgl_glxgears are working). However, DVD movies run blurry ("dropping frames" or something).
I am running Suse 10.1 (Xorg) where I replaced the limited xine version with the package from "packman" as commonly suggested. In kaffeine I turned xv use on. Now I am not sure if I am having a hardware issue (card, board) or just need a special ;-) tweak for my xorg.conf.
The driver used is
Most appreciated would be an answer to the following question: how can I confirm that xine and xorg.conf are being set up right.
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X300/X550 Series Generic
OpenGL version string: 2.0.5814 (8.25.18)
Using GLX_SGIX_pbuffer
1109 frames in 5.0 seconds = 221.800 FPS
7504 frames in 5.0 seconds = 1500.723 FPS
[fglrx] Maximum main memory to use for locked dma buffers: 1900 MBytes.
[fglrx] module loaded - fglrx 8.25.18 [May 18 2006] on minor 0
[fglrx] total GART = 67108864
[fglrx] free GART = 51118080
[fglrx] max single GART = 51118080
[fglrx] total LFB = 126808064
[fglrx] free LFB = 116322304
[fglrx] max single LFB = 116322304
[fglrx] total Inv = 0
[fglrx] free Inv = 0
[fglrx] max single Inv = 0
[fglrx] total TIM = 0ection "Device"
Identifier "Device[0]"
Driver "radeon"
VendorName "ATI"
BoardName "Radeon X300 (RV370) 5B60 (PCIE)"
BusID "3:0:0"

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "OverlayOnCRTC2" "0"
Option "Centermode" "off"

Section "DRI"
Group "video"
Mode 0660
Thanks for any help
Old 06-16-2006, 07:11 PM   #2
Registered: Apr 2006
Distribution: sabayon, opensuse
Posts: 55

Original Poster
Rep: Reputation: 16
Oh, and I forgot to mention that DMA is active for the dvd drive. Also when I run a vob of the same movie from my harddrive I get the same issues.



ati, radeon, suse10, x300, xine, xv

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon blurry distored in X (proprietary driver) titan100 Linux - Hardware 1 08-26-2005 09:20 AM
How to enable ATI Radeon 9600Pro (fglrx) TV-out fb? Mitchua Linux - Hardware 1 08-16-2005 08:16 AM
ATI Radeon 9000, fglrx, ... ARRRGGGHHH!!! zZeta Linux - Hardware 4 01-03-2005 10:27 PM
[ATI] fglrx vs dri-radeon <what is the diff?> carboncopy Slackware 1 06-18-2004 02:50 AM
Problem with fglrx: 2.6.1 and ati radeon 9000 firebolt Linux - Hardware 1 01-26-2004 01:19 AM

All times are GMT -5. The time now is 11:47 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration