LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   DVB card and MythTV (http://www.linuxquestions.org/questions/linux-hardware-18/dvb-card-and-mythtv-461407/)

IBall 07-06-2006 02:32 AM

DVB card and MythTV
 
Hi,
I have a Dvico FusionHDTV DVB-T lite card. It works correctly with Kaffine, I can watch all the local channels perfectly. I can pause live tv, and schedule recordings.

I have tried to install MythTV - unfortunately, it doesn't work. MythTV starts, and presents me with the menu. When I select "Watch TV", I get a blank screen and returned to the menu after a few seconds. The output of mythfrontend in the terminal is:
Code:

mythtv@iball:/home/ian$ mythfrontend
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  147
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  147
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
Session management error: Could not open network socket
2006-07-06 15:23:25.629 New DB connection, total: 1
Total desktop width=1280, height=1024, numscreens=1
2006-07-06 15:23:25.649 Using screen 0, 1280x1024 at 0,0
2006-07-06 15:23:25.653 mythfrontend version: 0.18.1.20050510-1 www.mythtv.org
2006-07-06 15:23:25.654 Enabled verbose msgs : important general
2006-07-06 15:23:25.884 Switching to square mode (blue)
mythtv: could not connect to socket
mythtv: No such file or directory
lirc_init failed for mythtv, see preceding messages
2006-07-06 15:23:26.820 Joystick disabled.
2006-07-06 15:23:26.847 Registering Internal as a media playback plugin.
2006-07-06 15:23:31.298 New DB connection, total: 2
2006-07-06 15:23:31.361 Connecting to backend server: 127.0.0.1:6543 (try 1 of 5)
2006-07-06 15:23:31.377 Using protocol version 15
2006-07-06 15:23:31.435 Using protocol version 15
2006-07-06 15:23:31.550 Disable DPMS
2006-07-06 15:23:36.585 taking too long to be allowed to read..
2006-07-06 15:23:41.589 taking too long to be allowed to read..
2006-07-06 15:23:50.594 Waited 4 seconds for data to become available, waiting again...
2006-07-06 15:23:54.598 Waited 4 seconds for data to become available, waiting again...
2006-07-06 15:23:58.602 Waited 4 seconds for data to become available, waiting again...
2006-07-06 15:24:02.607 Waited 4 seconds for data to become available, waiting again...
2006-07-06 15:24:06.611 Waited 4 seconds for data to become available, waiting again...
2006-07-06 15:24:10.615 Waited 4 seconds for data to become available, waiting again...
2006-07-06 15:24:14.619 Waited 4 seconds for data to become available, waiting again...
2006-07-06 15:24:18.624 Waited 4 seconds for data to become available, waiting again...
2006-07-06 15:24:18.624 Waited 14 seconds for data to become available, aborting
Couldn't read file: rbuf://127.0.0.1:6543/media/tv/ringbuf1.nuv
2006-07-06 15:24:18.676 Changing from None to WatchingLiveTV
2006-07-06 15:24:18.676 Decoder not alive, and trying to play..
2006-07-06 15:24:18.748 Changing from None to None
mythtv@iball:/home/ian$

MythTV automatically detected all the local TV channels, and as I said previously, Kaffine can use the card with no problems.

Does anyone have any ideas what I have done wrong?

Thanks
--Ian

chrisyc 07-07-2006 03:50 AM

Hi Ian, I'm new to mythtv myself and i don't run this dvb card but i think i may be able to help.
I see you must have mysql running since I see you have connected to a db. However are you running mythbackend?
Have you run mythtv-setup? Also you are running 0.18, have you tried 0.19?
If you have not tried 0.19 i suggest making 0.18 work first since I can only scan for new channels with 0.18 (so make a backup of your mysql db when you've got it working!!)
run $mythbackend and post the output of this, if it works fine, leave mythbackend running all the time ($mythbackend --daemon) and then run mythfrontend from any pc on the network ;)
Hope this helps
Chris

IBall 07-07-2006 08:52 PM

Thanks Chris.

I assumed that mythbackend would start automatically since it was in /etc/init.d. For some reason, it wasnt. After I ran mythbacked manually, everything now works perfectly. For some reason, mythbackend now starts automatically.

Thanks again
--Ian

chrisyc 07-08-2006 02:13 PM

;)
Glad to be of service; enjoy possibly the best tv program of all time!
Yes i agree with you mythbackend is also in /etc/init.d on my server, however if i look at the boot log it always says something along the lines of
services skipped at runlevel 3: mythbackend
apparently for you the --daemon has changed this?
Oh well, everything works so just follow the computing golden rule- if it works; leave it :D
All the best
Chris


All times are GMT -5. The time now is 08:56 AM.