LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-11-2007, 02:00 PM   #1
freu
LQ Newbie
 
Registered: Jan 2007
Posts: 1

Rep: Reputation: 0
Dual Nights of Dual Monitor Frustration


For the past two long nights, I have been suffering through the process of setting up dual monitors. I feel I have accomplished a lot, but my work is not yet done... i.e., It ainít workin.

By reversing the 0ís and 1ís, I can verify that both monitors work individually, but I cannot make them both work at the same time.

This is Debian 3 with kernel 2.4.

Any help will receive intangible rewards (aka good feelings).

Hereís the XF86Config-4:
Code:
# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
#   md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
#   dpkg-reconfigure xserver-xfree86

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/Speedo"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"speedo"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xfree86"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection
Section "InputDevice"
	Identifier	"Generic Mouse"
	Driver		"mouse"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

#
# NEC monitor config
#

Section "Device"
	Identifier	"ATI"
	Driver		"ati"
	BusID		"PCI:0:08:0"
	Screen		1
EndSection

Section "Monitor"
	Identifier	"MultiSync 70"
	HorizSync	31-69
	VertRefresh	55-120
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"NEC"
	Device		"ATI"
	Monitor		"MultiSync 70"
	DefaultDepth	24
	SubSection "Display"
		Depth	24
		Modes	"1152x864"
	EndSubSection
EndSection

#
# DELL monitor config
#

Section "Device"
	Identifier	"NVIDIA"
	Driver		"nv"
	BusID		"PCI:1:00:0"
	Screen		0
EndSection

Section "Monitor"
	Identifier	        "DELLMON"
	HorizSync	      31-69
	VertRefresh	      55-120
	Option		        "DPMS"
EndSection

Section "Screen"
	Identifier	      "DELL"
	Device		     "NVIDIA"
	Monitor		     "DELLMON"
	DefaultDepth	   24
	SubSection "Display"
		Depth		 24
		Modes		"1152x864"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	        "Default Layout"
	Screen		       0 "DELL"
        Screen		       1 "NEC" LeftOf "DELL"
	Option		        "Xinerama"
	InputDevice	      "Generic Keyboard"
	InputDevice	      "Configured Mouse"
	InputDevice	      "Generic Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection
 
Old 01-13-2007, 12:39 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by freu
For the past two long nights, I have been suffering through the process of setting up dual monitors. I feel I have accomplished a lot, but my work is not yet done... i.e., It ainít workin.

By reversing the 0ís and 1ís, I can verify that both monitors work individually, but I cannot make them both work at the same time.

This is Debian 3 with kernel 2.4.

Any help will receive intangible rewards (aka good feelings).

Hereís the XF86Config-4:
Try the file below if it works then remove the # from the Xinerama line to see if it works that way having put the # in fornt of the Load "xtrap" line, if not working then can you post the /var/log/XFree86.0.log file so we can see how everything gets detected make sure to back up the file before starting X with a working file or it will be overwritten and you will need to put it into two posts as it is rather big.
Code:
# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
#   md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
#   dpkg-reconfigure xserver-xfree86

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/Speedo"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"speedo"
	Load	"type1"
	Load	"vbe"
        Load       "xtrap"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xfree86"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection
Section "InputDevice"
	Identifier	"Generic Mouse"
	Driver		"mouse"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

#
# NEC monitor config
#

Section "Device"
	Identifier	"ATI"
	Driver		"ati"
	BusID		"PCI:0:08:0"
#	Screen		1
EndSection

Section "Monitor"
	Identifier	"MultiSync 70"
	HorizSync	31-69
	VertRefresh	55-120
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"NEC"
	Device		"ATI"
	Monitor		"MultiSync 70"
	DefaultDepth	24
	SubSection "Display"
		Depth	24
		Modes	"1152x864"
	EndSubSection
EndSection

#
# DELL monitor config
#

Section "Device"
	Identifier	"NVIDIA"
	Driver		"nv"
	BusID		"PCI:1:00:0"
#	Screen		0
EndSection

Section "Monitor"
	Identifier	        "DELLMON"
	HorizSync	      31-69
	VertRefresh	      55-120
	Option		        "DPMS"
EndSection

Section "Screen"
	Identifier	      "DELL"
	Device		     "NVIDIA"
	Monitor		     "DELLMON"
	DefaultDepth	   24
	SubSection "Display"
		Depth		 24
		Modes		"1152x864"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	        "Default Layout"
	Screen		       0 "DELL"   0 0
        Screen		       1 "NEC" LeftOf  "DELL"
#	Option		        "Xinerama"
	InputDevice	      "Generic Keyboard"
	InputDevice	      "Configured Mouse"
	InputDevice	      "Generic Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
default monitor on nvidia / dual monitor setup fenderog Suse/Novell 3 05-01-2009 05:36 PM
dual monitor, dual wallpaper novacrasher Linux - General 0 06-10-2006 04:43 PM
Issue trying to dual monitor with Dell 2005FPW LCD monitor damg Linux - Hardware 2 12-05-2005 10:13 AM
Booting to wrong Monitor (w/ dual monitor setup) NeoNostalgia Linux - General 1 06-30-2004 01:49 AM
RH 7.3, dual monitor, dual screensaver configuration a-wolfe Linux - Software 0 11-18-2003 09:05 AM


All times are GMT -5. The time now is 03:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration