LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-17-2004, 09:08 AM   #1
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Rep: Reputation: 15
dual monitor setup problem using 2 cards


hi, does anyone know what's the RIGHT way of setting up dual monitors ?

i have an s3 virge/dx (pci card)
and a geforce 4 mx 440

i first tried to edit my XF86Config file manually, adding my pci card, and keeping the nv card that was already installed
i also inserted extra monitor, and screen

it doesn't really mather what i entered here because it turns out the settings of my XF86Config-4 file are used during startx instead of the normal ones

this could be because i once had to manually set my screen resolution in that file

if anyone knows how to solve this (to make it use XF86Config settings instead of XF86Config-4) it will probably work

if not => if i try to change the settings in -4 file, startxlog sais there isn't a driver recognised for that driver (s3virge)
so when i change the driver in that file to "vga"" (the generic vga driver)
x starts, with that driver, but it used my NVIDIA card, and mynormal monitor
but i can tell it uses the vga driver because that one only supports up to 8 bit color

will post my log file

i'm sorry if i'm not very clear i'm still a
if so, just ask me to explain again


doing lspci also returns my pci card (it works in windows xp so it can't be broken anyway)
in the log file, my pci card is recognised in 2nd pci slot, and it sais it can't find card for driver in that slot so it should be trying to make the driver "work" for my pci card) but in reality it was trying to use the s3virge driver for my geforce card, which obviously didn't work (and the standard vga did)
thx

Last edited by steefje; 11-17-2004 at 09:14 AM.
 
Old 11-17-2004, 09:23 AM   #2
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Original Poster
Rep: Reputation: 15
This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository
(http://www.XFree86.Org/cvs).

XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-8 20040928112350 fabbione@fabbione.net)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.26 i686 [ELF]
Build Date: 28 September 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.27-1-386 (joshk@trollwife) (gcc version 3.3.4 (Debian 1:3.3.4-9)) #1 Fri Sep 3 06:24:46 UTC 2004
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Nov 17 15:52:21 2004
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen 1" (0)
(**) | |-->Monitor "Generic Monitor"
(**) | |-->Device "NVIDIA Corporation NV17 [GeForce4 MX 440]"
(**) |-->Input Device "Generic Keyboard"

(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "be"
(**) XKB: layout: "be"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/CID" does not exist.
Entry deleted from font path.
(**) FontPath set to "unix/:7100,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/:unscaled,/usr/lib/X11/fonts/Type1,/usr/lib/X11/fonts/Speedo,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80000090, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,1a30 card 8086,1a30 rev 03 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,1a31 card 0000,0000 rev 03 class 06,04,00 hdr 01
(II) PCI: 00:1e:0: chip 8086,244e card 0000,0000 rev 12 class 06,04,00 hdr 01
(II) PCI: 00:1f:0: chip 8086,2440 card 0000,0000 rev 12 class 06,01,00 hdr 80
(II) PCI: 00:1f:1: chip 8086,244b card 8086,2442 rev 12 class 01,01,80 hdr 00
(II) PCI: 00:1f:2: chip 8086,2442 card 8086,2442 rev 12 class 0c,03,00 hdr 00
(II) PCI: 00:1f:4: chip 8086,2444 card 8086,2442 rev 12 class 0c,03,00 hdr 00
(II) PCI: 00:1f:5: chip 8086,2445 card 4352,5934 rev 12 class 04,01,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0171 card 1b13,0001 rev a3 class 03,00,00 hdr 00
(II) PCI: 02:09:0: chip 1102,0007 card 1102,1002 rev 00 class 04,01,00 hdr 80
(II) PCI: 02:09:1: chip 1102,7005 card 1102,1002 rev 00 class 09,80,00 hdr 80
(II) PCI: 02:0a:0: chip 5333,8a01 card 5333,8a01 rev 01 class 03,00,00 hdr 00
(II) PCI: 02:0b:0: chip 10ec,8029 card 10ec,8029 rev 00 class 02,00,00 hdr 00
(II) PCI: 02:0d:0: chip 10ec,8029 card 10ec,8029 rev 00 class 02,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,2), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000e (VGA_EN is set)
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xec000000 - 0xedffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 2: bridge is at (0:30:0), (0,2,2), BCTRL: 0x0006 (VGA_EN is cleared)
(II) Bus 2 I/O range:
[0] -1 0 0x0000c000 - 0x0000c0ff (0x100) IX[B]
[1] -1 0 0x0000c400 - 0x0000c4ff (0x100) IX[B]
[2] -1 0 0x0000c800 - 0x0000c8ff (0x100) IX[B]
[3] -1 0 0x0000cc00 - 0x0000ccff (0x100) IX[B]
(II) Bus 2 non-prefetchable memory range:
[0] -1 0 0xe4000000 - 0xebffffff (0x8000000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:31:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV17 [GeForce4 MX 440] rev 163, Mem @ 0xec000000/24, 0xd0000000/27, 0xd8000000/19
(--) PCI: (2:10:0) S3 Inc. ViRGE/DX or /GX rev 1, Mem @ 0xe4000000/26

(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xe0000000 from 0xe3ffffff to 0xdfffffff
(II) Active PCI resource ranges:
[0] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[1] -1 0 0xd8000000 - 0xd807ffff (0x80000) MX[B](B)
[2] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[3] -1 0 0xec000000 - 0xecffffff (0x1000000) MX[B](B)
[4] -1 0 0x0000cc00 - 0x0000cc1f (0x20) IX[B]
[5] -1 0 0x0000c800 - 0x0000c81f (0x20) IX[B]
*cut* BLABLABLA (hope that wasn't important)
[15] -1 0 0x0000c000 - 0x0000c01f (0x20) IX[B]
[16] -1 0 0x0000e000 - 0x0000e03f (0x40) IX[B]
[17] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[18] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[19] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[20] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o": No symbols found
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap


*CUT*


(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "nv"
(II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.o
(II) Module nv: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.1
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
*...*
GeForce FX 5700VE, 0x0345, GeForce FX Go5700, GeForce FX Go5700,
0x0349, 0x034B, Quadro FX Go1000, Quadro FX 1100, 0x034F
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset GeForce4 MX 440 found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[6] -1 0 0xd8000000 - 0xd807ffff (0x80000) MX[B](B)
[7] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[8] -1 0 0xec000000 - 0xecffffff (0x1000000) MX[B](B)
[9] -1 0 0xe4000000 - 0xe7ffffff (0x4000000) MX[B](B)
[10] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[11] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[12] -1 0 0x0000cc00 - 0x0000cc1f (0x20) IX[B]
[13] -1 0 0x0000c800 - 0x0000c81f (0x20) IX[B]
[14] -1 0 0x0000c400 - 0x0000c407 (0x8) IX[B]
[15] -1 0 0x0000c000 - 0x0000c01f (0x20) IX[B]
[16] -1 0 0x0000e000 - 0x0000e03f (0x40) IX[B]
[17] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[18] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[19] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[20] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[6] -1 0 0xd8000000 - 0xd807ffff (0x80000) MX[B](B)
[7] -1 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B](B)
[8] -1 0 0xec000000 - 0xecffffff (0x1000000) MX[B](B)
[9] -1 0 0xe4000000 - 0xe7ffffff (0x4000000) MX[B](B)
[10] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[11] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[12] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[15] -1 0 0x0000cc00 - 0x0000cc1f (0x20) IX[B]
[16] -1 0 0x0000c800 - 0x0000c81f (0x20) IX[B]
[17] -1 0 0x0000c400 - 0x0000c407 (0x8) IX[B]
[18] -1 0 0x0000c000 - 0x0000c01f (0x20) IX[B]
[19] -1 0 0x0000e000 - 0x0000e03f (0x40) IX[B]
[20] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[21] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[22] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[23] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
[24] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[25] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R6/lib/modules/linux/libint10.a
(II) NV(0): Initializing int10
(II) NV(0): Primary V_BIOS segment is: 0xc000
(WW) System lacks support for changing MTRRs
(--) NV(0): Chipset: "GeForce4 MX 440"
(**) NV(0): Depth 24, (--) framebuffer bpp 32
(==) NV(0): RGB weight 888
(==) NV(0): Default visual is TrueColor
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(==) NV(0): Using HW cursor
(--) NV(0): Linear framebuffer at 0xD0000000
(--) NV(0): MMIO registers at 0xEC000000
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Loading /usr/X11R6/lib/modules/libi2c.a
(II) Module i2c: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.2.0
ABI class: XFree86 Video Driver, version 0.6
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Reloading /usr/X11R6/lib/modules/libddc.a
(II) NV(0): I2C bus "DDC" initialized.
(II) NV(0): Probing for analog device on output A...
(--) NV(0): ...found one
(II) NV(0): Probing for analog device on output B...
(--) NV(0): ...can't find one
(II) NV(0): Probing for EDID on I2C bus A...
(II) NV(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) NV(0): I2C device "DDC:ddc2" removed.
(II) NV(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) NV(0): I2C device "DDC:ddc2" removed.
(--) NV(0): DDC detected a CRT:
(II) NV(0): Manufacturer: PHL Model: b17b Serial#: 1260
(II) NV(0): Year: 1998 Week: 25
(II) NV(0): EDID Version: 1.1
(II) NV(0): Analog Display Input, Input Voltage Level: 0.700/0.300 V
(II) NV(0): Sync: Separate Composite SyncOnGreen
(II) NV(0): Max H-Image Size [cm]: horiz.: 32 vert.: 24
(II) NV(0): Gamma: 2.85
(II) NV(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) NV(0): redX: 0.625 redY: 0.340 greenX: 0.285 greenY: 0.600
(II) NV(0): blueX: 0.150 blueY: 0.065 whiteX: 0.281 whiteY: 0.311
(II) NV(0): Supported VESA Video Modes:
(II) NV(0): 720x400@70Hz
(II) NV(0): 640x480@60Hz
(II) NV(0): 800x600@75Hz
(II) NV(0): 1024x768@75Hz
(II) NV(0): 1280x1024@75Hz
(II) NV(0): Manufacturer's mask: 0
(II) NV(0): Supported Future Video Modes:
(II) NV(0): #0: hsize: 640 vsize 480 refresh: 85 vid: 22833
(II) NV(0): #1: hsize: 800 vsize 600 refresh: 85 vid: 22853
(II) NV(0): #2: hsize: 1024 vsize 768 refresh: 85 vid: 22881
(II) NV(0): #3: hsize: 1280 vsize 960 refresh: 85 vid: 22913
(II) NV(0): Supported additional Video Mode:
(II) NV(0): clock: 56.2 MHz Image Size: 306 x 230 mm
(II) NV(0): h_active: 800 h_sync: 832 h_sync_end 896 h_blank_end 1048 h_border: 0
(II) NV(0): v_active: 600 v_sync: 601 v_sync_end 604 v_blanking: 631 v_border: 0
(II) NV(0): Serial No: HD 001260
(II) NV(0): Monitor name: PHILIPS 107MB
(II) NV(0): Ranges: V min: 50 V max: 120 Hz, H min: 30 H max: 87 kHz, PixClock max 2550 MHz
(II) NV(0): Probing for EDID on I2C bus B...
(II) NV(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) NV(0): I2C device "DDC:ddc2" removed.
(II) NV(0): ... none found
(--) NV(0): CRTC 0 appears to have a CRT attached
(II) NV(0): Using CRT on CRTC 0
(--) NV(0): VideoRAM: 65536 kBytes
(==) NV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) NV(0): Generic Monitor: Using hsync range of 30.00-85.00 kHz
(II) NV(0): Generic Monitor: Using vrefresh range of 50.00-85.00 Hz
(II) NV(0): Clock range: 12.00 to 350.00 MHz
(II) NV(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
(II) NV(0): Not using default mode "512x384" (bad mode clock/interlace/doublescan)
(II) NV(0): Not using default mode "1280x960" (hsync out of range)
(II) NV(0): Not using default mode "640x480" (hsync out of range)
(II) NV(0): Not using default mode "1280x1024" (hsync out of range)
(II) NV(0): Not using default mode "640x512" (hsync out of range)
*.......................................*
(II) NV(0): Not using default mode "2048x1536" (hsync out of range)
(II) NV(0): Not using default mode "1024x768" (hsync out of range)
(II) NV(0): Not using default mode "2048x1536" (hsync out of range)
(II) NV(0): Not using default mode "1024x768" (hsync out of range)
(II) NV(0): Not using default mode "2048x1536" (bad mode clock/interlace/doublescan)
(II) NV(0): Not using default mode "1024x768" (hsync out of range)
(II) NV(0): Not using default mode "1792x1344" (width too large for virtual size)
(II) NV(0): Not using default mode "1600x1200" (width too large for virtual size)
(II) NV(0): Not using default mode "1600x1200" (width too large for virtual size)
(II) NV(0): Not using default mode "1400x1050" (width too large for virtual size)
(II) NV(0): Not using default mode "1400x1050" (width too large for virtual size)
(--) NV(0): Virtual size is 1280x1024 (pitch 1280)
(**) NV(0): *Default mode "1280x1024": 135.0 MHz, 80.0 kHz, 75.0 Hz
(II) NV(0): Modeline "1280x1024" 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
(**) NV(0): *Default mode "1280x960": 108.0 MHz, 60.0 kHz, 60.0 Hz
(II) NV(0): Modeline "1280x960" 108.00 1280 1376 1488 1800 960 961 964 1000 +hsync +vsync
(**) NV(0): *Default mode "1024x768": 94.5 MHz, 68.7 kHz, 85.0 Hz
(II) NV(0): Modeline "1024x768" 94.50 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
*................................*
(**) NV(0): Default mode "400x300": 18.0 MHz, 35.2 kHz, 56.3 Hz (D)
(II) NV(0): Modeline "400x300" 18.00 400 412 448 512 300 300 301 312 doublescan +hsync +vsync
(**) NV(0): Default mode "320x240": 18.0 MHz, 43.3 kHz, 85.2 Hz (D)
(II) NV(0): Modeline "320x240" 18.00 320 348 376 416 240 240 242 254 doublescan -hsync -vsync
(**) NV(0): Default mode "320x240": 15.8 MHz, 37.5 kHz, 75.0 Hz (D)
(II) NV(0): Modeline "320x240" 15.75 320 328 360 420 240 240 242 250 doublescan -hsync -vsync
(**) NV(0): Default mode "320x240": 15.8 MHz, 37.9 kHz, 72.8 Hz (D)
(II) NV(0): Modeline "320x240" 15.75 320 332 352 416 240 244 245 260 doublescan -hsync -vsync
(**) NV(0): Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
(II) NV(0): Modeline "320x240" 12.60 320 328 376 400 240 245 246 262 doublescan -hsync -vsync
(**) NV(0): Default mode "360x200": 17.8 MHz, 37.9 kHz, 85.0 Hz (D)
(II) NV(0): Modeline "360x200" 17.75 360 378 414 468 200 200 202 223 doublescan -hsync +vsync
(**) NV(0): Default mode "320x200": 15.8 MHz, 37.9 kHz, 85.3 Hz (D)
(II) NV(0): Modeline "320x200" 15.75 320 336 368 416 200 200 202 222 doublescan -hsync +vsync
(**) NV(0): Default mode "320x175": 15.8 MHz, 37.9 kHz, 85.3 Hz (D)
(II) NV(0): Modeline "320x175" 15.75 320 336 368 416 175 191 192 222 doublescan +hsync -vsync
(++) NV(0): DPI set to (100, 100)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xd8000000 - 0xd807ffff (0x80000) MX[B]
[1] 0 0 0xd0000000 - 0xd7ffffff (0x8000000) MX[B]
[2] 0 0 0xec000000 - 0xecffffff (0x1000000) MX[B]
[3] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
.....
[21] -1 0 0x0000c000 - 0x0000c01f (0x20) IX[B]
[22] -1 0 0x0000e000 - 0x0000e03f (0x40) IX[B]
[23] -1 0 0x0000dc00 - 0x0000dcff (0x100) IX[B]
[24] -1 0 0x0000d800 - 0x0000d81f (0x20) IX[B]
[25] -1 0 0x0000d000 - 0x0000d01f (0x20) IX[B]
[26] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
[27] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B](OprU)
[28] 0 0 0x000003c0 - 0x000003df (0x20) IS[B](OprU)
(II) NV(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
8x8 mono pattern filled rectangles
Indirect CPU to Screen color expansion
Solid Lines
Scanline Image Writes
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
32 256x256 slots
16 512x512 slots
(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(**) Option "dpms"
(**) NV(0): DPMS enabled
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Keyboard "Generic Keyboard" handled by legacy driver
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "true"
(**) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 5
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) Configured Mouse: ps2EnableDataReporting: succeeded
Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.Z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.Z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.Z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0
GetModeLine - scrn: 0 clock: 135000
GetModeLine - hdsp: 1280 hbeg: 1296 hend: 1440 httl: 1688
vdsp: 1024 vbeg: 1025 vend: 1028 vttl: 1066 flags: 5
 
Old 11-17-2004, 09:28 AM   #3
steefje
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: debian
Posts: 46

Original Poster
Rep: Reputation: 15
that was a log file i quickly posted (but it's a correct one, i mean used my nv card for posting this )
that's why the red "screen 1" etc should say screen 2 etc

i know this is kinda useless to u and i feel stupid but i don't have time now (i do tonight) to post a log file with the errors

edit*

here is my XF86Config-4 file


Quote:
# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "be"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV17 [GeForce4 MX 440]"
Driver "nv"
EndSection

Section "Device"
Identifier "s3"
Driver "s3virge"
Option "xaa_benchmark" ( doing xf86config for that card added those options in XF86config, so i added them here to)
Option "fifo_moderate"
Option "pci_burst_on"
Option "pci_retry"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-85
VertRefresh 50-85
Option "DPMS"
EndSection

Section "Monitor"
Identifier "noc"
HorizSync 30-85
VertRefresh 50-85
Option "DPMS"
EndSection

Section "Screen"
Identifier "Screen 1"
Device "NVIDIA Corporation NV17 [GeForce4 MX 440]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen 2"
Device "s3"
Monitor "noc"
DefaultDepth 8
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "screen 2"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Last edited by steefje; 11-17-2004 at 11:06 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
default monitor on nvidia / dual monitor setup fenderog Suse/Novell 3 05-01-2009 05:36 PM
Dual Monitor Display on two graphics cards jojotx0 Linux - Hardware 5 08-26-2005 08:28 PM
Dual Monitor Setup healfdeane Linux - Hardware 33 12-13-2004 11:06 AM
Booting to wrong Monitor (w/ dual monitor setup) NeoNostalgia Linux - General 1 06-30-2004 01:49 AM
dual monitor setup lil213 Linux - Hardware 2 01-14-2004 04:47 AM


All times are GMT -5. The time now is 02:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration