LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Dual Monitor: 2nd monitor not coming up -- xorg.conf missing something? (http://www.linuxquestions.org/questions/linux-hardware-18/dual-monitor-2nd-monitor-not-coming-up-xorg-conf-missing-something-762994/)

Hewson 10-19-2009 12:42 PM

Dual Monitor: 2nd monitor not coming up -- xorg.conf missing something?
 
This is a repost of my initial problem, I need some one who knows what they are doing more than I too take a look at this command output and give some sort of direction/clue/etc on what I'm doing wrong or missing.

Is my xorg.conf missing some vital line(s) or setting?

My best guess is that i'm missing something to tell the Xserver to use both screens, as the Xorg.0.log does not talk about trying to bring up the intel display; but this is just a hunch.

I'm running kubuntu 9.04 with 2 monitors: on-board intel video and a PCI nvidia display: I am using my nvidia display fine, but still can not get my 2nd display (the intel) working. What the heck am I missing?

lspci:
Code:

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 Display controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
01:08.0 Ethernet controller: Intel Corporation 82562EZ 10/100 Ethernet Controller (rev 02)

xorg.conf:
Code:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Sun Feb  1 20:21:04 UTC 2009


Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" rightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
    Load          "dbe"
    Load          "extmod"
    Load          "type1"
    Load          "freetype"
    Load          "glx"
EndSection

Section "ServerFlags"
    Option        "Xinerama" "0"
    Option        "DontZap" "False"
EndSection

Section "InputDevice"
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/psaux"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier    "Keyboard0"
    Driver        "kbd"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync      30.0 - 81.0
    VertRefresh    56.0 - 75.0
    ModeLine      "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce FX 5200"
    BusID          "PCI:1:0:0"
    Option        "ModeValidation" "NoEdidDFPMaxSizeCheck, NoMaxPClkCheck"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "0"
    Option        "metamodes" "1680x1050 +0+0"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection

Section "Monitor"
    Identifier    "Monitor1"
    VendorName    "Unknown"
    ModelName      "ViewSonic VA912b"
    HorizSync      30.0 - 82.0
    VertRefresh    50.0 - 75.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Device1"
    Driver        "vesa"
    VendorName    "Intel Corporation"
    BusID          "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier    "Screen1"
    Device        "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection

Xorg.0.log:
Code:


X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
Current Operating System: Linux Hydross 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686
Build Date: 09 April 2009  02:10:02AM
xorg-server 2:1.6.0-0ubuntu14 (buildd@rothera.buildd)
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Oct 16 08:49:28 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) |  |-->Monitor "Monitor0"
(**) |  |-->Device "Device0"
(**) |-->Screen "Screen1" (1)
(**) |  |-->Monitor "Monitor1"
(**) |  |-->Device "Device1"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(**) Option "DontZap" "False"
(**) Option "Xinerama" "0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
        Entry deleted from font path.
(==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
        built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(WW) Disabling Mouse0
(II) Loader magic: 0x3bc0
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 5.0
        X.Org XInput driver : 4.0
        X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0@1:0:0) nVidia Corporation NV34 [GeForce FX 5200] rev 161, Mem @ 0xfd000000/16777216, 0xf0000000/134217728, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
        [0] -1        0        0xffffffff - 0xffffffff (0x1) MX[B]
        [1] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [2] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [3] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [4] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [5] -1        0        0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(WW) Warning, couldn't open module type1
(II) UnloadModule: "type1"
(EE) Failed to load module "type1" (module does not exist, 0)
(II) LoadModule: "freetype"
(WW) Warning, couldn't open module freetype
(II) UnloadModule: "freetype"
(EE) Failed to load module "freetype" (module does not exist, 0)
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.0
        Module class: X.Org Server Extension
(II) NVIDIA GLX Module  173.14.16  Sat Jan 24 20:08:33 PST 2009
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.13.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.0.0
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.0.0
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.0
        Module class: X.Org Video Driver
(II) LoadModule: "vesa"
(II) Loading /usr/lib/xorg/modules/drivers//vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
        compiled for 1.5.99.902, module version = 1.3.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 5.0
(II) NVIDIA dlloader X Driver  173.14.16  Sat Jan 24 19:48:05 PST 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) VESA: driver for VESA chipsets: vesa
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(WW) Falling back to old probe method for vesa
(II) resource ranges after probing:
        [0] -1        0        0xffffffff - 0xffffffff (0x1) MX[B]
        [1] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [2] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [3] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [4] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [5] -1        0        0x00000000 - 0x00000000 (0x1) IX[B]
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "TwinView" "0"
(**) NVIDIA(0): Option "MetaModes" "1680x1050 +0+0"
(**) NVIDIA(0): Option "ModeValidation" "NoEdidDFPMaxSizeCheck, NoMaxPClkCheck"
(**) NVIDIA(0): Enabling RENDER acceleration
(WW) NVIDIA(0): Unrecognized ModeValidation token "NoEdidDFPMaxSizeCheck";
(WW) NVIDIA(0):    ignoring.
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):    enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce FX 5200 (NV34) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 04.34.20.27.02
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce FX 5200 at PCI:1:0:0:
(--) NVIDIA(0):    Samsung SyncMaster (DFP-0)
(--) NVIDIA(0): Samsung SyncMaster (DFP-0): 135.0 MHz maximum pixel clock
(--) NVIDIA(0): Samsung SyncMaster (DFP-0): Internal Single Link TMDS
(II) NVIDIA(0): Mode Validation Overrides for Samsung SyncMaster (DFP-0):
(II) NVIDIA(0):    NoMaxPClkCheck
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):    "1680x1050+0+0"
(II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
(--) NVIDIA(0): DPI set to (90, 88); computed from "UseEdidDpi" X config
(--) NVIDIA(0):    option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(II) UnloadModule: "vesa"
(II) Unloading /usr/lib/xorg/modules/drivers//vesa_drv.so
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
        [0] -1        0        0xffffffff - 0xffffffff (0x1) MX[B]
        [1] -1        0        0x000f0000 - 0x000fffff (0x10000) MX[B]
        [2] -1        0        0x000c0000 - 0x000effff (0x30000) MX[B]
        [3] -1        0        0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [4] -1        0        0x0000ffff - 0x0000ffff (0x1) IX[B]
        [5] -1        0        0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode "1680x1050+0+0"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
(II) config/hal: Adding input device Microsft Microsoft Wireless Desktop Receiver 3.1
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 2.1.1
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 4.0
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: always reports core events
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: Device: "/dev/input/event4"
(II) Microsft Microsoft Wireless Desktop Receiver 3.1: Found 6 mouse buttons
(II) Microsft Microsoft Wireless Desktop Receiver 3.1: Found x and y relative axes
(II) Microsft Microsoft Wireless Desktop Receiver 3.1: Found keys
(II) Microsft Microsoft Wireless Desktop Receiver 3.1: Configuring as mouse
(II) Microsft Microsoft Wireless Desktop Receiver 3.1: Configuring as keyboard
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: YAxisMapping: buttons 4 and 5
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Microsft Microsoft Wireless Desktop Receiver 3.1" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: xkb_rules: "evdev"
(**) Option "xkb_model" "pc105"
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: xkb_model: "pc105"
(**) Option "xkb_layout" "us"
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: xkb_layout: "us"
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: (accel) keeping acceleration scheme 1
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: (accel) filter chain progression: 2.00
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: (accel) filter stage 0: 20.00 ms
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: (accel) set acceleration profile 0
(II) config/hal: Adding input device Macintosh mouse button emulation
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event2"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) filter chain progression: 2.00
(**) Macintosh mouse button emulation: (accel) filter stage 0: 20.00 ms
(**) Macintosh mouse button emulation: (accel) set acceleration profile 0
(II) config/hal: Adding input device Microsft Microsoft Wireless Desktop Receiver 3.1
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: always reports core events
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: Device: "/dev/input/event3"
(II) Microsft Microsoft Wireless Desktop Receiver 3.1: Found keys
(II) Microsft Microsoft Wireless Desktop Receiver 3.1: Configuring as keyboard
(II) XINPUT: Adding extended input device "Microsft Microsoft Wireless Desktop Receiver 3.1" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: xkb_rules: "evdev"
(**) Option "xkb_model" "pc105"
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: xkb_model: "pc105"
(**) Option "xkb_layout" "us"
(**) Microsft Microsoft Wireless Desktop Receiver 3.1: xkb_layout: "us"


GoinEasy9 10-19-2009 02:02 PM

In fedora if you run nvidia-settings I do believe when you hit the save option it saves the correct xorg.conf info (if you are root). Does Kubuntu have a nvidia-settings app in it's system tools? It might give you the info your are looking for. I have a dual monitor setup in fedora and run nvidia-settings as user, then copy paste the info into xorg.conf so I can check what is being saved before saving it.

Hewson 10-19-2009 05:47 PM

nvidia-bug-report.sh nvidia-detector nvidia-settings nvidia-xconfig
come with the nvidia package. They aren't distro specific, so yes I have them. Unfortunately the xorg.conf that nvidia-settings creates does not have any list for my intel display, nor does the GUI application seem to recognize the intel display at all; so the xorg.conf isn't much help for getting intel display to work. My nvidia settings seem fine, its the intel settings or some kind of "use multiple monitors" setting that is missing.

GoinEasy9 10-20-2009 11:24 AM

My intel install does not have a dual monitor setup, and thus does not have an xorg.conf in Fedora. Soon xorg.conf will be thrown on the dust heap and hopefully we won't have to be bothered by these setups anymore. Be that as it may, here is my dual monitor listing in nVidia. It may or may not help, it seems to have more info than yours. Unfortunately, not on the intel side.
Code:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder63)  Fri Aug 14 17:55:55 PDT 2009

# Xorg configuration created by livna-config-display

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    ModulePath      "/usr/lib/xorg/modules/extensions/nvidia"
    ModulePath      "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
    Option        "AIGLX" "on"
    Option        "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "XkbLayout" "us"
    Option        "XkbModel" "pc105"
EndSection

Section "InputDevice"
    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Acer AL2216W"
    HorizSync      30.0 - 82.0
    VertRefresh    56.0 - 76.0
EndSection

Section "Device"
    Identifier    "Videocard0"
    Driver        "nvidia"
    Option        "AddARGBGLXVisuals" "True"
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "GeForce 8600 GT"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Videocard0"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option        "TwinView" "1"
    Option        "TwinViewXineramaInfoOrder" "DFP-0"
    Option        "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1680+0"
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection

Section "Extensions"
    Option        "Composite" "Enable"
EndSection

The first thing I noticed is my option "TwinView" = "1" and yours is "0". I was never an expert in Xorg, and now that it's going away I'll probably never be. See if the comparison to mine helps. Sorry I can't help more, I didn't realize my intel install would be devoid of an xorg.conf.


All times are GMT -5. The time now is 01:22 PM.