LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-03-2007, 10:56 AM   #46
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371

Quote:
The Siemens site is down
The manual for your modem will be on the CD that came with it. It will be a PDF file somewhere. Look for it. Read it.
Quote:
Looking at printouts of stuff you have sent, I went back into vi /cat etc etc and got the following:
This information does not help me to help you to help yourself.

Why not? Because you have not told me the command that generated these error messages.

Linux appears to be complaining that you are trying (inadvertantly perhaps) to edit the file with two editors (or two instances of an editor,) at the same time. An easy mistake to make, and I think even Windows complains about this sort of thing. The warnings are both sensible and self-explanatory.

The DHCP server in your modem does not seem to be configured correctly, so you need to set it up. Please read its manual.

Quote:
Looking through the 10.1.1.1 site, the first thing I notice is that it is running PPPoE 8/35. This page also shows my e-mail address.
The "10.1.1.1 site" is your modem's configuration page. PPPoE refers to the connection it is making to your ISP. It shows your email address because this is required for it to log into your ISP and establish a connection.
Quote:
In the "Host Configuration" page it goes thus: I.P Address: 10.1.1.1 IP Netmask 255.255.255.0 then the "Default Gateway" box is empty & next to it is a ticked box that says "Or Use WAN".
This seems to be OK. 10.1.1.1 is the LAN address of your modem.
Quote:
The DHCP page is marked thus: CLIENT IP ADDRESS: 10.1.1.3 IP NETMASK: 255.255.255.0 DEFAULT GATEWAY:10.1.1.1
This all looks fine. It should also say at the top DHCP Server (*)Enable, or have you set it for "Disable" or "Relay"? (Bad choices)
Quote:
DNS SERVER: Blank, with a ticked box next to it that says "or Self". Secondary Dns Server: (optional) blank.
This looks fine.
Quote:
DOMAIN NAME: Domain.invalid. LEASE TIME: 1 minute, with an unticked box next to it which allows for infinite time. m That's it;
Your network may work a little better if you set your lease time to more than one minute (eg 120 minutes).
"Domain.invalid" is a little boring. home.net might be more appropriate
Quote:
The Dynamic DNS settings are ticked "Disable".
That's fine.
Quote:
I can not alter any of the settings I have outlined because the page that allows access has a username "admin" and a password they (Optus)supply, and they only support Internet Explorer.
If you cannot access your modem at http://10.1.1.1 because "it requires IE", then either set it up from windows, using IE, or use firefox and firefox's "User Agent Switcher" (Get it here: http://www.cyberciti.biz/tips/howto-...x-firefox.html ) which will allow firefox to report itself as being IE, and will then work perfectly.

Once you have made the changes, and saved them, reboot your modem, either through its page at 10.1.1.1, or by switching it off & on again. Wait for it to get reconnected to your ISP (There's usually some sort of panel light to tell you this has happened).
Then boot into ubuntu. You should be connected (fingers crossed).
If not, please supply the outputs from the following commands
ifconfig
cat /etc/network/interfaces
sudo ifdown eth0
sudo dhclient eth0


Because you will have changed your modem so its DHCP server is working (I Hope!) you may need to set up windows again. As usual, the instructions will be in the modem's manual, page 9 I think. The important part is Obtain an IP address automatically and Obtain DNS server address automatically because this will use your modem's DHCP server.

Last edited by tredegar; 10-03-2007 at 10:58 AM. Reason: Stupid edit-paste
 
Old 10-03-2007, 02:26 PM   #47
viking1au
Member
 
Registered: Jul 2007
Posts: 41

Original Poster
Rep: Reputation: 15
Did the checks you mentioned in (Win XP) after gleaning what I could from the Optus disc. Entered 10.1.1.1 in the address bar and got the following:
System Summary
System Type: SpeedStream 4200-Series
Config Part #: 003-6190-G07
Firmware Part #: 004-D240-A6R
MAC Address: 00:13:A3:AF:21:B6

Point to Point Connection Summary:
PPPoE 8/35 58.104.55.105
AccConn: vwzd-windsor
(There is that 58 --- number again. Despite it, XP works fine.)
Will post other files from Ubuntu again.
 
Old 10-03-2007, 02:59 PM   #48
viking1au
Member
 
Registered: Jul 2007
Posts: 41

Original Poster
Rep: Reputation: 15
Here they are

laurence@laurence-desktop:~$ sudo ifconfig
eth0 Link encap:Ethernet HWaddr 00:18:F3:FD:94:D2
inet addr:58.104.55.105 Bcast:58.104.55.255 Mask:255.255.255.0
inet6 addr: fe80::218:f3ff:fefd:94d2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:21 errors:0 dropped:0 overruns:0 frame:0
TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4790 (4.6 KiB) TX bytes:2234 (2.1 KiB)
Interrupt:21 Base address:0xb400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

laurence@laurence-desktop:~$

laurence@laurence-desktop:~$ sudo cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp






iface eth0 inet dhcp

auto eth0
laurence@laurence-desktop:~$

laurence@laurence-desktop:~$ sudo ifdown eth0
Password:
There is already a pid file /var/run/dhclient.eth0.pid with pid 5181
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:18:f3:fd:94:d2
Sending on LPF/eth0/00:18:f3:fd:94:d2
Sending on Socket/fallback
DHCPRELEASE on eth0 to 10.1.1.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
laurence@laurence-desktop:~$

laurence@laurence-desktop:~$ sudo dhclient eth0
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:18:f3:fd:94:d2
Sending on LPF/eth0/00:18:f3:fd:94:d2
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPOFFER from 10.1.1.1
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 10.1.1.1
SIOCADDRT: Network is unreachable
bound to 58.104.55.105 -- renewal in 57 seconds.
laurence@laurence-desktop:~$
 
Old 10-03-2007, 03:23 PM   #49
viking1au
Member
 
Registered: Jul 2007
Posts: 41

Original Poster
Rep: Reputation: 15
Well, I did all that prior to making the change in XP from domain.invalid to HOME.NET and changing the lease time to 120 minutes, did a reboot and here I am. Let's hope XP still works tomorrow. ---- Thanks for all your efforts so far.
 
Old 10-03-2007, 03:35 PM   #50
viking1au
Member
 
Registered: Jul 2007
Posts: 41

Original Poster
Rep: Reputation: 15
At last glance, I noticed the address of the router is: 192.168.254.254, as you thought.
 
Old 10-04-2007, 10:00 AM   #51
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Point to Point Connection Summary:
PPPoE 8/35 58.104.55.105
AccConn: vwzd-windsor
(There is that 58 --- number again. Despite it, XP works fine.)
That address is the one your ISP is allocating to your modem / router.
Quote:
aurence@laurence-desktop:~$ sudo ifconfig
eth0 Link encap:Ethernet HWaddr 00:18:F3:FD:942
inet addr:58.104.55.105 Bcast:58.104.55.255 Mask:255.255.255.0
inet6 addr: fe80::218:f3ff:fefd:94d2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:21 errors:0 dropped:0 overruns:0 frame:0
TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4790 (4.6 KiB) TX bytes:2234 (2.1 KiB)
Your PC is picking up your Internet address, it should be picking up an address in the 10.1.1.* range, served up by your router's DHCP server not your ISP's DHCP server.
As I said before, your modem does not seem to have its DHCP server correctly configured. Have you enabled it as I asked earlier? It needs to be set as "Enabled", not as "DHCP Relay".
Quote:
I noticed the address of the router is: 192.168.254.254
No, the Optus model sits at 10.1.1.1 by default.
Why do you think its address is 192.168.254.254 ?
 
Old 10-04-2007, 01:54 PM   #52
viking1au
Member
 
Registered: Jul 2007
Posts: 41

Original Poster
Rep: Reputation: 15
double check

Yes, I have been into the Speedstream settings and checked DHCP settings and it is enabled as you said. Copy and paste of this does not copy the bullets that one ticks or unticks; I have tried this, indeed, it does not copy & paste the boxes with the settings in them,but maybe tis may be the page that has the error????????????

DHCP Configuration

DHCP Server: EnableDisableDHCP Relay (ENABLE BULLET IS TICKED)
Relay IP:
Client IP Address:
IP Netmask:
Default Gateway: or Self
DNS Server:
Primary or Self
DNS Server:
Secondary (Optional)
Domain Name:
Lease Time (mins):
Requires a specified DNS or Infinite time

RELAY IP 0.0.0
Client IP address 10.1.1.3
IP NETMASK 255.255.255.0
DEFAULT GATEWAY 10.1.1.1
DNS SERVER(primary)Panel is blank but small box marked "or self" is ticked
DNS SERVER (secondary)(optional) is blank.
DOMAIN NAME HOME.NET
LEASE TIME 120 MINS. --- SMALL TEXT UNDER THIS STATES "REQUIRES A SPECIFIED DNS". THe box marked "Or infinite time" is not ticked.

Is this starting to hit around the correct area?

The 192 etc etc is something I saw somewhere in the settings; will have to find it again.

The only other thing that puzzled me is in RIP settings; both LAN and PPPoE 8/35 bullets are ticked "Disabled". Dunno about this one. Dynamic DNS page is also ticked "Disable".
 
Old 10-04-2007, 01:59 PM   #53
viking1au
Member
 
Registered: Jul 2007
Posts: 41

Original Poster
Rep: Reputation: 15
"bridge"??????????????

I also notice in the Mode Selection page one can tick or untick "optus bridge",NAPT, or Full Bridge. --- Optus Bridge has the tick.
 
Old 10-04-2007, 02:17 PM   #54
viking1au
Member
 
Registered: Jul 2007
Posts: 41

Original Poster
Rep: Reputation: 15
Re "home.net"

Just fired up Ubuntu again and had a quick peek at Network and I notice Ubuntu has automatically picked up on the changes we made to the Speedstream and in the relevant place, we now have "Home.Net" instead of domain.invalid.- This gives me a glimmer of hope. Ubuntu did this (seemingly) all by itself.
 
  


Reply

Tags
modem, printer, probs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
D-Link DSL-200 Rev B DSL modem -- success!! ludeKing Linux - Hardware 1 03-11-2007 07:32 PM
installing Cups in DSL and using DSL to share a network printer fakie_flip DamnSmallLinux 0 09-13-2006 10:20 PM
Dsl Modem Installation -- Aztech Dsl Turbo 100 psganesh Linux - Networking 0 07-01-2004 03:04 AM
VSFTPD and DSL router probs nuzzy Linux - Networking 0 02-11-2004 11:37 AM
DSL probs w/ Mandrake 9.0 xds4lx Linux - Networking 3 10-12-2002 07:03 PM


All times are GMT -5. The time now is 06:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration