LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 09-29-2007, 02:08 AM   #1
Lannix
LQ Newbie
 
Registered: Jan 2007
Location: Leicester, UK
Distribution: Debian Etch, Mac OS X 10.4
Posts: 23

Rep: Reputation: 15
DRM being disable (?) in Debian 4 w/2.6.21 kernel, ATI Rage 128 Pro


This is my third thread concerning my various X problems, they don't show any signs of letting up!

I'm using a fairly old iMac G3 with an onboard ATI Rage 128 pro TR card and for some reason, DRM is being disabled on startx. For the last few months, I've been running X with the "NoAccel" option enabled, and it's made for a painfully slow system. But it's better than no X. After looking through the net, I think it's to do with a memory error or something in DRI.

I've just tried commenting out the line in xorg.conf which loads GLX (as I don't really need it) thinking this might help, but X catches a Sig 11. I've pasted my Xorg.0.log file up on PasteBin, the URL is below.

I appreciate all help, thanks!


Xorg log: http://pastebin.ca/719377
 
Old 09-29-2007, 03:17 AM   #2
Lannix
LQ Newbie
 
Registered: Jan 2007
Location: Leicester, UK
Distribution: Debian Etch, Mac OS X 10.4
Posts: 23

Original Poster
Rep: Reputation: 15
Woo! After an hour or two of messing with Xorg.conf, I've sorted it. Video RAM was incorrect so set it to use the default ammount.
 
  


Reply

Tags
ati, dri, drm, ppc, rage, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg impossibly slow on Debian Etch (PowerPC) with ATI Rage 128 Pro video card Lannix Linux - Hardware 7 04-20-2007 01:41 AM
ATI Rage 128 pro weijie90 Linux - Hardware 0 07-21-2006 10:02 PM
drm drivers for ati rage 128 pro maq Linux - Hardware 2 05-11-2005 12:14 PM
framebuffer on an ATI 128 Rage Pro falling Linux - Hardware 2 02-01-2005 08:29 PM
XFree86 and ATI Rage 128 Pro TF falstaff Linux - Software 2 03-16-2003 01:53 PM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration