LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-06-2003, 11:01 PM   #1
jslade
LQ Newbie
 
Registered: Apr 2003
Distribution: RedHat
Posts: 3

Rep: Reputation: 0
Question DMA on /dev/hda but not on /dev/dvd


I am trying to enable DMA mode on my dvd-rom to get enough speed to actually play a dvd. My drive supports DMA, so does the controller/motherboard, but I can get it to work. My HD is already running in DMA mode (set at startup), so I can't understand why the dvd doesn't work.

# hdparm -d1 /dev/dvd <-- As root, of course

/dev/dvd:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)


# hdparm -i /dev/dvd

/dev/dvd:

Model=HITACHI DVD-ROM GD-7500, FwRev=0005, SerialNo=
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: sdma0 sdma1 sdma2 mdma0 mdma1 *mdma2
UDMA modes: udma0 udma1 udma2
AdvancedPM=no

# hdparm -i /dev/hda

/dev/hda:

Model=MAXTOR 4K040H2, FwRev=A08.1500, SerialNo=572121417537
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
RawCHS=16383/16/63, TrkSize=32256, SectSize=21298, ECCbytes=4
BuffType=DualPortCache, BuffSize=2000kB, MaxMultSect=16, MultSect=16
CurCHS=4047/16/255, CurSects=16511760, LBA=yes, LBAsects=78198750
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2
AdvancedPM=no WriteCache=enabled
Drive conforms to: ATA/ATAPI-5 T13 1321D revision 1: 1 2 3 4 5


The motherboard is SiS, I don't know the exact details (dmesg says omething about SIS5513, SIS730 ATA 100 controller)

Thanks for any help

Jeremy
 
Old 04-06-2003, 11:22 PM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
First off, try finding where /dev/dvd is pointing to:
ls -l /dev/dvd
Then, taking the actual device, try there:
hdparm -d1 /dev/hdX

If your device is using scsi emulation, determine which standard ide block device it was before emulation occured:
hda = Primary Master
hdb = Secondary Master
hdc = Primary Slave
hdd = Secondary Slave

Also, check the man page, it mentions using the -X option with -d option to ensure it uses the correct dma.

So
hdparm -d1 -X udma2 /dev/hdX
might be what you are looking for.

Cool
 
Old 04-07-2003, 09:19 AM   #3
jslade
LQ Newbie
 
Registered: Apr 2003
Distribution: RedHat
Posts: 3

Original Poster
Rep: Reputation: 0
Using hdparm -X option didn't help, still same result:

(/dev/dvd is linked to /dev/hdb, btw)

# hdparm -d1 -X udma2 /dev/hdb

/dev/hdb:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
setting xfermode to 66 (UltraDMA mode2)
using_dma = 0 (off)

Same result for any of the other DMA modes (sdma0, mdma2)


Thanks for the suggestion, though...
 
Old 04-07-2003, 10:10 AM   #4
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
Do a search of the forums, I just noticed you are using RedHat and I recall there is a specific problem with enabling DMA on cdrom/dvdroms with RedHat, there's a setting you have to enter somewhere (I don't remember).
 
Old 04-07-2003, 11:26 PM   #5
jslade
LQ Newbie
 
Registered: Apr 2003
Distribution: RedHat
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the suggestion. I had no idea this problem was specific to rh-8.0. Here's what I found:

---------------------------------------------------------------------
I had the same problem. Here's the solution from Red Hat's web site:

NOTE: As with the 8.0 release, IDE DMA on CD-ROM drives is disabled by
default. If you are sure that your CD-ROM drive is capable of IDE
DMA, place the following line in the /etc/modules.conf file:

options ide-cd dma=1

I did it and now DVD is smooth as silk.
-----------------------------------------------------------------------

I did the same thing, works perfectly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enabling DMA on my /dev/hda Riddick Slackware 11 12-13-2005 07:28 PM
/dev/hda under lilo.conf even thoug my HD is under /dev/hdb Basel Slackware 8 10-27-2005 06:00 PM
Cannot find DVD-Burner (/dev/hda) logosys Linux - Hardware 6 07-24-2005 08:14 PM
howto turn on DMA for /dev/hda ? tdking19 Linux - Hardware 3 05-15-2005 07:31 AM
How can I boot either one of my hard drives /dev/hda or /dev/hdb, I have RH9 and FC2 omogunkristi Linux - General 1 06-21-2004 05:11 AM


All times are GMT -5. The time now is 05:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration