LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-28-2005, 02:17 PM   #1
NeilB
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Rep: Reputation: 0
Question DLT-4000 drive on Dell6100/SLES 9 sp1


I cannot get the DLT tape drive to work.
Running Suse Linux Enterprise Server v9 sp1 on a Dell 6100/200 with LSI Megaraid Controller/Adaptec 7880 scsi. The DLT-4000 tape drive is on the non-raid controller channel with a cdrom (which works fine), and I've loaded a new Quantum DLTtape IV (40/80 GB), and green light came on. Set the Density Select button to 20.0gb/Compress/Density Override indicators flashing yellow.
I cannot mount the st0 drive or otherwise make use of the tape drive.
Can someone help me? Is there some step I've missed (like "formatting" the tape - remember tape drive newbie here ;-)?

eduapp04:/ # mt -f /dev/st0 status
mt: /dev/st0: Input/output error

Looking in /dev I found a directory /dev/tape/by-path:

eduapp04:/dev/tape/by-path # ls -al
total 0
drwxr-xr-x 2 root root 104 Jan 28 11:44 .
drwxr-xr-x 3 root root 72 Jan 4 05:02 ..
lrwxrwxrwx 1 root root 9 Jan 28 11:44 pci-0000:01:0c.0-scsi-0:0:6:0-generic -> ../../sg1

but /dev/sg1 will not respond to mount either.

eduapp04:/dev # mt -f /dev/sg1 status
mt: /dev/sg1: Operation not permitted
eduapp04:/dev #

From some of the posts here I tried the following commands for some more info: --- and THANKS for any help received!

************************************************************
eduapp04:~ # dmesg | grep scsi
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
(scsi0:A:1): 20.000MB/s transfers (20.000MHz, offset 15)
scsi1 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
scsi2:Found MegaRAID controller at 0xe490, IRQ:20
scsi2 : LSI Logic MegaRAID U.77 254 commands 16 targs 5 chans 7 luns
scsi2: scanning scsi channel 0 for logical drives.
Attached scsi disk sda at scsi2, channel 0, id 0, lun 0
scsi2: scanning scsi channel 4 [P0] for physical devices.
scsi2: scanning scsi channel 5 [P1] for physical devices.
sr0: scsi-1 drive
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 1, lun 0
Attached scsi tape st0 at scsi0, channel 0, id 6, lun 0
Attached scsi generic sg0 at scsi0, channel 0, id 1, lun 0, type 5
Attached scsi generic sg1 at scsi0, channel 0, id 6, lun 0, type 1
Attached scsi generic sg2 at scsi2, channel 0, id 0, lun 0, type 0
Attached scsi generic sg3 at scsi2, channel 4, id 6, lun 0, type 3
Attached scsi generic sg4 at scsi2, channel 4, id 6, lun 1, type 3
Attached scsi generic sg5 at scsi2, channel 4, id 6, lun 2, type 3
Attached scsi generic sg6 at scsi2, channel 4, id 6, lun 3, type 3
Attached scsi generic sg7 at scsi2, channel 4, id 6, lun 4, type 3
Attached scsi generic sg8 at scsi2, channel 4, id 6, lun 5, type 3
Attached scsi generic sg9 at scsi2, channel 4, id 6, lun 6, type 3

************************************************************
eduapp04:/ # mt -f /dev/st0 status
mt: /dev/st0: Input/output error

************************************************************
eduapp04:/dev # lsmod
Module Size Used by
vfat 19456 0
fat 49824 1 vfat
usbserial 36080 0
parport_pc 41280 1
lp 15492 0
parport 44232 2 parport_pc,lp
edd 13720 0
joydev 14528 0
sg 41760 0
st 45212 0
sr_mod 21028 0
ide_cd 42628 0
cdrom 43036 2 sr_mod,ide_cd
nvram 13448 0
ipv6 275580 41
af_packet 26376 2
evdev 13952 0
usbcore 116700 2 usbserial
e100 38400 0
mii 9344 1 e100
subfs 12160 2
dm_mod 59904 0
reiserfs 264016 1
megaraid 44104 3
megaraid_mm 15648 0
aic7xxx 198452 1
sd_mod 25088 4
scsi_mod 120132 6 sg,st,sr_mod,megaraid,aic7xxx,sd_mod

************************************************************
eduapp04:/dev # cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 01 Lun: 00
Vendor: TOSHIBA Model: CD-ROM XM-6401TA Rev: 1009
Type: CD-ROM ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 06 Lun: 00
Vendor: Quantum Model: DLT4000 Rev: CD50
Type: Sequential-Access ANSI SCSI revision: 02
Host: scsi2 Channel: 00 Id: 00 Lun: 00
Vendor: MegaRAID Model: LD0 RAID5 42840R Rev: U.77
Type: Direct-Access ANSI SCSI revision: 02
Host: scsi2 Channel: 04 Id: 06 Lun: 00
Vendor: DELL Model: 6UW BACKPLANE Rev: 7
Type: Processor ANSI SCSI revision: 02
Host: scsi2 Channel: 04 Id: 06 Lun: 01
Vendor: DELL Model: 6UW BACKPLANE Rev: 7
Type: Processor ANSI SCSI revision: 02
Host: scsi2 Channel: 04 Id: 06 Lun: 02
Vendor: DELL Model: 6UW BACKPLANE Rev: 7
Type: Processor ANSI SCSI revision: 02
Host: scsi2 Channel: 04 Id: 06 Lun: 03
Vendor: DELL Model: 6UW BACKPLANE Rev: 7
Type: Processor ANSI SCSI revision: 02
Host: scsi2 Channel: 04 Id: 06 Lun: 04
Vendor: DELL Model: 6UW BACKPLANE Rev: 7
Type: Processor ANSI SCSI revision: 02
Host: scsi2 Channel: 04 Id: 06 Lun: 05
Vendor: DELL Model: 6UW BACKPLANE Rev: 7
Type: Processor ANSI SCSI revision: 02
Host: scsi2 Channel: 04 Id: 06 Lun: 06
Vendor: DELL Model: 6UW BACKPLANE Rev: 7
Type: Processor ANSI SCSI revision: 02
 
Old 01-28-2005, 05:35 PM   #2
NeilB
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Original Poster
Rep: Reputation: 0
POSSIBLY SOLVED! Our school received a donation of 2 Dell 6100s and I caniballized one of them for it's DLT4000 drive; tried this other unit in the problem machine and Presto! it seems to work fine. Original DLT drive has a hardware problem I guess.
Thanks to the forum for many other clues on how to approach this,and one in particular for a backup script I'm putting to use with some mods...

Regards,

NeilB
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get and apply SLES 9 sp1? RonRafajko Suse/Novell 1 03-01-2006 10:07 AM
tar command and dlt drive LuvdemHeels Red Hat 0 11-24-2004 03:29 PM
removing XP SP1 DAChristen29 General 2 10-16-2003 01:57 PM
DLT 40 How do I access this tape drive? chr15t0 Linux - Hardware 1 02-14-2003 10:13 AM
Linux with SCSI DLT drive AMilroy Linux - General 0 07-09-2001 11:01 AM


All times are GMT -5. The time now is 01:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration