LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-20-2004, 10:15 PM   #1
Reu
LQ Newbie
 
Registered: Jul 2004
Posts: 5

Rep: Reputation: 0
Display Mode Not Supported Error After Plugging In New Monitor


Greetings to all,

So this morning I recieved my new LCD monitor...

Plugged in my new LCD monitor to my Red Hat Linux box..

Turn on the machine..

Greeted by the regular OS loader and the interactive startup mode..

Finally it's up and I should see the desktop(KDE) login screen..

..but the screen went black with a "Diplay Mode Not Supported" box floating around..

My guess is because the old monitor's refresh rate/resolution/monitor info... is still being loaded therefore those do not work with my LCD monitor..

Is there a way which I can remedy this little problem I have?
 
Old 07-20-2004, 10:29 PM   #2
BajaNick
Senior Member
 
Registered: Jul 2003
Location: So. Cal.
Distribution: Slack 11
Posts: 1,737

Rep: Reputation: 46
You probably have to modify your XF86Config file but I dont know what you would modify in it. Maybe go through it and find a line that has LCD in it or something, try a google for LCD displays and Linux.
 
Old 07-21-2004, 03:27 AM   #3
transke
LQ Newbie
 
Registered: Jul 2004
Posts: 12

Rep: Reputation: 0
Hi there

I am also having a problem with my LCD screen, but mine is that I cannot change the resolution and it is stuck on 640x480. If you managed to fix your problem please post a message, maybe it will work on my monitor as well...

T.S.
 
Old 07-21-2004, 05:00 AM   #4
Frustin
Member
 
Registered: May 2002
Location: Essex, UK
Distribution: Debian, Redhat, AIX 5L
Posts: 512

Rep: Reputation: 30
both of you post your /etc/X11/XF86Config-4 files on here.
 
Old 07-21-2004, 01:22 PM   #5
transke
LQ Newbie
 
Registered: Jul 2004
Posts: 12

Rep: Reputation: 0
I do not know what information that could be useful so I just send all o fthe ciontent of the xorg.conf file:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "no"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1280x1024"
DisplaySize 340 280
HorizSync 31.5 - 80.0
VertRefresh 56.0 - 75.1
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
VendorName "Videocard vendor"
BoardName "ATI Radeon 7000"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Thank you for helping...


I just tried my neighbours CRT monitor it was working fine. Seems like the problems is with my LCD monitor and linux. Anybody heard of similar problems? Maybe it is because I use it in analog mode? It seems like linux does not find my LCD monitor...

T.S.
 
Old 07-22-2004, 02:46 AM   #6
Frustin
Member
 
Registered: May 2002
Location: Essex, UK
Distribution: Debian, Redhat, AIX 5L
Posts: 512

Rep: Reputation: 30
where did you get this settings?

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1280x1024"
DisplaySize 340 280
HorizSync 31.5 - 80.0
VertRefresh 56.0 - 75.1
Option "dpms"
EndSection

type at the command line:

Xfree86 -xf86config /root/XF86Config-4.new

open the newly created /root/XF86Config-4

then take the settings that were created in there.
 
Old 07-22-2004, 09:28 AM   #7
transke
LQ Newbie
 
Registered: Jul 2004
Posts: 12

Rep: Reputation: 0
Hi

Everything in the settings is when I choose a generic LCD panel with the given resolution. The horSync and VertRefresh rates I got from Eizo. com. The setting is for analog mode for the L550.

When I type

Xfree86 -xf86config /root/XF86Config-4.new

in the command line it does not recognize the command.

When I press the INFO-button in the screen it says something like "input 640x480" and this do not change, No matter what I change in the XF86Config-4 file.

I have Linux Mandrake 10.0

Sorry for using someone elses thread for my question but maybe we could help each other, it may be the same problem.

T.S.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell 1905FP flatscreen error "Cannot display this video mode", under X Ford Prefect Linux - Hardware 5 09-30-2008 08:49 AM
Mode ot Supported.. HELP!!! MentoZ Linux - Newbie 6 11-19-2005 03:20 PM
Change the display mode in text mode Drunkalot Linux - General 7 08-12-2005 11:35 AM
How can I change display mode from character mode to graph mode wuzhong Linux - Hardware 1 08-08-2004 09:36 AM
cc1: error: code model `kernel' not supported in the 32 bit mode Doleo Linux - Newbie 0 02-26-2004 08:16 AM


All times are GMT -5. The time now is 08:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration