LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 08-27-2011, 12:50 PM   #1
Jeff91
Bodhi Developer
 
Registered: Jan 2009
Location: Alsip, IL
Distribution: Bodhi and Maemo
Posts: 297

Rep: Reputation: 33
Display Link Setup with Plugable UGA-2k-A


I took the plunge and picked one of these up for my Linux box. I simply need a second working X server on my second display.

No matter which tutorials I follow though I cannot seem to get it to work. I'm running on the 3.0 version of the Linux kernel and I've install the display link xorg driver and built and installed the latest libdlo. I know the adapter is functioning with my system because running "sudo make check" from the libdlo directory causes my external screen to display the test images A-OK.

This is my current xorg.conf - http://pastebin.com/Vr6Jd2D5

I based it off of settings I found here - http://mulchman.org/blog/?p=21

My primary screen comes on line after a reboot, but I still get something on the external display. I can confirm that there is a displaylink_drv.so located in my /usr/lib/xorg/modules/drivers directory.

Anyone know what I am missing here?
~Jeff
 
Old 08-27-2011, 05:13 PM   #2
Jeff91
Bodhi Developer
 
Registered: Jan 2009
Location: Alsip, IL
Distribution: Bodhi and Maemo
Posts: 297

Original Poster
Rep: Reputation: 33
I've made some progress for any that may know where I should be headed next -

When I configure the display link screen to be screen 0 it works fine, but I cannot access my internal display (laptop). When I configure my internal display to be screen 0 it works fine but I cannot access the display link screen. Any ideas? this is my xorg.conf: http://pastebin.com/yzm7WSaV

~Jeff
 
  


Reply

Tags
displaylink, displays, hardware, xorg, xorg.conf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't display graphics, display manager may not be setup dsollen Linux - Software 5 06-17-2009 02:13 PM
SCSI Tape Drive hot plugable? davidstvz Linux - Hardware 9 08-28-2008 01:48 PM
canīt hear sounds or see any plugable or mountable devices ... rem1986 Debian 1 12-30-2005 11:59 AM
right-click menu won't display;touchgraph link browser jariep Linux - Software 0 04-28-2004 02:46 PM
ip link setup eth0 up hangs thomasb Linux - Networking 0 01-12-2003 08:24 AM


All times are GMT -5. The time now is 03:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration