LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-26-2007, 10:24 AM   #1
Grid_Iron
LQ Newbie
 
Registered: Oct 2006
Location: Makati, Phillipines
Distribution: Mandrake Linux 10.0
Posts: 6

Rep: Reputation: 0
display in monitor is too big for the screen in X


I have just installed an nvidia driver correctly with no errors (what I assume)but when i finished, then started X then I saw my desktop was too big for my screen. When I move my mouse left to right, up or down , I can go to different parts of the desktop but I cannot see my desktop as a whole.

My XF86Config-4 shows:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Nov 9 17:55:20 PST 2006

# File generated by XFdrake.
# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1" 0 0
EndSection

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "glx"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)

# allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
Identifier "monitor1"
VendorName "Plug'n Play"
HorizSync 30.0 - 50.0
VertRefresh 50.0 - 100.0
ModeLine "1024x480" 65.0 1024 1032 1176 1344 480 488 494 563 -hsync -vsync
ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
BoardName "NVIDIA GeForce DDR (generic)"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
DefaultDepth 24
Option "DPMS"
EndSection
 
Old 04-26-2007, 11:08 AM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
You have some strange modeline info there.. 1024 x 480 is a very weird size. My guess is that the X server is deciding to use a screen size which is smaller than what you have set as 'Virtual Size' for the desktop. In other words, your virtual desktop is larger than the chosen resolution for the monitor.
I don't use modelines myself, I use the standard format in my display sections, like "1024x768", so if you want to use modelines, you will need to do a little bit of searching here for threads about "xorg.xonf, modeline, xconfig, nvidia" etc..
As an experiment, you could comment out the 3 modelines, and in the SubSection "Display", under the line "Depth 24" put a line like:
Modes "1024x768"
and comment out the Virtual mode.

An easier way might be to simply run 'xorgconfig' or 'xconfig' whichever it is, and go through the process of answering the questions to set it up and create a new config file. Be sure to NOT choose Virtual desktop. That in itself is what's making your desktop bigger thsn your monitor.
WHen all done, you will need to change the Driver back to 'nvidia' instead of 'nv' as the config-tool will put 'nv' in there.
Best of luck.

Last edited by GrapefruiTgirl; 04-26-2007 at 11:10 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Desktop too big for monitor screen jwillar Linux - Hardware 1 11-11-2006 09:46 AM
White screen display on monitor saege Mandriva 11 11-09-2006 06:09 AM
GDM/KDM Login Screen too big for screen on ATI 3D Rage Pro daemon_14 Linux - Software 0 01-14-2006 02:34 PM
Login Screen always appears on 2nd monitor of dual display... Billydakid Linux - Hardware 0 11-09-2005 11:06 PM
Screen Mackin' Big and Off Screen With Slackware. SammyK Linux - General 1 10-01-2003 09:16 AM


All times are GMT -5. The time now is 06:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration