LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 01-03-2013, 02:57 AM   #1
miros84
Member
 
Registered: Aug 2009
Location: Spain
Distribution: Debian stable, squeeze
Posts: 501

Rep: Reputation: 31
Disable keyboard to wakeup my computer.


How can I disable that keyboard can wakeup my computer.
I want to be wake up only by mouse.

I use Debian Wheezy.
 
Old 01-03-2013, 03:04 AM   #2
trevoratxtal
Member
 
Registered: Dec 2012
Location: South Devon, UK
Distribution: PCLinuxOS, Suse, Mint, Puppy.
Posts: 41

Rep: Reputation: 3
Wake up on-----

I think that is a Bios setting and may or not be in your computer,
If you have problems getting to your Bios please come back.
It is something that happens long before Linux Kernel is awake, unless some one can tell me otherwise.
Trev

Last edited by trevoratxtal; 01-03-2013 at 03:05 AM. Reason: spelling
 
Old 01-03-2013, 08:17 AM   #3
miros84
Member
 
Registered: Aug 2009
Location: Spain
Distribution: Debian stable, squeeze
Posts: 501

Original Poster
Rep: Reputation: 31
I dont think so.
In Windows, you can set which devices can wake or not the computer when it suspend.
Going to device managager, but in Linux? How can I disable or enable which devices can wake it up?
 
Old 01-03-2013, 10:10 AM   #4
trevoratxtal
Member
 
Registered: Dec 2012
Location: South Devon, UK
Distribution: PCLinuxOS, Suse, Mint, Puppy.
Posts: 41

Rep: Reputation: 3
Wake up

wake up from keyboard/mouse/lan is a part of Bios and works from cold start.
Whereas
You require wake up from Sleep that is different as the operating system is already running only on hold.
As I do not wish to use Windows it is not in my experience so I cannot help sorry.
Trev
 
Old 02-06-2013, 05:56 AM   #5
miros84
Member
 
Registered: Aug 2009
Location: Spain
Distribution: Debian stable, squeeze
Posts: 501

Original Poster
Rep: Reputation: 31
Somebody else? I can disable keyboard in Windows in device manager and prevent to wake up the computer.
What about Linux?
 
Old 02-06-2013, 08:46 AM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,653
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
trevoratxtal is right, usually this is a BIOS setting (Windows is able to interface with your BIOS, for example to set a wake-up alarm time). I would look there first.
 
Old 02-07-2013, 11:10 AM   #7
Pastychomper
Member
 
Registered: Sep 2011
Location: Scotland
Distribution: Debian
Posts: 53

Rep: Reputation: 24
If you're talking about 'sleep' as in suspend to RAM rather than 'hibernate' (suspend to disc) then there is a way to do it in software. I know because when I upgraded from Lenny to Squeeze I lost the ability to wake by keyboard, but can still wake by pressing the power button. I made no direct changes to the BIOS in that time. I even had the two versions dual-booting for a while - Lenny wakes from keyboard, Squeeze does not.

Unfortunately I don't know what the difference is, so can't help there.
 
Old 02-11-2013, 10:58 AM   #8
miros84
Member
 
Registered: Aug 2009
Location: Spain
Distribution: Debian stable, squeeze
Posts: 501

Original Poster
Rep: Reputation: 31
Yes, I am talking about suspend in memory. I looked in Bios but keyboard suspend is disbled. I tried to enable but it was the same. Computer wake up when somebody touch the keyboard.
I put it in disalbe again. Must be some software way to change that. Something in kernel or config file somewhere, but I dont know what to change there. If somebody has any idea?...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] disable keyboard temporarily so that a book on keyboard does nothing. ununun Linux - General 9 12-09-2012 10:03 AM
Disable AND Enable Keyboard FROM the Keyboard pukster Linux - Hardware 2 02-09-2011 11:55 AM
How to disable second keyboard in X? Jaa Linux - Desktop 0 08-22-2006 11:14 AM
keyboard shortcut for poweroff, sleep, wakeup ashwin_cse Linux - Hardware 1 10-28-2005 06:09 AM
Wakeup with USB keyboard jonathan_hehn Mandriva 1 12-20-2003 02:02 AM


All times are GMT -5. The time now is 11:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration