LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Dis-able touchpad tapping 10.04, Dell Inspiron (http://www.linuxquestions.org/questions/linux-hardware-18/dis-able-touchpad-tapping-10-04-dell-inspiron-4175430580/)

buccaneere 10-04-2012 07:49 PM

Dis-able touchpad tapping 10.04, Dell Inspiron
 
Anyone know how-to?

notsure 10-04-2012 09:25 PM

I use gsynaptics

TobiSGD 10-04-2012 09:35 PM

You can use a xorg configuration file for that. Here is mine, for example:
Code:

# #
# # Use "synclient -l" to see all available options
# # Use "man synaptics" for details about what the options do
# #
 Section "InputClass"
        Identifier "touchpad"
        Driver "synaptics"
        MatchDevicePath "/dev/input/event*"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "TapButton2" "0"
        Option "TapButton3" "0"
        Option "VertEdgeScroll" "1"
        Option "HorizEdgeScroll" "1"
        Option "MinSpeed" "1.1"
        Option "MaxSpeed" "1.9"
EndSection

Edit this file to your needs (to disable tapping set all TapButton entries to 0) and save it as 50-synaptics.conf in the directory /etc/X11/xorg.conf.d/ (you have to be root to do this). Then restart the X server, usually it is sufficient to log out and in again.

buccaneere 10-04-2012 10:03 PM

Quote:

Originally Posted by TobiSGD (Post 4797686)
You can use a xorg configuration file for that. Here is mine, for example:
Code:

# #
# # Use "synclient -l" to see all available options
# # Use "man synaptics" for details about what the options do
# #
 Section "InputClass"
        Identifier "touchpad"
        Driver "synaptics"
        MatchDevicePath "/dev/input/event*"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"
        Option "TapButton2" "0"
        Option "TapButton3" "0"
        Option "VertEdgeScroll" "1"
        Option "HorizEdgeScroll" "1"
        Option "MinSpeed" "1.1"
        Option "MaxSpeed" "1.9"
EndSection

Edit this file to your needs (to disable tapping set all TapButton entries to 0) and save it as 50-synaptics.conf in the directory /etc/X11/xorg.conf.d/ (you have to be root to do this). Then restart the X server, usually it is sufficient to log out and in again.


Thanks notsure, but adding programs (even native Linux applications) defeats the whole purpose IMO of open source...

I was looking for /etc/X11/xorg.conf like in old OS files, but no luck.

And I cannot find file inside dir, entitled /etc/X11/xorg.conf.d , even as root browser in Nautilus (10.04LTS)

TobiSGD 10-04-2012 10:48 PM

I can't see how adding programs, especially open source programs, defeats the purpose of open source.

But anyways, as I stated above, you have to save the the code I posted as a file named 50-synaptics.conf in the directory /etc/X11/xorg.conf.d/, that means you have to create the file yourself.

buccaneere 10-08-2012 01:53 PM

Quote:

Originally Posted by TobiSGD (Post 4797709)
I can't see how adding programs, especially open source programs, defeats the purpose of open source.

But anyways, as I stated above, you have to save the the code I posted as a file named 50-synaptics.conf in the directory /etc/X11/xorg.conf.d/, that means you have to create the file yourself.

Done; thanks. The touch pad was about to get NUKED UGH...

.......................................

Defeat was not the right word.

My point was, open source is about being able to modify the [base] script for the function. If you can do that, THAT'S the first option, if you want only to modify a function.

If you cannot do that (like in Windows), and you have to load a program piggy back to accomplish the function mod, it's not 'pure' open source, in it's most basic sense.


All times are GMT -5. The time now is 03:32 PM.