LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-09-2004, 10:48 AM   #31
titetanium
Member
 
Registered: Mar 2004
Distribution: debian testing/unstable
Posts: 68

Rep: Reputation: 16

I went and compiled the savage drivers like you said, and it compiled without errors. Copied the drivers to /lib/modules/linuxversion/kernel/drivers/char/drm directory and then ran depmod -a. Result was unresolved symbol errors with the drm modules. The new XF86 server was awesome! It made my mouse run like as if I was running 2.6............., gee whiz fast! Glinfo shows dri as not enabled. How do I sort out the unresolved symbols? Oh and btw, I found the same drm driver in the kernel source and then edited the config.in file to enable me to choose to compile the savage drm driver into the kernel or as a module and then recompiled a new kernel, inserted kernel, rebooted, and then tried to insert the savage module with the same unresolved symbols errors. Grrrrrr, I've been wanting to get the 3d thing going for a long while, and this is frustrating to say the least.
 
Old 05-09-2004, 10:37 PM   #32
titetanium
Member
 
Registered: Mar 2004
Distribution: debian testing/unstable
Posts: 68

Rep: Reputation: 16
Nevermind. I hacked and sorted out the unresoved symbols. Now it works! woot!!!!!!!!!!!!!!!!!!!!
Btw, what does woot mean anyway?
 
Old 05-10-2004, 04:15 AM   #33
janfy_fr
LQ Newbie
 
Registered: May 2004
Location: France, Longpont sur Orge
Distribution: Debian
Posts: 14

Rep: Reputation: 0
$ cat /proc/dri/0/name
savage 0xe200 pci:0000:01:00.0

$ glxinfo | more
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: Brian Paul
server glx version string: 1.4 Mesa 5.0

I don't know how to check if it is the latest version or not, but I downloaded it via CVS two weeks ago...
 
Old 05-10-2004, 04:46 AM   #34
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Original Poster
Rep: Reputation: 46
There is another VIA\S3 DRI HOWTO here. The sections on setting up the XF86Config-4 file is a little different. He has you put load "GLcore", and the Device section is more detailed also.
 
Old 05-10-2004, 03:11 PM   #35
janfy_fr
LQ Newbie
 
Registered: May 2004
Location: France, Longpont sur Orge
Distribution: Debian
Posts: 14

Rep: Reputation: 0
DRI operates on my laptop! Yes!!
Thank you /bin/bash and Fransemail! I think I would have given up without your pieces of advice!

Things have gone better when I did this :
$cd /usr/src/xc/xc/programs/Xserver/hw/xfree86/drivers/savage
$make install
$ldconfig
$sync
$insmod

I restarted (without conviction), and glxinfo last telled me "Direct Rendering : yes"!
glxgears now reaches 500 fps instead of 240 before!

Thanks again. Now you can say me : Have fun! ;o)
 
Old 05-12-2004, 04:54 PM   #36
alex-gurgel
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.0 Professional
Posts: 2

Rep: Reputation: 0
Hi ! Recently i've found this post and try to make this in my SuSE 9.0 linux.

Well, I'm having this error:
Code:
make[5]: Leaving directory /build/xc/xc/programs/Xserver/hw/xfree86/drivers'
make[4]: *** [clean] Error 2
make[4]: Leaving directory `/build/xc/xc/programs/Xserver/hw/xfree86'
make[3]: *** [clean] Error 2
make[3]: Leaving directory `/build/xc/xc/programs/Xserver'
make[2]: *** [clean] Error 2
make[2]: Leaving directory `/build/xc/xc/programs'
make[1]: *** [clean] Error 2
make[1]: Leaving directory `/build/xc/xc'
make: *** [World] Error 2
I'm trying to compile in my own user, not in root. What I can do to resolve this ? Maybe logging root?


P.S.: Sorry about my english....
 
Old 05-13-2004, 01:34 PM   #37
alex-gurgel
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.0 Professional
Posts: 2

Rep: Reputation: 0
I forgot to say something? The folder /build/xc.... is in my home directory.

Help, please !!!!!
 
Old 05-16-2004, 06:44 PM   #38
dacosta
LQ Newbie
 
Registered: May 2004
Distribution: Fedora Core 1
Posts: 13

Rep: Reputation: 0
*sighs* *frustration*

Hi!

Can anyone tell me how to get rid of this
"depmod: *** Unresolved symbols in /lib/modules... " message :-/ What did I wrong? Any suggestions?


Bye

Luis

P.S: I use Fedora Core with a 2.4.22 Kernel.
 
Old 05-25-2004, 06:51 AM   #39
BruceCadieux
Member
 
Registered: Apr 2002
Location: Wales MA.
Distribution: openSuSE 11.1
Posts: 409

Rep: Reputation: 32
After trying everything listed here, it wouldn't work.

The modules were not recognized and wouldn't load.

agpgart, via_agp, and savage.ko wouldn't load. I read through the instructions at http://linux-sxs.org/guis/DRIS3.html

I realized loading those modules before x started may work and it was.

I added the following lines to the end of my /etc/init.d/rc file
modprobe via_agp

modprobe agpgart

/sbin/insmod /lib/modules/"$(uname -r)"/kernel/drivers/char/drm/savage.ko

I rebooted and after starting x glxinfo reported direct rendering was enabled, and glxgears was showing better then double the speed I was getting before.

Quake3 plays very well.
 
Old 07-07-2004, 09:33 PM   #40
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Original Poster
Rep: Reputation: 46
Here is a quicker method I discovered. I used this method when I installed Suse-9.1, but it should work for most distros. The default Suse kernel doesn't have DRI turned on so I had to build a new kernel and enable DRI. Even though there is no S3/VIA option in the kernel config you still must turn on DRI in the kernel (it's below /dev/agpgart in the Device drivers/Character devices section.) I did not stress this point in my first post and this may be causing some people some problems. So as long as you have your kernel sources properly installed(see post #1) and you enabled DRI in the kernel you should be OK. This should also work on other Graphics cards besides the S3/VIA Savage.

Here is the Step-by-step guide.
  • Get a snapshot from http://www.freedesktop.org/dri/snapshots/
    NOTE: You must get a common- package as well as the savage snapshot.
  • Un-pack both packages in the same directory, this will create a directory dripkg with all the necessary files.
    tar xjvf common-20040628-linux.i386.tar.bz2
    tar xjvf savage-20040628-linux.i386.tar.bz2
  • Go into dripkg directory and run the script install.sh. NOTE: You must be root to run the script.
    cd dripkg
    sudo ./install.sh
  • If you had no errors in the above step then proceed, otherwise you need to find out what the problem is.
  • Now verify you have your /etc/X11/XF86Config file setup as mentioned in the first post.
  • Check that the agpgart and via_agp modules are loaded. If not you may need to edit /etc/modprobe.conf.
  • If you are in X then exit and restart and you should have DRI running.

I have used this method several times since I discovered it. It saves me a lot of time and the snapshots are kept up-to-date so you always get the latest updates to the DRI tree.

Once again I hope this helps someone.

[EDIT] According to azeemarif you should un-tar the common package first then the savage package. Also if you have an older XFree-server you will need to build or get a newer version.

You should also check out the DRI Open Source Project Documentation. They will have the latest information.

Because you are using a snapshot of the savage dri sources there may be bugs which make them fail. If you have problems try downloading an older snapshot or a newer one as they come out.

<Edit> Fixed broken link.

Last edited by /bin/bash; 12-24-2004 at 04:44 PM.
 
Old 08-14-2004, 10:39 PM   #41
shep fc3
LQ Newbie
 
Registered: Aug 2004
Posts: 16

Rep: Reputation: 0
I know this is kinda an old thread, but I found it pretty helpful. However I am not able to get it installed and running properly. I have tried 3 different methods and none have worked. When I try the one from the first post, and also the method posted at http://www.linux-sxs.org/guis/DRIS3.html I get the following error:

accessx.c:532: error: `XtNstate' undeclared (first use in this function)
accessx.c:532: warning: left-hand operand of comma expression has no effect
make[6]: *** [accessx.o] Error 1

Then when I try the method in the last post (which is much faster), I get this error:

Compiling...
ERROR: Kernel modules did not compile

The DRI drivers can not be installed without the latest kernel modules.
Installation will be aborted. See the dri.log file for information on
what went wrong.

I just upgraded to kernel 2.6.7, so it should be ok. Any help would be greatly appreciated.
 
Old 08-17-2004, 04:28 PM   #42
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Original Poster
Rep: Reputation: 46
shep

Did you enable enable DRI in your 2.6.7 kernel? I know there is no S3/VIA dri module in the kernel but it seems you still need to turn that option on.

Try this:
Code:
$ grep DRM /usr/src/linux/.config
CONFIG_DRM=y
# CONFIG_DRM_TDFX is not set
# CONFIG_DRM_GAMMA is not set
# CONFIG_DRM_R128 is not set
# CONFIG_DRM_RADEON is not set
# CONFIG_DRM_MGA is not set
# CONFIG_DRM_SIS is not set
If that doesn't help check your dri.log file, and post it here if you think it will help.
 
Old 08-18-2004, 08:11 PM   #43
shep fc3
LQ Newbie
 
Registered: Aug 2004
Posts: 16

Rep: Reputation: 0
Yeah, its compiled into the kernel
CONFIG_DRM=y
CONFIG_DRM_TDFX=m
CONFIG_DRM_GAMMA=m
CONFIG_DRM_R128=m
CONFIG_DRM_RADEON=m
CONFIG_DRM_I810=m
CONFIG_DRM_I830=m
CONFIG_DRM_MGA=m
CONFIG_DRM_SIS=m
 
Old 08-18-2004, 08:15 PM   #44
shep fc3
LQ Newbie
 
Registered: Aug 2004
Posts: 16

Rep: Reputation: 0
This is all that is in the DRI log
shep@debian-shep:~/dripkg$ cat dri.log
cc -o .o
cc: no input files
make: *** [.o] Error 1

Also, when I tried what janfy_fr suggested, it killed my x windows all together. I had to reinstall it. something about a mismatch version of ABI or something like that.
 
Old 08-18-2004, 08:42 PM   #45
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Original Poster
Rep: Reputation: 46
Humm.. It looks like maybe your snapshot was corrupted. The savage.bz2 file should be about 1.9M and the common.bz2 file is 1.08M. You should create 5 subdirectories and 4 files in the dripkg directory. Maybe you should try starting over.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
libGL is out of sync with DRI - no direct rendering ATI m9 cor67393 Slackware 5 08-21-2005 12:13 PM
Can't get DRI enabled with Savage/IX-MV Arttu Linux - Software 14 02-09-2005 02:36 AM
DRI not working on Savage Trurl Linux - Hardware 2 01-24-2005 09:22 PM
Question about DRI for S3 savage (twister) blubz Linux - Hardware 1 11-19-2004 10:20 AM
XFree86 DRI : glxinfo -> Direct rendering : No Muzzy Linux - Hardware 20 05-24-2004 07:03 AM


All times are GMT -5. The time now is 04:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration