LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-18-2006, 01:38 PM   #136
trademarka
LQ Newbie
 
Registered: Dec 2005
Distribution: SuSE 10
Posts: 10

Rep: Reputation: 0

ok, so i turned on DRM in .config
Quote:
CONFIG_DRM=y
CONFIG_DRM_TDFX=m
CONFIG_DRM_R128=m
CONFIG_DRM_RADEON=m
CONFIG_DRM_I810=m
CONFIG_DRM_I830=m
CONFIG_DRM_I915=m
CONFIG_DRM_MGA=m
CONFIG_DRM_SIS=m
CONFIG_DRM_VIA=m
then I did "make all"
after this the script ran fine and installed
i made the changes to the xorg.conf and modprobe.conf
and after i restarted X, it crashed...
here is what it said
Quote:
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 18 20:24:06 2006
(==) Using config file: "/etc/X11/xorg.conf"
[10e] 320 x 200, 70Hz
[111] 640 x 480, 60Hz, 72Hz, 75Hz, 85Hz
[114] 800 x 600, 60Hz, 72Hz, 75Hz, 85Hz
[117] 1024 x 768, 60Hz, 70Hz, 75Hz, 85Hz
[11a] 1280 x 1024, 60Hz, 75Hz
[11d] 640 x 400, 70Hz
[122] 1600 x 1200, 60Hz
[133] 320 x 240, 72Hz
[13c] 1400 x 1050, 60Hz, 75Hz
[143] 400 x 300, 72Hz
[153] 512 x 384, 70Hz
[173] 720 x 480, 75Hz
[17e] 720 x 576, 75Hz
(WW) SAVAGE(0): Failed to set up write-combining range (0x90000000,0x2000000)
(WW) SAVAGE(0): Failed to set up write-combining range (0x92000000,0x5000000)
Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXgetActiveScreen from module /usr/X11R6/lib/modules/extensions/libdri.a is unresolved!

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 4. Server aborting


Please consult the The X.Org Foundation support
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
ok, that sucked, didnt it?
after removing Load "dri" line from xorg.conf i at least got X to start, but how do I enable DRI???

Thanks
 
Old 02-19-2006, 03:09 AM   #137
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Original Poster
Rep: Reputation: 46
Make sure you have agpgart enabled. Before starting X run modprobe via-agp, that should load both via-agp and agpgart. Make sure you have correct permissions to access /dev/agpgart.

In xorg.conf

Section "DRI"
Mode 0666
EndSection

As of 2.6.14 the kernel has savage DRI support built in so as long as SUSE has it enabled you shouldn't have to do anything except possibly edit your xorg.conf file.

Last edited by /bin/bash; 02-19-2006 at 03:13 AM.
 
Old 02-23-2006, 06:16 PM   #138
ruebs
LQ Newbie
 
Registered: Feb 2006
Posts: 2

Rep: Reputation: 0
Hello everybody.
I have some problems left too.
I installed the drivers. there seems to be no prob till there. also, i have already modified my xorg.conf.
but where do i have to tell my ubuntu or x.org to load up the modules on startup since i have NO modprobe.conf or local.start on my system?? someone mentioned the etc/modprobe.d/aliases would be the same as the modprobe.conf but didn't write much more, and also i can't find it anymore.
BruceCadieux mentioned something about modprobing in the /etc/init.d/rc in Thread #39
but i have no clue how to put that at the end of rc...
I'm really greatfull for any help!

Thanks!
 
Old 02-27-2006, 06:49 AM   #139
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Original Poster
Rep: Reputation: 46
Quote:
BruceCadieux mentioned something about modprobing in the /etc/init.d/rc in Thread #39
but i have no clue how to put that at the end of rc...
su
nano /etc/init.d/rc
<PageDn> to end of file.
modprobe via-agp
<Ctrl>+x
y<Enter>
 
Old 02-27-2006, 04:00 PM   #140
ruebs
LQ Newbie
 
Registered: Feb 2006
Posts: 2

Rep: Reputation: 0
thanx /bin/bash.
found out that the etc/modules file loads these modules also on start up.
 
Old 04-19-2006, 08:14 PM   #141
rfuller
LQ Newbie
 
Registered: Jan 2006
Location: 3rd Rock from sol.
Distribution: Mainley fedora core ... and whatever other distro helps reduce my work load at the moment.
Posts: 16

Rep: Reputation: 0
0% of this works for me I have read and tried every single thing in this thread and on dri.freedesktop.org and their mailing lists and right now all I want is to get rid of this stuff. Does anyone have any idea how to reverse the changes and go back to stock I'm sick of searching through this stuff? X doesn't even work going to vesa and no dri! This thread literally destroyed X on my system and I don't want dri I just want X back. Reversal techniques please
 
Old 04-19-2006, 09:38 PM   #142
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Original Poster
Rep: Reputation: 46
Quote:
Originally Posted by rfuller
0% of this works for me I have read and tried every single thing in this thread and on dri.freedesktop.org and their mailing lists and right now all I want is to get rid of this stuff. Does anyone have any idea how to reverse the changes and go back to stock I'm sick of searching through this stuff? X doesn't even work going to vesa and no dri! This thread literally destroyed X on my system and I don't want dri I just want X back. Reversal techniques please
From Post #1
Quote:
# make install #Warning this will overwrite your current XFree86 installation. Make sure you know how to undo this if it fails. Also you must be root to run make install.
You didn't read post 1 very carefully. Also you should re-read Post #132. You don't have to do anything except build a new kernel >= 2.6.14 and select DRM and dri savage support.

Now, since you might be running Fedora? I would suggest:
rpm -qa|grep xorg
rpm -i --force <xorg packages>
 
Old 08-31-2006, 12:34 AM   #143
ruben
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
ok this may be and old thread but i am lost in all this info im new to linux and just want my games to work dri is disabled and i need some help like maybe on a few things if at all possible ill edit if anyone will help me.
 
Old 08-31-2006, 07:27 AM   #144
ruben
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
can someone plsz help with this im so confused on what to do and what not to do
 
Old 09-01-2006, 07:41 AM   #145
trademarka
LQ Newbie
 
Registered: Dec 2005
Distribution: SuSE 10
Posts: 10

Rep: Reputation: 0
first of all, what is your hardware and what distribution are you using?
the simplest way to solve the DRI problem is installing the latest version of your linux distribution, then all you'll have to do is modify your xorg.conf file...
 
Old 09-04-2006, 10:37 AM   #146
ruben
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
pro savage sucks get another card from newegg.com i recommend a geforce
for 62 dollars its a 256 mb video card with 16 great review so id say its worth the upgrade and also this driver is supported by suse without alot of trouble.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
libGL is out of sync with DRI - no direct rendering ATI m9 cor67393 Slackware 5 08-21-2005 01:13 PM
Can't get DRI enabled with Savage/IX-MV Arttu Linux - Software 14 02-09-2005 03:36 AM
DRI not working on Savage Trurl Linux - Hardware 2 01-24-2005 10:22 PM
Question about DRI for S3 savage (twister) blubz Linux - Hardware 1 11-19-2004 11:20 AM
XFree86 DRI : glxinfo -> Direct rendering : No Muzzy Linux - Hardware 20 05-24-2004 08:03 AM


All times are GMT -5. The time now is 04:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration