LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-05-2004, 12:32 PM   #1
Robert52
LQ Newbie
 
Registered: Feb 2004
Location: Scappoose OR
Distribution: Fedora Core 1, Mandrake 9.2, Windows BSOD, Windows GPF, Windows Fatal Exception.
Posts: 25

Rep: Reputation: 15
Diagonal lines = garbled display


I get video corruption: coarse diagonal lines from upper left to lower right, lines are wider than they are tall.

This happens when I try to RETURN my desktop to anything but 1280x1084 by clicking on little red hat, preferences, screen resolution. It used to work with a 1024x768 setting, but that isn't even in the box of options anymore. And Tux Racer, which sounds like a lot of fun has always had the same darn problem.

I have a very common video card, an ATI Radeon 9600se. It is 4x/8x compatable, with 128 megs of memory. and a 19 inch Envision monitor. Why, oh why can't the documentation be written simple enough for a new person to understand? New people are the lifeblood of Linux. Without new recruits, this will die out as just a quirky little toy.

Can anyone offer intelligent suggestions on how to fix the video corruption? It used to work, and I don't understand what changed to make it not work now. How else can I change my video resolution?

Please use small, simple words like "first" and "then" and leave out unexplained references to making configuration changes. I am honestly trying to leave microsoft, but I can't even establish basic functionality.

If I download the video driver from ATI, it comes in an .RPM format. What the heck do I do with it then? It might as well be written in Chineese.
 
Old 03-05-2004, 03:13 PM   #2
wapcaplet
Guru
 
Registered: Feb 2003
Location: Colorado Springs, CO
Distribution: Gentoo
Posts: 2,018

Rep: Reputation: 48
If it's what I'm thinking of (looks sort of like your display is being digitally scrambled), then I'm fairly sure it's a refresh problem. Your video drivers are probably okay; it's most likely your monitor configuration that needs to be tweaked.

First (you asked ), see if you can find the manual that came with your monitor. If you don't have it, you may be able to search for the model number on Google and turn up some specs. The things you want to know are "Horizontal sync" and "Vertical refresh", each of which should be a range such as "30 to 75 kilohertz" or "50 to 100 hertz", respectively.

Then, using a GUI tool to do the configuration or by editing your /etc/X11/XF86Config-4 file directly, enter those values in the "Monitor" section of the configuration. If you're using a GUI config tool, it ought to just ask you what the rates are; if you want to edit the config file directly, the lines will look something like this:

Code:
Section "Monitor"
  Identifier "Some monitor name"
  HorizSync 30-75
  VertRefresh 50-100
EndSection
Restart X, and the settings should take effect.

As for the ATI drivers, the .rpm file can be installed using a GUI installer (such as rpmdrake, if you're using Mandrake), or, in my opinion an easier way, just through the command-line using the 'rpm' tool. Open up a terminal window and type:

rpm -Uvh /path/to/the/ATIdriver.rpm

If all goes well, it'll do some stuff and when it's done you'll have the driver installed. You may want to check out any READMEs or other documentation provided by ATI, since they may have more explicit instructions on how to install it, and whether you need to do any other configuration.

Last edited by wapcaplet; 03-05-2004 at 03:17 PM.
 
Old 03-06-2004, 03:28 AM   #3
Robert52
LQ Newbie
 
Registered: Feb 2004
Location: Scappoose OR
Distribution: Fedora Core 1, Mandrake 9.2, Windows BSOD, Windows GPF, Windows Fatal Exception.
Posts: 25

Original Poster
Rep: Reputation: 15
Wapcaplet,

Excellent suggestion! Thank you. The text

[root@localhost Drivers]# rpm -Uvh fglrx-glc22-4.3.0-3.7.0.i386.rpm
Preparing... ########################################### [100%]
file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx-glc22-4.3.0-3.7.0 conflicts with file from package XFree86-Mesa-libGL-4.3.0-42
[root@localhost Drivers]#

appears after I entered the text you specified. I hate to ask for spoon-feeding, but can I just delete the file that is conflicting? Isn't it just a default kind of generic video driver?

Someday I will learn the meaning of those little letters after the minus (-Uvh) then I will be a MAN!

Thanks again.
Robert
 
Old 03-06-2004, 09:52 AM   #4
wapcaplet
Guru
 
Registered: Feb 2003
Location: Colorado Springs, CO
Distribution: Gentoo
Posts: 2,018

Rep: Reputation: 48
That conflict is fairly common with video drivers, since MesaGL provides some of the same driver support that the ATI driver does. Check out this README (search for the word 'conflict') to see what you can do. I'd recommend using their second suggestion - remove the MesaGL RPM first, then install your ATI driver RPM.

If you're curious what the -Uvh stuff does, read the RPM man page ('man rpm' from a terminal window). Briefly, the U means upgrade, the v means be verbose, and the h shows the installation progress using '#' marks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
display garbled (not corrupted) in linux console sessions Erik Garrison Linux - Hardware 1 10-24-2005 07:29 PM
printer printing vertical lines at beginning and end of lines makhand Linux - Hardware 0 09-02-2005 02:03 PM
nvidia display driver on 2.6 mouse sluggish, screen paint garbled jankom Linux - Hardware 5 03-12-2005 12:39 PM
installed fedora, display garbled after launching some apps elnomadkvn Linux - Newbie 7 04-09-2004 05:34 AM
XFree86 display = ugly orange lines on dell 1100 eipo Linux - Laptop and Netbook 1 02-20-2004 09:46 PM


All times are GMT -5. The time now is 07:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration