LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-09-2004, 07:32 PM   #1
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Rep: Reputation: 30
/dev/scd0 does not exist


After I installed my 2.6.1 kernel, my cd-rom/DVD drive didn't work. After much searching on Linuxquestions.org, I figured out what the problem was; I didn't have the hdc=ide-scsi being past to the kernel in the lilo.conf. After I did that, my system informed me that a new piece of hardware, scd0 was found and it was installed. Everything was fine then, the next day I started up my computer and I was back to square one agan. I am getting /dev/scd0 doesn't exist now. When I do lsmod, this is what I get:

Module Size Used by
ipv6 251456 8
agpgart 32940 0
nvidia 2077128 14
vfat 16384 0
fat 47648 1 vfat
sg 39832 0
lp 12192 0
parport 44648 1 lp
orinoco_cs 9224 1
orinoco 43660 1 orinoco_cs
hermes 9984 2 orinoco_cs,orinoco
ds 15876 7 orinoco_cs
yenta_socket 18176 1
pcmcia_core 72544 3 orinoco_cs,ds,yenta_socket
af_packet 22920 2
ide_scsi 16260 0
ide_cd 41476 0
cdrom 35744 1 ide_cd
rtc 14024 0


Here's my /etc/fstab:

/dev/hda5 / ext3 noatime 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 noatime 1 2
/dev/scd0 /mnt/cdrom auto user,iocharset=iso8859-1,ro,noauto 0 0
none /proc proc defaults 0 0
/dev/hda1 swap swap defaults 0 0

Please help.
 
Old 02-09-2004, 09:30 PM   #2
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
OK, a little update. I was playing around a little and a few things have changed. /dev/scd0 now exists, /dev/dvd now exists, and /dev/cdrom now exists.

lr-xr-xr-x 1 root root 13 Feb 9 20:48 cdrom -> cdroms/cdrom0
lr-xr-xr-x 1 root root 31 Feb 9 20:48 dvd -> scsi/host0/bus0/target0/lun0/cd
lr-xr-xr-x 1 root root 31 Feb 9 20:48 scd0 -> scsi/host0/bus0/target0/lun0/cd

Here is what the /dev/cdroms/cdrom0 says:

lr-xr-xr-x 1 root root 34 Dec 31 1969 cdrom0 -> ../scsi/host0/bus0/target0/lun0/cd

The good news is that when I use GMplayer and I go to open a dvd with the device /dev/dvd, everything is great and works fine. When I go to mount a regular disk I get the error:

mount: wrong fs type, bad option, bad superblock on /dev/scd0,
or too many mounted file systems

I wanted to see what would happen if there wasn't a disk in the drive and sure enough it said that no medium could be found. Does anyone have any ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cdrom /dev/scd0 laurentwahl Linux - Hardware 3 04-28-2005 12:00 PM
knoppix looks for CDROM in /dev/scd0 dongmin Linux - Newbie 1 05-22-2004 11:44 PM
HELP: /dev/scd0 is not a block device fysx Linux - Hardware 1 09-02-2003 11:51 PM
ide-scsi /dev/scd0 doesn't exist freenet Linux - Hardware 1 07-09-2003 06:39 PM
Help me sleep: MAKEDEV /dev/scd0- BBehemoth Linux - General 1 10-20-2002 12:59 AM


All times are GMT -5. The time now is 01:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration