LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-07-2008, 02:42 PM   #1
scanman
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Rep: Reputation: 0
Desperate with intel wireless 3945ABG


In brief I have fresh install of Suse 11 on laptop HP
The wireless Intel 3945ABG is working with public wifi networks but I can not connect to my password protected home network. All intentions to solve the problem can be seen on the following link.

it is not possible to post the url in first post, so I will post it as respond to this treat...

I will be very grateful if someone can help me with this issue.
 
Old 10-07-2008, 02:43 PM   #2
scanman
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
here all the saga can be seen:
http://forums.opensuse.org/network-i...suse-11-a.html
 
Old 10-07-2008, 06:16 PM   #3
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,067

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
First, as root do ifconfig. You'll see what name your WiFi adapter has. I suppose it is wlan0 or so.

Then do iwlist wlan0 scan
What do you see? Please paste the output here.

jlinkels
 
Old 10-08-2008, 01:38 AM   #4
scanman
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jlinkels View Post
First, as root do ifconfig. You'll see what name your WiFi adapter has. I suppose it is wlan0 or so.

Then do iwlist wlan0 scan
What do you see? Please paste the output here.

jlinkels
Code:
linux-5emn:/home/scanman # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1B:24:E1:19:8A
          inet addr:192.168.1.35  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::21b:24ff:fee1:198a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1336 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1355 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1078348 (1.0 Mb)  TX bytes:244925 (239.1 Kb)
          Interrupt:250 Base address:0x8000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4664 (4.5 Kb)  TX bytes:4664 (4.5 Kb)

wlan0     Link encap:Ethernet  HWaddr 00:1C:BF:57:A5:77
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wmaster0  Link encap:UNSPEC  HWaddr 00-1C-BF-57-A5-77-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

linux-5emn:/home/scanman # iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 00:1A:2B:02:E8:00
                    ESSID:"WLAN_FD"
                    Mode:Master
                    Channel:3
                    Frequency:2.422 GHz (Channel 3)
                    Quality=97/100  Signal level=-28 dBm  Noise level=-127 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000066dcabf0b7

linux-5emn:/home/scanman #
 
Old 10-08-2008, 05:32 AM   #5
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
I think it is the following.

iwconfig wlan0 key WEP_KEY
 
Old 10-08-2008, 06:11 AM   #6
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,067

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
If your wireless router happens to be a linksys, you must use a hex key in both the router and the PC. Use WEP encryption and specify the key for example as "12345abcde". The passphrase with normal characters will not work if your router is Linksys and you PC is not.

If you have a router which allows ASCII keys, issue the following command:
iwconfig wlan0 key s:mykey
or in case of a hex key like with Linksys:
iwconfig wlan0 key 12345abcde

Then:
iwconfig wlan0 essid WLAN_FD
and
dhclient wlan0

It might be that you have to enter these three commands (in that order!) once more.

If that fails as well, edit your interfaces file to reflect these settings (not sure where that file lives in Suse), and after booting restart you network. Again, unsure how to do that in Suse, but it should be something like:
/etc/rc.d/init.d/networking restart

The 3945 sometimes is a difficult beast to get to work.

jlinkels
 
Old 10-09-2008, 04:15 AM   #7
scanman
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
The modem is Comtrend
The security settings are:
Authentication = open
Wep encryption = enabled
Encryption strength = 128

the console returns:

Code:
linux-5emn:/home/scanman # iwconfig wlan0 key C221D203163FX
linux-5emn:/home/scanman # iwconfig wlan0 essid WLAN_FD
linux-5emn:/home/scanman # dhclient wlan0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:1c:bf:57:a5:77
Sending on   LPF/wlan0/00:1c:bf:57:a5:77
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 2
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
linux-5emn:/home/scanman #

Last edited by scanman; 10-09-2008 at 04:26 AM.
 
Old 10-09-2008, 06:05 AM   #8
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,067

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Have you tried to edit /etc/network/interfaces and restart the network? See the config below:

Code:
auto wlan0
iface wlan0 inet dhcp
pre-up ip link set wlan0 up
wireless-essid WaveLAN Network
wireless-key s:*****
wireless-mode Managed
wireless-ap any
The pre-up is claimed to improve matters. Maybe that is why the network sometimes has to be restarted, instead of issuing iwconfig commands.

The wireless-ap any sometimes helps, sometimes on the contrary.

You could try to rmmod iwl3945 and modprobe it again.

Did you try to disable encryption on your router and does it work then?

jlinkels
 
Old 10-11-2008, 01:31 AM   #9
scanman
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
This is what my console return. For to be honest I am not sure what exactly I have to do. I am completely newbie with linux. The only thing I can make is to run console under the su and to type the commands you tell me. Also I can install programs with yast if something is missing.

Quote:

You could try to rmmod iwl3945 and modprobe it again.
This means to me only to try to type mentioned commands.

I did try to switch off the encryption of the modem and also have tried to switch off all password protection and to connect only with MAC filtering but it was all the same result.


Code:
linux-5emn:/home/scanman # auto wlan0
bash: auto: command not found
linux-5emn:/home/scanman # iface wlan0 inet dhcp
bash: iface: command not found
linux-5emn:/home/scanman # wireless-essid Wavelan Network
bash: wireless-essid: command not found
linux-5emn:/home/scanman # rmmod iwl3945

linux-5emn:/home/scanman #
linux-5emn:/home/scanman # modprobe iwl3945
linux-5emn:/home/scanman #
 
  


Reply

Tags
wifi, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel Wireless 3945ABG Wireless NIC card not working after 8.04 clean install creature124 Linux - Hardware 4 05-03-2008 11:58 AM
Intel PRO Wireless 3945ABG: Help! LDJ Linux - Newbie 13 09-21-2007 05:21 AM
Fedora 7 and Intel wireless 3945ABG Jackes Linux - Hardware 9 08-26-2007 11:49 AM
Intel 3945ABG Wireless card smiffy848 Linux - Newbie 1 06-23-2007 10:21 AM
Problem - Intel Intel(R) PRO/Wireless 3945ABG suresheva31 Fedora 2 09-18-2006 07:45 PM


All times are GMT -5. The time now is 03:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration