LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   dell photo printer help (http://www.linuxquestions.org/questions/linux-hardware-18/dell-photo-printer-help-435801/)

rude_reality 04-16-2006 08:58 PM

dell photo printer help
 
Ok, I have been looking for this answer for the past few weeks. A friend of mine gave me an usb printer and I tried to install it on to my linux box ( Slackware 10.1), But can't get it to work. My dmesg states the following :

usb.c: registered new driver usblp
printer.c: usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x413C pid 0x5008
printer.c: v0.13: USB Printer Device Class driver

When I go to do a sample test like

echo "hello, world" > usblp0

and

echo "Hello, world" > usblp

no print out was produce. So I went to the /dev directory to see if there was and file name usblp, or usblp0. There was not. How I see it the linux see the printer, but don't know how to connect with it right? I see that a printer module was loaded to:

printer 7648 0 (unused)

oh hey, the printer is a dell photo printer 720

DragonM15 05-05-2006 06:03 PM

Hey man, I have the same printer... I am currently running Slackware 10.2, however I have the same problem.... except maybe a step back.... my dell printer is currently using port lp0 not usblp0 or anything like that. I did some digging and found out that this printer is basically a Lexmark z600 series in a different case pretty much. Lexmark has support for their printers. I tried installing it, but I get the output of

bash-3.1# sh z600cups*.gz.sh
Verifying archive integrity...OK
Uncompressing Lexmark Printer Drivertrap: usage: trap [-lp] [arg signal_spec ...]

and that is all. I did some more looking around, but have had more bad luck. However, I am still looking. I will post again if I find something. Lemme know if you figure something out on your end.

DragonM15

DragonM15 05-05-2006 06:06 PM

I dont know if you have tried this yet

http://downloads.lexmark.com/cgi-per...Redhat&target=

DragonM15 05-05-2006 06:19 PM

I also looked through here:
http://www.ubuntuforums.org/archive/...p/t-83456.html

It is ubuntu yes, but I followed it as closely as possible, and I got an error when I tried to install the RPM's. If I turn them into tgz's, there is NOTHING in the tgz.
this is my error... dependencies as usual:
Code:

bash-3.1# rpm -i z600llpddk*.rpm
error: Failed dependencies:
        /bin/sh is needed by z600llpddk-2.0-1
        libc.so.6 is needed by z600llpddk-2.0-1
        libc.so.6(GLIBC_2.0) is needed by z600llpddk-2.0-1
        libc.so.6(GLIBC_2.1.3) is needed by z600llpddk-2.0-1

And
Code:

bash-3.1# rpm -i z600cups*.rpm
error: Failed dependencies:
        z600llpddk >= 2.0-1 is needed by z600cups-1.0-1
        cups >= 1:1.1.15-10 is needed by z600cups-1.0-1
        /bin/sh is needed by z600cups-1.0-1

However, I have bin 10.2, and cups 1.1.23. And since I cant install llpddk, and I ahve GLIBC 2.3.5. I can upgrade to 2.3.6... should i?? Ideas anybody?


All times are GMT -5. The time now is 05:40 PM.