LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-22-2004, 06:04 AM   #1
cgtueno
Member
 
Registered: Jul 2003
Posts: 356
Blog Entries: 1

Rep: Reputation: 49
Dell Optiplex GX1 - Sound - Mandrake 10 Community


Hi Guys

I trying to setup sound on :
Dell Optiplex GX1 PIII 450 - Integrated sound adapter
under
Mandrake Linux 10 Community Edition

The machine worked ok under Red Hat Linux 8.0
when I ran sndconfig.

There is no version of sndconfig that I can find for MDK10c
I think that it implements ALSA

Harddrake does not list a sound adapter.

Could someone cast some light on how to get my
integrated sound adapter up and running under this disto ?

Regards

Chris

Last edited by cgtueno; 09-22-2004 at 06:08 AM.
 
Old 09-22-2004, 07:31 AM   #2
cgtueno
Member
 
Registered: Jul 2003
Posts: 356
Blog Entries: 1

Original Poster
Rep: Reputation: 49
Additional

I tried
System / Configuration/Configure your desktop
Sound
Sound System / Hardware / Autodetect

and I get the error:

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such file or directory)
The sound server will continue, using the null output device.

Sure enough there is no /dev/dsp directory.

I think that I installed mdk10c as a network client, rather
than a multimedia client (there are no multimedia tools
on the desktop). Would that make a diffrence ?

Chris
 
Old 09-22-2004, 07:49 PM   #3
cgtueno
Member
 
Registered: Jul 2003
Posts: 356
Blog Entries: 1

Original Poster
Rep: Reputation: 49
OK

I installed all the sound stuff from the disto CDs
sndconfig version 0.70 (Red Hat c2000) was one
of the updates.

Ran it.
Machine's hardware is a Crystal Audio 4236
(Integrated into motherboard).
Generated sound ok.

System/Configuration.KDE/sound/sound system
General
Enabled, Test Sound - Works ok

Hardware
Autodetect

Problem:

I'm tryng to run skype and Gnomemeeting.
Errors:
Gnomemeeting:
Edit/Configuration Druid...Test audio
Its trying to run full duplex (record & play)
Issues error message that it /dev/sound/dsp was opened ok
but could not read data from it.

It looks like I need a full duplex audio driver.
However, when I try
System/Configuration KDE/sound/sound system
Hardware
Autodetect
full duplex
Error: Error initializing the sound server,
can't start sound i/o,
and the output is redirected to null

Conclusions

I've tried the obvious.
This looks like I need a PCI soundcard that mdk10c can recognise
and for which it has a full duplex driver.
Rather than using the integrated sound adapter.

Qu#1 : Anyone have any helpful advice ?

QU #2 : Where could I find a list of pci sound cards
for which mdk10c has a full duplex sound driver
compatible with skype and Gnomemeeting ?

Regards

Chris
 
Old 12-01-2004, 05:15 AM   #4
cgtueno
Member
 
Registered: Jul 2003
Posts: 356
Blog Entries: 1

Original Poster
Rep: Reputation: 49
Hi Guys

I could still use some help with this problem !

Chris
 
Old 12-04-2004, 08:02 PM   #5
cgtueno
Member
 
Registered: Jul 2003
Posts: 356
Blog Entries: 1

Original Poster
Rep: Reputation: 49
Hi Guys

Solution:

Gave up on the embeded 4236 Sound adapter.
Ihad to try quite a few sound cards until I found a
PCI sound balster clone.

After that I got skype to work ok.

Regards

Chris
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Optiples GX1 sound and Xandros 3.0.2 wingl Linux - Hardware 4 08-30-2005 03:13 PM
no sound dell optiplex gx1 sarge gongli Debian 2 11-30-2004 09:46 PM
Free BSD on a Optiplex GX1?? tacoduck *BSD 5 11-26-2004 02:10 PM
Red Hat 9.0 Dell Optiplex GX1 Dual CDROM Sec IDE mas & slv - hdc not responding cgtueno Linux - Hardware 6 11-12-2004 01:20 AM
Dell OptiPlex GX1, Lilo, and my hdd tony98 Linux - Hardware 2 11-12-2004 12:52 AM


All times are GMT -5. The time now is 11:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration