LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-14-2007, 10:29 AM   #1
eewanco
LQ Newbie
 
Registered: Jun 2007
Location: Shrewsbury, MA
Distribution: Red Hat 9
Posts: 1

Rep: Reputation: 0
Unhappy Dell 2007FP: wavy/shimmering @1280x1024 & above


My 21" CRT blew the other day so I replaced it with an LCD monitor identical to one I had just gotten at work: A Dell 2007FP. It works fine on all the Windows machines, even at 1600x1200 60 Hz, but it doesn't work so hot on my Linux machine: I get a shimmering with wavy columns (1-2mm amplitude ) that is just unacceptable. I am told this is a symptom of the wrong refresh rate.

I am running an older system. The machine is 2003 vintage, with an Intel 845 (i810 driver) built-in video card. I am running Red Hat 9 (yes I realize this is old) running XFree86 (yes even older), but I tried the Mandriva Spring 2007 One Live disc and it has the same problem.

The problem happens for 1600x1200 @60 Hz and 1280x1024 @60Hz, but not any lower resolutions. I tried three different ModeLine values I picked up on the Internet (see comments). I tried Autoprobe too.

The Monitor section of my XFree86Config file is below.

Can anyone help me get this to work, or else recommend a large brand-name LCD monitor that will work with an older version of Linux?

Thanks for any help!

Eric

Quote:
Section "Monitor"

# 640x480@59.9 hsync: 31.5
Identifier "Monitor0"
VendorName "Dell"
ModelName "DELL 2007FP"
Option "dpms"
# Option "NoDDC"
HorizSync 30.0 - 83.0
# HorizSync 30.0 - 81.0
# VertRefresh 60.0
VertRefresh 56-76
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "640x480@75" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
ModeLine "800x600@60.3" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
ModeLine "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
ModeLine "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
ModeLine "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
# ModeLine "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
# Modeline "1600x1200_60.00" 160.96 1600 1704 1880 2160 1200 1201 1204 1242 -HSync +Vsync
ModeLine "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
EndSection

Last edited by eewanco; 06-19-2007 at 04:54 PM. Reason: Transposed model number
 
Old 06-15-2007, 03:27 AM   #2
mufy
Member
 
Registered: Oct 2004
Location: Kuwait
Distribution: Currently - AIX | Previously - RHEL 4 ES, FC 10
Posts: 206
Blog Entries: 4

Rep: Reputation: 30
Hi there,

If you'd installed your linux box with one type of monitor and then replaced it with another, this type of glitch is usually seen.

The other day when I installed RHEL3 WS on a DELL OptiPlex 745 with a Samsung SyncMaster 710V LCD monitor and later replaced it with a Compaq LCD, I got myself into a similar situation. I'd to connect the box back to the first monitor and lower the resolution. Apart from that, it'd be advisable to specify driver as Vesa in /etc/X11/XF86config file.

That's all I have on this, for now :-).
 
  


Reply

Tags
i810, lcd, monitor, xfree86


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem getting default resolution of 1280x1024 on dell 1907FP LCD sadik_anwar Ubuntu 1 09-05-2006 09:06 PM
Screen goes wavy when installing RH 9 hschnell Red Hat 1 04-09-2004 02:51 PM
shimmering console in 1024x768 mep]-[isto Slackware 13 12-14-2003 12:39 AM
shimmering in framebugger 1024x768 console mep]-[isto Linux - Newbie 5 12-13-2003 07:19 AM
blurryness/wavy look with computer php General 15 02-18-2003 12:26 AM


All times are GMT -5. The time now is 06:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration