LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-23-2011, 03:42 AM   #1
Kobussie
LQ Newbie
 
Registered: Feb 2006
Location: Limburg, NL
Distribution: Debian(Etch); Arch Linux, FreeBSD
Posts: 22

Rep: Reputation: 1
Debian squeeze soundcard problem


Hi!,

Yesterday I upgraded my Debian system from Lenny to Squeeze (kernel:2.6.32-5-686). Mayor problem: my extra soundcard. In Lenny I used "alsaconf" to switch soundcards; in Squeeze there's no more alsaconf.
Now I have to use pulseaudio... but i'm not familiar with that. http://www.pulseaudio.org gives me no clues.

I have an onboard soundchip and a M-Audio pci soundcard. The onboard sound is working allright, but I want to be able to switch to my M-Audio card. Pulseaudio only gives one device: the "alsa_output.pci-0000_00_11.5.analog-stereo": my onboard sound.

lspci:
Code:
...
00:0c.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)
...
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
...
from lsmod (grep snd):
Code:
snd_ice1724            72980  0 
snd_ak4114              5177  1 snd_ice1724
snd_pt2258              1992  1 snd_ice1724
snd_ice1712            41641  0 
snd_ice17xx_ak4xxx      1700  2 snd_ice1724,snd_ice1712
snd_via82xx            15256  1 
snd_ak4xxx_adda         5131  3 snd_ice1724,snd_ice1712,snd_ice17xx_ak4xxx
gameport                6061  1 snd_via82xx
snd_cs8427              4701  1 snd_ice1712
snd_i2c                 2594  4 snd_ice1724,snd_pt2258,snd_ice1712,snd_cs8427
snd_mpu401_uart         4067  2 snd_ice1712,snd_via82xx
snd_via82xx_modem       6292  0 
snd_ac97_codec         79148  4 snd_ice1724,snd_ice1712,snd_via82xx,snd_via82xx_modem
snd_seq_midi            3576  0 
snd_seq_midi_event      3684  1 snd_seq_midi
ac97_bus                 710  1 snd_ac97_codec
snd_pcm                47226  6 snd_ice1724,snd_ak4114,snd_ice1712,snd_via82xx,snd_via82xx_modem,snd_ac97_codec
snd_rawmidi            12513  3 snd_ice1724,snd_mpu401_uart,snd_seq_midi
snd_seq                35463  2 snd_seq_midi,snd_seq_midi_event
snd_timer              12258  2 snd_pcm,snd_seq
snd_seq_device          3673  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    34375  18 snd_ice1724,snd_ak4114,snd_pt2258,snd_ice1712,snd_via82xx,snd_ak4xxx_adda,snd_cs8427,snd_i2c,snd_mpu401_uart,snd_via82xx_modem,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc          5045  3 snd_via82xx,snd_via82xx_modem,snd_pcm
soundcore               3450  1 snd
And from dmesg I got this line:
Code:
[    7.624775] ICE1712: probe of 0000:00:0c.0 failed with error -16
 
Old 02-23-2011, 04:01 AM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,594

Rep: Reputation: 497Reputation: 497Reputation: 497Reputation: 497Reputation: 497
This may help you
http://forums.debian.net/viewtopic.php?f=6&t=55362

---------- Post added 02-23-11 at 02:01 AM ----------

This may help you
http://forums.debian.net/viewtopic.php?f=6&t=55362
 
Old 02-23-2011, 08:06 AM   #3
Kobussie
LQ Newbie
 
Registered: Feb 2006
Location: Limburg, NL
Distribution: Debian(Etch); Arch Linux, FreeBSD
Posts: 22

Original Poster
Rep: Reputation: 1
Thanks, I've read this before. but it didn't help me: I've the right modules. I think the problem is in pulseaudio.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Squeeze Grub2 Problem -> error: out of partition michalng Debian 4 01-09-2011 02:41 AM
[SOLVED] Wireless problem with Debian Squeeze ZebraIzToronto Debian 2 12-18-2010 03:06 PM
[SOLVED] Debian Squeeze Radeon 4650 AGP startup problem Mr Marmmalade Debian 7 12-05-2010 10:07 AM
[SOLVED] Problem getting mythweb to work in debian/squeeze garyg007 Linux - Software 6 08-26-2010 03:06 PM
[SOLVED] Radeon Xpress 200 problem on Debian squeeze (kernel 2.6.30) kaz2100 Debian 7 11-24-2009 06:16 AM


All times are GMT -5. The time now is 06:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration