LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 10-10-2007, 11:18 AM   #1
svancouw
LQ Newbie
 
Registered: Oct 2006
Location: California
Distribution: Debian Etch
Posts: 9

Rep: Reputation: 0
Debian - eth0 error: no such device on ifup eth0


I have an odd situation I was hoping you all could help me with. I had posted this to the wrong forum, where I discovered a noob error.

I have a vmware setup on a server I'm building, and during a shutdown process the system hung and I was forced to power it off. Now neither guest OS (both Debian) has /dev/eth0 or eth1 (board has two NICs) but the driver is loaded in the kernel (pcnet32). The device shows up correctly in dmesg and lsmod, nothing but "lo" shows in ifconfig, and when I try to bring it up using "ifup eth0" I get:

Code:
SIOCSIFADDR: No such device
eth0: ERROR while getting interface flags: No such device
SIOCSIFNETMASK: No such device
SIOCSIFBRDADDR: No such device
eth0: ERROR while getting interface flags: No such device
eth0: ERROR while getting interface flags: No such device
Failed to bring up eth0.
This happens even if I used rmmod and then insmod to reload the driver. I have only had to worry about drivers once before and I'm afraid I don't know what to do at this point.

Please let me know what you need and I'll get you the information as soon as possible. I don't have access to the system all day.

Thanks!
 
Old 10-11-2007, 09:17 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,805

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
Try using modprobe to load the module, instead of insmod. Insmod works well enough to load a module into the kernel, but it doesn't resolve module dependencies, which modprobe does. If the pcnet32 module has other modules it depends upon, modprobe will load them as well; insmod won't.
 
Old 10-11-2007, 11:59 PM   #3
svancouw
LQ Newbie
 
Registered: Oct 2006
Location: California
Distribution: Debian Etch
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for the reply. I had actually tried modprobe, which had seemed at the time to have no effect, but I will definitely keep that in mind for the next time I have a problem like this.

Turns out I figured out part of the problem late this morning. Turns out the eth0 device refuses to function, but the second nic eth1 does (found this by running, of all things, ifconfig -a. N00b mistake). I have no idea how the second nic showed up, as I only have one nic being shared with the vmware guest OS. I ended up signing up for their paid support.

I have two other OSs where they showed up as eth2. Still no explanation for that. It may be that whenever vmware assigns an interface it provides a fake (guessing here) MAC address. I saw the different MAC addresses somewhere in udev with the eht0 and eht1 names, but I cannot remember where that was now.

For now I'm using eth1 for internet, and I've found out how to make my server work entirely off of eth1 (including 3rd party software). I'll drop a note in here if/when I find out how to get eth0 working again. Sounds like it might require manually editing the vmware files for the guest.
 
Old 11-01-2010, 03:31 PM   #4
parleer
LQ Newbie
 
Registered: Nov 2010
Posts: 1

Rep: Reputation: 0
Your problem may be that udev is not allowing the eth0 device to be created because it is restricting the NIC to a certain MAC address. This was happening to me and I found the solution here:

ubuntuforums.org/showthread.php?t=255018
 
Old 09-07-2011, 05:32 PM   #5
hrodriguez231
LQ Newbie
 
Registered: Sep 2011
Posts: 1

Rep: Reputation: Disabled
Thumbs up thank you

Thank you very much parleer, the answer is in your URL.
Thank you again.

Quote:
Originally Posted by parleer View Post
Your problem may be that udev is not allowing the eth0 device to be created because it is restricting the NIC to a certain MAC address. This was happening to me and I found the solution here:

ubuntuforums.org/showthread.php?t=255018
 
  


Reply

Tags
networking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0: Device eth0 has different MAC address than expected,ignoring. lin1010 Linux - Networking 5 11-24-2010 08:30 AM
ifup eth0 causing error messages - SIOCGIFADDR: Cannot assign requested address pxumsgdxpcvjm Linux - Networking 7 01-20-2006 07:22 PM
ifup eth0 failed, failed to bring eth0 MKSrivastava Debian 1 12-07-2005 11:35 AM
ifup eth0 fails.... esi-eric Linux - Hardware 4 07-23-2004 01:11 PM
eth0 ifup warmongr Linux - Networking 2 04-29-2004 05:00 PM


All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration